Subject: Re: [v6ops] New draft: draft-matthews-v6ops-design-guidelines-00.txt

From: Philip Matthews <[email-masked]>
Date: Tue, 3 Jul 2012 15:26:43 -0400

Thanks!
If the working group decided to take this effort up, then my instinct is telling me that the best we will be able to do for most questions is simply list pros and cons.  There will probably be a few questions where we can agree that "this is best practice", but I suspect those will be few. So all I really want to do is capture people's thoughts/opinions for or against each option for a question, so that someone else can read them and make up his/her own mind.

As well as my own thoughts, I spent some time searching mailing lists and presentations, trying to find arguments for or against a choice. But I am sure I have missed things for my existing questions   (not to mention the areas I have not even covered yet). I did see the (quite good and helpful) slide presentation that you and others have been presenting at various *NOG meetings recently and took some arguments from there.  However, since I was only reading slides, I didn't get the arguments behind some of the statements made there. If have additional arguments for or against a choice, I would love to hear it.

- Philip

On 2012-06-29, at 20:38 , Randy Bush wrote:

>>> A new version of I-D, draft-matthews-v6ops-design-guidelines-00.txt
>>> has been successfully submitted by Philip Matthews and posted to the
>>> IETF repository.
>>> 
>>> Filename:	 draft-matthews-v6ops-design-guidelines
>>> Revision:	 00
>>> Title:		 Design Guidelines for IPv6 Networks
>>> Creation date:	 2012-06-29
>>> WG ID:		 Individual Submission
>>> Number of pages: 10
>>> URL:             http://www.ietf.org/internet-drafts/draft-matthews-v6ops-design-guidelines-00.txt
>>> Status:          http://datatracker.ietf.org/doc/draft-matthews-v6ops-design-guidelines
>>> Htmlized:        http://tools.ietf.org/html/draft-matthews-v6ops-design-guidelines-00
> 
> i read this document prepared to laugh and/or puke.  i was pleasantly
> surprised.  this is generally quite good advice without getting
> religious, and a darned good start.  congrats!
> 
> randy
>

---

From: Philip Matthews <[email-masked]>
Date: Tue, 3 Jul 2012 15:41:18 -0400

Thanks.  I also have not come up with anything yet for OSPFv3.

One thing I am thinking of covering in a future revision was the "I am currently running IGP X for IPv4, should I run IGP Y for IPv6?" question. (Note: I want to do this WITHOUT covering the "which is better: OSPF or ISIS?" question, because that question is not specific to IPv6).   

- Philip

On 2012-06-29, at 21:20 , Tina TSOU wrote:

> 8.  OSPF
> 
>   (TBD)
> 
> I used basic OSPFv3 functionalities in IPv6 at my enterprise. Nothing special was found.
> 
> Tina
> @ 2001:db8:1:ffff:e8e2:7822:9d12:e12e
> 
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf Of
>> Randy Bush
>> Sent: Friday, June 29, 2012 5:39 PM
>> To: Philip Matthews
>> Cc: IETF v6ops list
>> Subject: Re: [v6ops] New draft: draft-matthews-v6ops-design-guidelines-
>> 00.txt
>> 
>> _______________________________________________
>> v6ops mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Randy Bush <[email-masked]>
Date: Wed, 04 Jul 2012 05:20:10 +0900

> Thanks.  I also have not come up with anything yet for OSPFv3.

is-is

---

From: KK <[email-masked]>
Date: Fri, 27 Jul 2012 14:21:56 -0700

Hi Philip,

Overall, I think this is useful guidance.

A few comments/questions:

Section 1.
draft-chkpvc-enterprise-incremental-ipv6 (work in progress) aims to
provide guidance for enterprises on their IPv6 deployments. You may
want to consider adding this as a reference as well.

Section 3.1.
I am not sure if I am reading this correctly...

>An advantage of option (b) is there is only half as many layer 3 interfaces, which can help with scaling.  If physical links are used, then there is also a capex advantage.

Doesn't using option (b) actually use twice as many layer 3
interfaces? In which case, I am not sure I understand how this would
be a capex advantage?

It almost seems that your description of advantages for the two
options have been swapped around, i.e. the advantage of option (b) is
that you get separate measurements for IPv4 and IPv6, while option (a)
gets you scaling and capex advantages.

Section 3.2.
draft-behringer-lla-only (work in progress) talks about using
link-local addresses where possible. You may want to consider adding
that as a reference.

Regards,
KK

On Fri, Jun 29, 2012 at 11:14 AM, Philip Matthews
<[email-masked]> wrote:
> (Looks like my first attempt didn't make it for some reason, so I am
> resending. My apologies if you receive two copies.)
>
> I have submitted a draft entitled "Design Guidelines for IPv6 Networks". The
> intent is to present some of the common design choices that come up when
> designing IPv6 networks, and document the pros and cons of the various
> possible solutions. These are questions like "Should I do eBGP peering with
> globals or link-locals?" that come up from time-to-time on mailing lists or
> *NOG presentations. The goal is to document them in one place, give fairly
> thorough discussion, and present a best-practice (if we can come to some
> agreement).
>
> The document is looking at both IPv6-only networks and mixed IPv4/IPv6
> networks.  That is, a number of questions have to do with how IPv4 and IPv6
> should or should not be mixed in a network.
>
> The current version is very much a work-in-progress, with content in some
> areas, but TBDs in other areas.  Currently, I have put in content around
> point-to-point links, static routing, and eBGP routing.
>
> I have gotten some interesting feedback on a preliminary version from a
> couple of people, but want to see what others say before doing more work on
> the document.
>
> I would be interested in hearing comment on both the general idea of the
> document, as well as comments on the current discussion areas and new
> discussion areas.
>
> - Philip
>
> Begin forwarded message:
>
> From: [email-masked]
> Date: June 29, 2012 9:46:43 EDT
> To: [email-masked]
> Subject: New Version Notification for
> draft-matthews-v6ops-design-guidelines-00.txt
>
>
> URL:
> http://www.ietf.org/internet-drafts/draft-matthews-v6ops-design-guidelines-00.txt
> Status:
> http://datatracker.ietf.org/doc/draft-matthews-v6ops-design-guidelines
> Htmlized:
> http://tools.ietf.org/html/draft-matthews-v6ops-design-guidelines-00
>
>
> Abstract:
>   This document presents advice on the design choices that arise when
>   designing IPv6 networks (both dual-stack and IPv6-only).  The
>   intended audience is someone designing an IPv6 network who is
>   knowledgeable about best current practices around IPv4 network
>   design, and wishes to learn the corresponding practices for IPv6.
>
>
>
>
> The IETF Secretariat
>
>
>
>

---

From: Philip Matthews <[email-masked]>
Date: Sat, 28 Jul 2012 21:38:14 -0400

> Overall, I think this is useful guidance.

Thanks very much for your comments.

> want to consider adding this as a reference as well.

I have not seen this draft. I'll take a look at it.
The list of references in the draft are still very much a work-in-progress.

> gets you scaling and capex advantages.

Yup.  Indeed, they got swapped.
I guess I need to proofread more carefully next time! :-)

> link-local addresses where possible. You may want to consider adding

That draft is the draft that I meant when I wrote
    "For more discussion on these points see [recent I-D]".
I haven't seen an updated version of this draft yet, so I am not sure what is happening with it.