Subject: [v6ops] "RE: goals of draft-zhang-v6ops-ipv6oa-iwf-00.txt "

From: [email-masked]
Date: Tue, 24 Jul 2012 15:46:16 +0800

Hi,

I have throughly read this draft and the discussions on the mailing list,
the previous questions from fred and J.S help my understanding about this 
draft, 
and this solution seems more economical which just need updates the 
version of 
the ATM nodes than buying extra equipments to replace the located ATM 
nodes or ATM network； 

But here I have a comment: 

    1) You said the "Interworking Function" is a layer 2 node, but in 
section 4.2,what the IPv6oA IWF do seems like a 
        layer 3 node because this node has to deal with IP address. What 
do you think ? 

Thanks~
Cui Wang

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.

---

From: Jiexin Zhang <[email-masked]>
Date: Wed, 25 Jul 2012 09:40:40 +0800

2012/7/25, Jiexin Zhang <[email-masked]>:
> Thanks for the comments from Miss Wang.  Actually，I think IWF means it
can perform both layer2 and IP function. Therefore, IWF can be
performed in a layer 2 node, such as an ATM switch, which works like
the IPv4oA IWF in ATM switch usually.  And it can also be performed
in a layer 3 node, BRAS as an example. In this draft, we just defined
IWF is in a layer 2 node.
~~JX
>
> 2012/7/24, [email-masked] <[email-masked]>:
>> Hi,
>>
>> ZTE Information Security Notice: The information contained in this mail
>> (and
>> any attachment transmitted herewith) is privileged and confidential and
>> is
>> intended for the exclusive use of the addressee(s).  If you are not an
>> intended recipient, any disclosure, reproduction, distribution or other
>> dissemination or use of the information contained is strictly prohibited.
>> If you have received this mail in error, please delete it and notify us
>> immediately.
>>
>>
>

---

From: "Will Liu (Shucheng)" <[email-masked]>
Date: Wed, 25 Jul 2012 03:52:34 +0000

Let me add one point. In fact the IPv6oA interworking is sort of an ND and IND proxy. It makes changes to ND and IND messages. However, it does not initiate the ND message. More details were written in the last but two paragraphs in chapter 4.2.

“When IPv6oA IWF sends Inverse Neighbor Discovery Message, it can
        change the Neighbor Solicitation Message from BNG to Inverse Neighbor
        Discovery Solicitation message or change the Inverse Neighbor
        Discovery Advertisements message from CPE to Neighbor Advertisements
        message since IND protocol is just the extension to the IPv6 Neighbor
        Discovery.”

Did this answer the question, or do you have other questions regarding the responsibilities of IWF?

Regards,
Will

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Jiexin Zhang
> Sent: Wednesday, July 25, 2012 9:41 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [v6ops] "RE: goals of draft-zhang-v6ops-ipv6oa-iwf-00.txt "
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Jiexin Zhang <[email-masked]>
Date: Wed, 25 Jul 2012 08:54:37 +0800

2012/7/24, [email-masked] <[email-masked]>:
> ZTE Information Security Notice: The information contained in this mail (and
> any attachment transmitted herewith) is privileged and confidential and is