Subject: [v6ops] draft-ietf-v6ops-wireline-incremental-ipv6 to Informational

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 11 Jul 2012 17:20:54 +0000

(1) What type of RFC is being requested (BCP, Proposed Standard, Internet Standard, Informational, Experimental, or Historic)? Why is this the proper type of RFC? Is this type of RFC indicated in the title page header?

This document is recommended as "informational"; it is essentially a white paper describing a phased approach to operational deployment of IPv6.

(2) The IESG approval announcement includes a Document Announcement Write-Up. Please provide such a Document Announcement Write-Up. Recent examples can be found in the "Action" announcements for approved documents. The approval announcement contains the following sections:

Technical Summary

   Operators worldwide are in various stages of preparing for, or
   deploying IPv6 into their networks.  The operators often face
   difficult challenges related to both IPv6 introduction along with
   those related to IPv4 run out.  Operators will need to meet the
   simultaneous needs of IPv6 connectivity and continue support for IPv4
   connectivity for legacy devices with a stagnant supply of IPv4
   addresses.  The IPv6 transition will take most networks from an IPv4-
   only environment to an IPv6 dominant environment with long transition
   period varying by operator.  This document helps provide a framework
   for wireline providers who are faced with the challenges of
   introducing IPv6 along with meeting the legacy needs of IPv4
   connectivity utilizing well defined and commercially available IPv6
   transition technologies.

Working Group Summary

The working group process was pretty straightforward. To the shepherd's knowledge, while every operator has not taken (or considered) taking every step laid out, there is no dissent regarding the approach. What the framework lays out is what steps make sense at the various decision points and how they should be thought through.

Document Quality

The framework is well written and has stood up under review.

Personnel

Who is the Document Shepherd? Who is the Responsible Area Director?

The Document Shepherd is Fred Baker. The Responsible AD is Ron Bonica.

(3) Briefly describe the review of this document that was performed by the Document Shepherd. If this version of the document is not ready for publication, please explain why the document is being forwarded to the IESG.

The shepherd read the initial document, followed the working group discussion and spoke with the authors privately, and read the ultimate outcome. The document is clear and understandable.

(4) Does the document Shepherd have any concerns about the depth or breadth of the reviews that have been performed?

No. The acknowledgements section notes a number of people who have commented or contributed text.

(5) Do portions of the document need review from a particular or from broader perspective, e.g., security, operational complexity, AAA, DNS, DHCP, XML, or internationalization? If so, describe the review that took place.

This is not, in my view, required. The document contains no formal language, and imposes no protocol specifics.

(6) Describe any specific concerns or issues that the Document Shepherd has with this document that the Responsible Area Director and/or the IESG should be aware of? For example, perhaps he or she is uncomfortable with certain parts of the document, or has concerns whether there really is a need for it. In any event, if the WG has discussed those issues and has indicated that it still wishes to advance the document, detail those concerns here.

The shepherd is comfortable with the document, and working group discussion has not surfaced remaining issues.

(7) Has each author confirmed that any and all appropriate IPR disclosures required for full conformance with the provisions of BCP 78 and BCP 79 have already been filed. If not, explain why.

Yes.

(8) Has an IPR disclosure been filed that references this document? If so, summarize any WG discussion and conclusion regarding the IPR disclosures.

Not to my knowledge.

(9) How solid is the WG consensus behind this document? Does it represent the strong concurrence of a few individuals, with others being silent, or does the WG as a whole understand and agree with it?

As noted in the acknowledgements, working group discussion was robust and broad. I would describe this as having broad consensus.

(10) Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarise the areas of conflict in separate email messages to the Responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.)

No.

(11) Identify any ID nits the Document Shepherd has found in this document. (See http://www.ietf.org/tools/idnits/ and the Internet-Drafts Checklist). Boilerplate checks are not enough; this check needs to be thorough.

I found no nits.

(12) Describe how the document meets any required formal review criteria, such as the MIB Doctor, media type, and URI type reviews.

N/A

(13) Have all references within this document been identified as either normative or informative?

The references are list as normative and informative.

(14) Are there normative references to documents that are not ready for advancement or are otherwise in an unclear state? If such normative references exist, what is the plan for their completion?

There are no such references.

(15) Are there downward normative references references (see RFC 3967)? If so, list these downward references to support the Area Director in the Last Call procedure.

An informational document cannot have downward references.

(16) Will publication of this document change the status of any existing RFCs? Are those RFCs listed on the title page header, listed in the abstract, and discussed in the introduction? If the RFCs are not listed in the Abstract and Introduction, explain why, and point to the part of the document where the relationship of this document to the other RFCs is discussed. If this information is not in the document, explain why the WG considers it unnecessary.

This document uses other RFCs, but does not update them.

(17) Describe the Document Shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all protocol extensions that the document makes are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that newly created IANA registries include a detailed specification of the initial contents for the registry, that allocations procedures for future registrations are defined, and a reasonable name for the new registry has been suggested (see RFC 5226).

The document doesn't depend on IANA registries or create new ones.

(18) List any new IANA registries that require Expert Review for future allocations. Provide any public guidance that the IESG would find useful in selecting the IANA Experts for these new registries.

N/A

(19) Describe reviews and automated checks performed by the Document Shepherd to validate sections of the document written in a formal language, such as XML code, BNF rules, MIB definitions, etc.

N/A

---

From: Tina TSOU <[email-masked]>
Date: Thu, 19 Jul 2012 06:22:17 +0000

The document is a good guide for anyone preparing to deploy IPv6 in their networks. It describes the transition methods, highlighting its pros and cons. However, in the discussion of NAT64 analysis, it is mentioned ipv6 only clients and hosts to IPv4 servers. In my opinion, the reverse case, IPv4 only host and IPv6 server can be included. Though this possibility is less, I guess when all details of the other transition technologies are discussed, it would be good to add this. In the discussion of Phase 0: Foundation: Tools and Management, the requirement of the monitoring tools to be updated with IPv6 capable and both IPv4/IPv6 simultaneously can be included in the discussion. In the phase 1: tunneled IPv6, 6rd is discussed very well. In my opinion, there can be a brief discussion of various ways of tunneling: ( ISATAP, manual, 6to4, GRE,) or just a reference to which draft should be referred to for further information about these tunneling options. Moreover, it is mentioned not all applications will be efficiently delivered in the tunneling approach, as the MTU reduces. Few examples of the applications that are less affected by tunneling and applications that should not be tunneled  would be helpful. The rest of the document is very well illustrated and documented.

Tina

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Fred Baker (fred)
> Sent: Wednesday, July 11, 2012 10:21 AM
> To: Ron Bonica
> Cc: [email-masked]; IPv6 Ops
> WG
> Subject: [v6ops] draft-ietf-v6ops-wireline-incremental-ipv6 to
> Informational
> 
> 
> (1) What type of RFC is being requested (BCP, Proposed Standard,
> Internet Standard, Informational, Experimental, or Historic)? Why is
> this the proper type of RFC? Is this type of RFC indicated in the title
> page header?
> 
> This document is recommended as "informational"; it is essentially a
> white paper describing a phased approach to operational deployment of
> IPv6.
> 
> (2) The IESG approval announcement includes a Document Announcement
> Write-Up. Please provide such a Document Announcement Write-Up. Recent
> examples can be found in the "Action" announcements for approved
> documents. The approval announcement contains the following sections:
> 
> Technical Summary
> 
> The working group process was pretty straightforward. To the shepherd's
> knowledge, while every operator has not taken (or considered) taking
> every step laid out, there is no dissent regarding the approach. What
> the framework lays out is what steps make sense at the various decision
> points and how they should be thought through.
> 
> Document Quality
> 
> (3) Briefly describe the review of this document that was performed by
> the Document Shepherd. If this version of the document is not ready for
> publication, please explain why the document is being forwarded to the
> IESG.
> 
> The shepherd read the initial document, followed the working group
> discussion and spoke with the authors privately, and read the ultimate
> outcome. The document is clear and understandable.
> 
> (4) Does the document Shepherd have any concerns about the depth or
> breadth of the reviews that have been performed?
> 
> (5) Do portions of the document need review from a particular or from
> broader perspective, e.g., security, operational complexity, AAA, DNS,
> DHCP, XML, or internationalization? If so, describe the review that
> took place.
> 
> This is not, in my view, required. The document contains no formal
> language, and imposes no protocol specifics.
> 
> (6) Describe any specific concerns or issues that the Document Shepherd
> has with this document that the Responsible Area Director and/or the
> IESG should be aware of? For example, perhaps he or she is
> uncomfortable with certain parts of the document, or has concerns
> whether there really is a need for it. In any event, if the WG has
> discussed those issues and has indicated that it still wishes to
> advance the document, detail those concerns here.
> 
> The shepherd is comfortable with the document, and working group
> discussion has not surfaced remaining issues.
> 
> (7) Has each author confirmed that any and all appropriate IPR
> disclosures required for full conformance with the provisions of BCP 78
> and BCP 79 have already been filed. If not, explain why.
> 
> Yes.
> 
> (8) Has an IPR disclosure been filed that references this document? If
> so, summarize any WG discussion and conclusion regarding the IPR
> disclosures.
> 
> Not to my knowledge.
> 
> (9) How solid is the WG consensus behind this document? Does it
> represent the strong concurrence of a few individuals, with others
> being silent, or does the WG as a whole understand and agree with it?
> 
> As noted in the acknowledgements, working group discussion was robust
> and broad. I would describe this as having broad consensus.
> 
> (10) Has anyone threatened an appeal or otherwise indicated extreme
> discontent? If so, please summarise the areas of conflict in separate
> email messages to the Responsible Area Director. (It should be in a
> separate email because this questionnaire is publicly available.)
> 
> No.
> 
> (11) Identify any ID nits the Document Shepherd has found in this
> document. (See http://www.ietf.org/tools/idnits/ and the Internet-
> Drafts Checklist). Boilerplate checks are not enough; this check needs
> to be thorough.
> 
> I found no nits.
> 
> (12) Describe how the document meets any required formal review
> criteria, such as the MIB Doctor, media type, and URI type reviews.
> 
> N/A
> 
> (14) Are there normative references to documents that are not ready for
> advancement or are otherwise in an unclear state? If such normative
> references exist, what is the plan for their completion?
> 
> (15) Are there downward normative references references (see RFC 3967)?
> If so, list these downward references to support the Area Director in
> the Last Call procedure.
> 
> (16) Will publication of this document change the status of any
> existing RFCs? Are those RFCs listed on the title page header, listed
> in the abstract, and discussed in the introduction? If the RFCs are not
> listed in the Abstract and Introduction, explain why, and point to the
> part of the document where the relationship of this document to the
> other RFCs is discussed. If this information is not in the document,
> explain why the WG considers it unnecessary.
> 
> (17) Describe the Document Shepherd's review of the IANA considerations
> section, especially with regard to its consistency with the body of the
> document. Confirm that all protocol extensions that the document makes
> are associated with the appropriate reservations in IANA registries.
> Confirm that any referenced IANA registries have been clearly
> identified. Confirm that newly created IANA registries include a
> detailed specification of the initial contents for the registry, that
> allocations procedures for future registrations are defined, and a
> reasonable name for the new registry has been suggested (see RFC 5226).
> 
> (18) List any new IANA registries that require Expert Review for future
> allocations. Provide any public guidance that the IESG would find
> useful in selecting the IANA Experts for these new registries.
> 
> N/A
> 
> (19) Describe reviews and automated checks performed by the Document
> Shepherd to validate sections of the document written in a formal
> language, such as XML code, BNF rules, MIB definitions, etc.
> 
> N/A
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops