Subject: [v6ops] Answers to the on-site questions for draft-zhang-v6ops-ipv6oa-iwf-00.txt

From: "Will Liu (Shucheng)" <[email-masked]>
Date: Tue, 7 Aug 2012 06:33:01 +0000

Hi,

I am sending the answers to those questions I didn't answered during my presentation of draft-zhang-v6ops-ipv6oa-iwf-00.txt. Please see below.

[17:29:04] <joel jaeggli> fred - question - internet architecturel has a defined internetworking function - which you didn't use.
A: Fred, I am really sorry I am not sure which internetworking function you were refering to. Could you please reply with the specific one? Thanks.

[17:29:43] <joel jaeggli> wes george - where did you find a slam that does atm but speaks ipv6
A: I said "the scenario here is come from from china telecom" at the meeting.

[17:31:26] <joel jaeggli> lorenzo - a large number of these devices are doing ipoe which doesn't support v6. I think you might be willing to replace the bng and do you want.
A: IWF on BNG is a alternative solution, which we might think about to add into our draft. However, the scenario here is like this, "CPE--(1)--AN--(2)--BNG". Network (2) is ethernet based ipv6 network in current deployment. That's why we are suggesting to do this on AN. 

Regards,
Will

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 7 Aug 2012 15:51:10 +0000

> A: Fred, I am really sorry I am not sure which internetworking function you were refering to. Could you please reply with the specific one? Thanks.

As I noted to Zveno Chen, First, I owe you an apology. I was unnecessarily rough with you Friday, and that was inappropriate of me.

The defined interworking function between any two link layer networks, in the IP architecture, is an IP router, also historically called a "gateway".

> A: IWF on BNG is a alternative solution, which we might think about to add into our draft. However, the scenario here is like this, "CPE--(1)--AN--(2)--BNG". Network (2) is ethernet based ipv6 netw…

Where you have drawn:

4.1.  A general topology for IPv4 and IPv6 networks
                                           ----------
                                         ///          \\\
    +------+ IPv6 over +-------------+ //                \\ +----------+
    |      | ATM       |             ||                    ||          |
    | CPE  +-----------+  IPv6oA IWF |    Ethernet base     |   BNG    |
    |      |           |             |    IPv6 network      |          |
    +------+           +-------------+|                    |+----------+
                                       \\                //
                                         \\\          ///
                                            ----------

I would expect to see

                                        ----------
                    +-------------+   ///          \\\
 +------+ IPv6 over |   IP Router | //                \\ +----------+
 |      | ATM       +-----+-------+|                    ||          |
 | CPE  +-----------+ATM  |  802.3+    Ethernet base     |   BNG    |
 |      |           +-----+-------+    IPv6 network      |          |
 +------+                          |                    |+----------+
                                    \\                //
                                      \\\          ///
                                         ----------

This type of structure is very common, although ATM is in less use than it was before.