Subject: Re: [v6ops] New draft: draft-matthews-v6ops-design-guidelines-00.txt

From: Victor Kuarsingh <[email-masked]>
Date: Wed, 01 Aug 2012 13:34:04 -0700

Philip,

In general, I like the concept of this document and it appears to be quite
objective.  

Not to try and bloat the size/subject areas of the document, but should we
add a section which discusses the basics of operating IPv6 in BGP/MPLS IP
VPNs?

There are some things to be aware of - such as with 6VPE, Multi Protocol BGP
etc.  One may also still need to consider 6PE.

Additionally, I saw some comments noting OSPFv3 and IS-IS.  Would a document
like this try and provide a contrast between these two protocols or just
talk to each of the without specific guidelines as to when each may or may
not be useful? (some network operators may want to consider first which to
use, then how to use the respective protocol).  Again, I am not saying you
should put this contrast/compare in, as wondering if you had planned to.

My opinion on this is that we may not need to since exposing the reader to
both, they can then compare/contrast them on their own.

Regards,

Victor K

Begin forwarded message:

> From: [email-masked]
> Date: June 29, 2012 9:46:43  EDT
> To: [email-masked]
> Subject: New Version Notification for
> draft-matthews-v6ops-design-guidelines-00.txt
> 
> 
> A new version of I-D, draft-matthews-v6ops-design-guidelines-00.txt
> has been successfully submitted by Philip Matthews and posted to the
> IETF repository.
> 
> Filename:  draft-matthews-v6ops-design-guidelines
> Revision:  00
> Title:  Design Guidelines for IPv6 Networks
> Creation date:  2012-06-29
> WG ID:  Individual Submission
> Number of pages: 10
> URL:             
> http://www.ietf.org/internet-drafts/draft-matthews-v6ops-design-guidelines-00.
> txt
> Status:          
> http://datatracker.ietf.org/doc/draft-matthews-v6ops-design-guidelines
> Htmlized:        
> http://tools.ietf.org/html/draft-matthews-v6ops-design-guidelines-00
> 
> 
> Abstract:
>    This document presents advice on the design choices that arise when
>    designing IPv6 networks (both dual-stack and IPv6-only).  The
>    intended audience is someone designing an IPv6 network who is
>    knowledgeable about best current practices around IPv4 network
>    design, and wishes to learn the corresponding practices for IPv6.
> 
> 
> 
> 
> The IETF Secretariat
> 

_______________________________________________ v6ops mailing list
[email-masked] https://www.ietf.org/mailman/listinfo/v6ops

---

From: Philip Matthews <[email-masked]>
Date: Thu, 2 Aug 2012 13:40:52 -0700

Victor:
As we discussed face-to-face ...
Yes, I think that 6PE, 6VPE, and iBGP would all fall within what I see as the scope of the draft. I also think a discussion of what IGP to use for IPv6 would also fall within the scope of the draft. However, I have not yet figured out what to say in these areas. I would like to keep the draft to crisply-worded questions with a solid list of pros and cons, and I haven't yet quite figured out what these would be for the areas you mentioned.
- Philip

On 2012-08-01, at 13:34 , Victor Kuarsingh wrote:

> Philip,
> 
> In general, I like the concept of this document and it appears to be quite objective.  
> 
> Not to try and bloat the size/subject areas of the document, but should we add a section which discusses the basics of operating IPv6 in BGP/MPLS IP VPNs?
> 
> There are some things to be aware of - such as with 6VPE, Multi Protocol BGP etc.  One may also still need to consider 6PE.
> 
> Additionally, I saw some comments noting OSPFv3 and IS-IS.  Would a document like this try and provide a contrast between these two protocols or just talk to each of the without specific guidelines as to when each may or may not be useful? (some network operators may want to consider first which to use, then how to use the respective protocol).  Again, I am not saying you should put this contrast/compare in, as wondering if you had planned to.
> 
> My opinion on this is that we may not need to since exposing the reader to both, they can then compare/contrast them on their own.
> 
> Regards,
> 
> Victor K
> 
> 
> 
> Begin forwarded message:
> 
>> Subject: New Version Notification for draft-matthews-v6ops-design-guidelines-00.txt
>> 
>> 
>> URL:             http://www.ietf.org/internet-drafts/draft-matthews-v6ops-design-guidelines-00.txt
>> Status:          http://datatracker.ietf.org/doc/draft-matthews-v6ops-design-guidelines
>> Htmlized:        http://tools.ietf.org/html/draft-matthews-v6ops-design-guidelines-00
>> 
>> 
>> Abstract:
> _______________________________________________ v6ops mailing list [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops