Subject: [v6ops] draft-rafiee-cga-tsig-00 - request for comments

From: "Rafiee, Hosnieh" <[email-masked]>
Date: Sat, 6 Oct 2012 11:24:52 +0200

Please take a look at my new RFC draft and share your comments with me so that I might improve it.

Thanks,

Hosnieh

Filename:            draft-rafiee-cga-tsig

Revision:              00

Title:                      Transaction SIGnature (TSIG) using CGA Algorithm in IPv6

Creation date:   2012-09-30

WG ID:                  Individual Submission

Number of pages: 13

URL:             http://www.ietf.org/internet-drafts/draft-rafiee-cga-tsig-00.txt

Status:          http://datatracker.ietf.org/doc/draft-rafiee-cga-tsig

Htmlized:        http://tools.ietf.org/html/draft-rafiee-cga-tsig-00

---

From: Randy Bush <[email-masked]>
Date: Sat, 06 Oct 2012 06:39:51 -0700

definitely interesting.  rather cute.

but should it not be over in dns land?

randy

---

From: "Rafiee, Hosnieh" <[email-masked]>
Date: Sat, 6 Oct 2012 18:06:22 +0200

Dear Randy,

 I have already discussed with DNSEXT WG and been told that it is in FIN-WAIT. Therefore I posted this draft here. I hope I can receive good comments and this WG adopt this draft here.

Thank you,
Best Regards,
Hosnieh

-----Original Message-----
From: Randy Bush [mailto:[email-masked]] 
Sent: Saturday, October 06, 2012 3:40 PM
To: Rafiee, Hosnieh
Cc: [email-masked]
Subject: Re: [v6ops] draft-rafiee-cga-tsig-00 - request for comments

randy

---

From: Randy Bush <[email-masked]>
Date: Sat, 06 Oct 2012 09:14:51 -0700

>  I have already discussed with DNSEXT WG and been told that it is in
>  FIN-WAIT. Therefore I posted this draft here. I hope I can receive
>  good comments and this WG adopt this draft here.
> 

imiho, dnsext should have been sent an RST looooong ago.  but how about
dnsop?

</wg v6ops chair>
but v6ops should not be hacking on aspects of the dns which have nothing
to do with ipv6.

randy

---

From: Ted Lemon <[email-masked]>
Date: Sat, 6 Oct 2012 16:26:48 +0000

> imiho, dnsext should have been sent an RST looooong ago.  but how about

It's a standards-track document.   Neither dnsop nor v6ops is chartered to work on standards-track documents.   DNSEXT should just do the work before finishing.   It could be brought up in intarea—since DNSEXT seems determined to commit suicide, and it was in the Internet area, it makes sense that intarea should inherit the work.

---

From: "Rafiee, Hosnieh" <[email-masked]>
Date: Sat, 6 Oct 2012 18:31:25 +0200

Dear Randy, Dear  Ted

>  but how about dnsop?
I tried that mailing list but I received no response. Moreover, they are not so IPv6 specific. 
>but v6ops should not be hacking on aspects of the dns which have nothing to do with ipv6.
I don't agree with you with regard to this sepcific draft. Because this approach is just for IPv6 and the authentication approach used here is just related to IPv6 and does not work in IPv4. This draft focused on Neighbor Discovery protocol which again is just IPv6 specific.

>It's a standards-track document.   Neither dnsop nor v6ops is chartered to work on standards-track documents.   DNSEXT should just do the work before finishing.   It could be brought up in intarea-since DNSEXT ?>seems determined to commit suicide, and it was in the Internet area, it makes sense that intarea should inherit the work.
I also discussed it with that group but they do not think that it is appropriate for their group because it pretains to security and IPv6 plus DNS.

Best Regards,
Hosnieh

---

From: Randy Bush <[email-masked]>
Date: Sat, 06 Oct 2012 09:32:50 -0700

> It's a standards-track document.  Neither dnsop nor v6ops is chartered
> to work on standards-track documents.

see RFC 4213

but i essentially agree

> DNSEXT should just do the work before finishing.

dnsext should not be given any excuses to drag on

but this is all above my pay grade

randy

---

From: joel jaeggli <[email-masked]>
Date: Sat, 06 Oct 2012 09:38:13 -0700

So,

dnsext is closing down.

I personally don't see any harm in discussing it here, if there is interest.

I don't think that CGA fits within the scope of our charter.

joel

On 10/6/12 6:39 AM, Randy Bush wrote:
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: "Rafiee, Hosnieh" <[email-masked]>
Date: Sat, 6 Oct 2012 19:33:17 +0200

I would appreciate it. if you find this draft interesting, to start a discussion in this group which we can continue at the meeting in Atlanta.

-----Original Message-----
From: joel jaeggli [mailto:[email-masked]] 
Sent: Saturday, October 06, 2012 6:38 PM
To: Randy Bush
Cc: Rafiee, Hosnieh; [email-masked]
Subject: Re: [v6ops] draft-rafiee-cga-tsig-00 - request for comments

So,

dnsext is closing down.

joel