Subject: [v6ops] draft-binet-v6ops-cellular-host-requirements-01

From: <[email-masked]>
Date: Thu, 15 Nov 2012 15:59:51 +0100

Dear all,

We submitted a new version of the draft to take into account the comments received from M. Abrahamsson and P. Vickers.

The main changes are:

* Add some clarification text for REQ#3
* Mention stateless dhcpv6 is useful to retrieve other information than DNS
* Re-word REQ#15
* Cite "Happy Eyeballs" in REQ#16
* Update the text of REQ#17
* Add two sub-requirements to REQ#19: IPv6-only connectivity + SLAAC
* Precise the ordering in REQ#21

A more detailed diff is available at:
http://www.ietf.org/rfcdiff?url2=draft-binet-v6ops-cellular-host-requirements-01

Chairs, would it be possible to issue a Call For Adoption for this document? Thanks.

Cheers,
Med

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : jeudi 15 novembre 2012 15:53
À : [email-masked]
Objet : I-D Action: draft-binet-v6ops-cellular-host-requirements-01.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : Internet Protocol Version 6 (IPv6) Requirements for Cellular Hosts
	Author(s)       : David Binet
                          Mohamed Boucadair
                          Ales Vizdal
                          Cameron Byrne
                          Gang Chen
	Filename        : draft-binet-v6ops-cellular-host-requirements-01.txt
	Pages           : 16
	Date            : 2012-11-15

Abstract:
   This document lists a set of IPv6-related requirements to be
   supported by cellular hosts.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-binet-v6ops-cellular-host-requirements

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-binet-v6ops-cellular-host-requirements-01

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-binet-v6ops-cellular-host-requirements-01

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Jouni <[email-masked]>
Date: Thu, 15 Nov 2012 17:39:34 +0200

Med,

I am slightly confused about the overlap of draft-binet-v6ops-* and draft-ietf-v6ops-rfc3316bis. My recollection was that overlaps were supposed to be removed and then concentrate on the remaining part in draft-binet-v6ops-*, no? This would concern requirements #1, #6, #7, #8, #9, #17, #22, #23, #25, #26, #27. My recommendation would be removing those and just reference to [draft-ietf-v6ops-rfc3316bis] because the base IPv6 compliancy would come from there and I see no reason to repeat those here.

Then a question about the relevance of #24. Given the current bandwidth in 3G/LTE is there really a need to compress headers? And if people really see it as a life critical feature to have, I would appreciate listing the ROHC profiles that are essential (e.g., align with IR.92 & IR.58 that will be implemented on the network side).

- Jouni

On Nov 15, 2012, at 4:59 PM, <[email-masked]> <[email-masked]> wrote:

> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: <[email-masked]>
Date: Fri, 16 Nov 2012 13:07:01 +0100

Hi Jouni,

What I understood from the v6ops meeting is that wg participants see these two documents have distinct objectives. As such the question of overlapping does not apply as these documents serve two distinct objectives. Furthermore, because draft-binet-*'s objective is to define an IPv6 profile for cellular, we prefer the document be self-contained and use consistent language for all requirements.

Cheers,
Med 

>De : Jouni [mailto:[email-masked]] 
>Envoyé : jeudi 15 novembre 2012 16:40
>À : BOUCADAIR Mohamed OLNC/OLN
>Cc : [email-masked]; Mikael Abrahamsson; Pete Vickers
>Objet : Re: [v6ops] draft-binet-v6ops-cellular-host-requirements-01
>
>
>Med,
>
>I am slightly confused about the overlap of 
>draft-binet-v6ops-* and draft-ietf-v6ops-rfc3316bis. My 
>recollection was that overlaps were supposed to be removed and 
>then concentrate on the remaining part in draft-binet-v6ops-*, 
>no? This would concern requirements #1, #6, #7, #8, #9, #17, 
>#22, #23, #25, #26, #27. My recommendation would be removing 
>those and just reference to [draft-ietf-v6ops-rfc3316bis] 
>because the base IPv6 compliancy would come from there and I 
>see no reason to repeat those here.
>
>Then a question about the relevance of #24. Given the current 
>bandwidth in 3G/LTE is there really a need to compress 
>headers? And if people really see it as a life critical 
>feature to have, I would appreciate listing the ROHC profiles 
>that are essential (e.g., align with IR.92 & IR.58 that will 
>be implemented on the network side).
>
>- Jouni
>
>
>> We submitted a new version of the draft to take into account 
>the comments received from M. Abrahamsson and P. Vickers.
>> 
>> The main changes are:
>> 
>> De : [email-masked] 
>[mailto:[email-masked]] De la part de 
>[email-masked]
>> Objet : I-D Action: 
>draft-binet-v6ops-cellular-host-requirements-01.txt
>> 
>> 
>> 	Filename        : 
>draft-binet-v6ops-cellular-host-requirements-01.txt
>> 	Pages           : 16
>> 	Date            : 2012-11-15
>> 
>> Abstract:

---

From: jouni korhonen <[email-masked]>
Date: Fri, 16 Nov 2012 15:09:27 +0200

Med,

I still see no reason to replicate information since what comes to "a pure IPv6 profile for a 3GPP link", it should be exactly the same in both documents. I am just trying to avoid misalignment now and in the future. I would also argue that draft-binet-* is a profile for a specific deployment(s) in mind, not a generic IPv6 profile for cellular. It is a way more (not that it would be a bad thing though..).

- Jouni

---

From: <[email-masked]>
Date: Fri, 16 Nov 2012 14:17:18 +0100

Re-,

draft-binet-* assumes both DS and IPv6-only deployment modes. Nothing specific there.

Cheers,
Med

>De : jouni korhonen [mailto:[email-masked]] 
>Envoyé : vendredi 16 novembre 2012 14:09
>Cc : [email-masked] WG
>I still see no reason to replicate information since what 
>comes to "a pure IPv6 profile for a 3GPP link", it should be 
>exactly the same in both documents. I am just trying to avoid 
>misalignment now and in the future. I would also argue that 
>draft-binet-* is a profile for a specific deployment(s) in 
>mind, not a generic IPv6 profile for cellular. It is a way 
>more (not that it would be a bad thing though..).
>
>- Jouni
>
>
>> What I understood from the v6ops meeting is that wg 
>participants see these two documents have distinct objectives. 
>As such the question of overlapping does not apply as these 
>documents serve two distinct objectives. Furthermore, because 
>draft-binet-*'s objective is to define an IPv6 profile for 
>cellular, we prefer the document be self-contained and use 
>consistent language for all requirements.
>> 
>> Cheers,
>> Med 
>>

---

From: jouni korhonen <[email-masked]>
Date: Sun, 18 Nov 2012 01:14:05 +0200

Hi,

Likewise rfc3316bis assumes IPv6-only or dual-stack. Point being, rfc3316bis does not do in direction that is not necessary to run IPv6 (in a possibly multi interfaced host). IMHO the rest like NAT related recommendations, transition recommendations, WLAN specifics, tethering recommendations are then well served in draft-bonet-*.

- Jouni

---

From: Lorenzo Colitti <[email-masked]>
Date: Sun, 18 Nov 2012 21:06:22 -0800

On Thu, Nov 15, 2012 at 7:39 AM, Jouni <[email-masked]> wrote:

> My recollection was that overlaps were supposed to be removed and then
> concentrate on the remaining part in draft-binet-v6ops-*, no? This would
> concern requirements #1, #6, #7, #8, #9, #17, #22, #23, #25, #26, #27. My
> recommendation would be removing those and just reference to
> [draft-ietf-v6ops-rfc3316bis] because the base IPv6 compliancy would come
> from there and I see no reason to repeat those here.
>

That's what I remember from the meeting as well.

---

From: <[email-masked]>
Date: Mon, 19 Nov 2012 08:30:55 +0100

Hi Jouni,

The question of overlapping is not important IMHO as the two documents are targeting distinct objectives. I thought you agreed with this point (below an excerpt from the minutes):

"
Lorenzo C - Doc 1 is a shopping list document 2 is a treatis on how
you implment ipv6 on 3316. they're not covering the same domain

Jouni K - Agree with Lorenzo - different objectives so they need to be
treated differently
"

If now you are claiming yours is also doing what draft-binet-* does, I'm puzzled then...

Cheers,
Med 

>Envoyé : dimanche 18 novembre 2012 00:14
>Likewise rfc3316bis assumes IPv6-only or dual-stack. Point 
>being, rfc3316bis does not do in direction that is not 
>necessary to run IPv6 (in a possibly multi interfaced host). 
>IMHO the rest like NAT related recommendations, transition 
>recommendations, WLAN specifics, tethering recommendations are 
>then well served in draft-bonet-*.
>
>- Jouni
>
>>>>> Objet : Re: [v6ops] 
>draft-binet-v6ops-cellular-host-requirements-01
>>>>> 
>>>>> 
>>>>> Med,
>>>>>

---

From: jouni korhonen <[email-masked]>
Date: Tue, 20 Nov 2012 10:35:50 +0200

> The question of overlapping is not important IMHO as the two documents are targeting distinct objectives. I thought you agreed with this point (below an excerpt from the minutes):

I agree these document have different objectives. That is clear. Still it does not make sense to repeat IPv6 related requirements in normative language that are part of the generic cellular host IPv6 requirement. Even after the change I proposed, there still are many deployment & profile issues that are not covered anywhere except in draft-binet-*.

- Jouni

---

From: "Diego R. Lopez" <[email-masked]>
Date: Tue, 20 Nov 2012 22:22:07 +0000

Just let me support what I think is the common agreement expressed
so far, that both documents are relevant for the WG.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
-----------------------------------------

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx