Subject: [v6ops] Clarifications on draft-ietf-v6ops-rfc3316bis-00.txt

From: Hui Deng <[email-masked]>
Date: Sat, 17 Nov 2012 10:56:13 -0600

Hello, authors,

in section 2.11, it says
"learning the DNS server  addresses from the link layer signaling can be
cumbersome when the MT
   and the TE are separated using other techniques than PPP interface"
Can you be more specific about what else could be used? and what can be
cumbersome?

for privacy consideration,
can you help to write some analysis text about the relationship with
"always on capability in 3GPP"

Does SIPTO/LIPA has some influence on this document?

thanks

-Hui

---

From: jouni korhonen <[email-masked]>
Date: Sun, 18 Nov 2012 01:31:22 +0200

Hi,

On Nov 17, 2012, at 6:56 PM, Hui Deng wrote:

> Hello, authors,
>  
> in section 2.11, it says
> "learning the DNS server  addresses from the link layer signaling can be cumbersome when the MT
> Can you be more specific about what else could be used? and what can be cumbersome?

Like proprietary APIs or USB cdc etc between the MT and the TE. There might not be "easy" or standard way to let the TE stack to learn DNS information that the network sent in NAS signaling. PPP had one. Learning the DNS information using IP protocols between the TE stack and the gateway just makes the MT implementation easier and avoids OS specific hacks there.

> can you help to write some analysis text about the relationship with "always on capability in 3GPP"

Do you mean analysis of a cellular host having the same prefix in use for a long periods of time?

> Does SIPTO/LIPA has some influence on this document?

I am not sure yet. Maybe a recommendation to use DNA might be useful here?

- Jouni

>  
> thanks
>  
> -Hui
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Hui Deng <[email-masked]>
Date: Thu, 22 Nov 2012 15:18:05 +0800

Excuse me quite late reply, inline please.

2012/11/18 jouni korhonen <[email-masked]>

> Like proprietary APIs or USB cdc etc between the MT and the TE. There
> might not be "easy" or standard way to let the TE stack to learn DNS
> information that the network sent in NAS signaling. PPP had one. Learning
> the DNS information using IP protocols between the TE stack and the gateway
> just makes the MT implementation easier and avoids OS specific hacks there.
>
I thought propriatary way also works, but if you think so, please add some
text in the current draft.

> Do you mean analysis of a cellular host having the same prefix in use for

What I mean is in the case of LTE, it will keep one IP address or IPv6
prefix to allow its always on which keep PDP context.

> I am not sure yet. Maybe a recommendation to use DNA might be useful here?

In the case of SIPTO/LIPA, UE will has two PDP connections and two IP
addresses assigned. does it make some level difference?

thanks for your discussion

-Hui