Subject: [v6ops] draft-ietf-v6ops-64share-03

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 05 Apr 2013 18:12:31 +0200

Hello,

There is a serious report about the use of IPv6 'tethering' with
operator Verizon and doing 'mobile hotspot' with an iPhone.

It is not clear though whether that uses the 64share technique described
in this document or another one.

Alex

---

From: "cb.list6" <[email-masked]>
Date: Fri, 5 Apr 2013 09:53:04 -0700

> operator Verizon and doing 'mobile hotspot' with an iPhone.

Yes, Apple, ZTE, and Samsung are all known to have a implementations
similar in objective to 64share.

> in this document or another one.

These are proprietary implementations that do not conform to any known
standard, or ...at least are not openly documented.

One of the chief motivations for the 64share draft is to have a known
and open model that has been openly peer reviewed and can be
referenced as the desired model for the specific scope of the I-D.

Cameron

> Alex
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 05 Apr 2013 19:41:58 +0200

Le 05/04/2013 18:53, cb.list6 a écrit :
>> It is not clear though whether that uses the 64share technique
>> described in this document or another one.
>>
>
> These are proprietary implementations that do not conform to any
> known standard, or ...at least are not openly documented.
>

Cameron,

Reflecting implementation as much as possible to specification is good.

There may exist indicators by which one could say how much an
implementation is reflected in specification.  For 64share it's easy to
suggest an appoximate test of conformance (without having access to
source code).

Alex

>
> Cameron
>
>> Alex
>>
>> _______________________________________________ v6ops mailing list
>>  [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
>
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 05 Apr 2013 19:54:24 +0200

Le 05/04/2013 19:41, Alexandru Petrescu a écrit :
>> Yes, Apple, ZTE, and Samsung are all known to have a
>> implementations similar in objective to 64share.
>>
>> One of the chief motivations for the 64share draft is to have a
>> known and open model that has been openly peer reviewed and can be
> implementation is reflected in specification.  For 64share it's easy
> to suggest an appoximate test of conformance (without having access
> to source code).

For example: compare the address of the smartphone (having 'Personal
Hotspot' off) with the address of the other PC in the hotspot
(smartphone sets 'Personal Hotspot').

Are they the same on the first 64bits?  If yes then the solution is
likely to be 64share.  If no, then the solution is mobile hotspot, but
may not be 64share.

More details could be tested.

Alex

>
> Alex
>
>>
>> Cameron
>>
>>> Alex
>>>
>>> _______________________________________________ v6ops mailing
>>> list [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
>>
>>
>
>