Subject: Re: [v6ops] Interest in DHCPv6 Route/DefRouter/Src-basedRoute configuration to Client?

From: Alexandru Petrescu <[email-masked]>
Date: Sat, 13 Apr 2013 23:14:52 +0200

We had discussion about interest in DHCPv6
Route/DefRouter/src-basedRoute configuration to Client.

During that discussion one question was raised about RFC4191 "default
route preferences and more specific routes" implementation status.  I
reported that in linux there is implementation ok about this, with a
certain degree of maturity.

I wonder what does that mean with respect to:

- are there other non-linux implementaitons of rfc4191.
- any effect of this on the alternative way of doing it with DHCP.

Alex

---

From: Tim Chown <[email-masked]>
Date: Sun, 14 Apr 2013 01:01:31 +0100

On 28 Mar 2013, at 08:06, Mark Smith <[email-masked]> wrote:

> The only way to record all addresses in use on an segment is to observe neighbor discovery messages, primarily DADs, and once learned, actively probe them using methods similar to NUD to detect when they disappear. If that is still not acceptable, then admission control via e.g. 802.1x, and then isolating authorised clients in their own virtual point-to-point link with the router (e.g. individual VLAN with individual /64) would be the way to control who attaches to the network, and what they can reach.

Or by querying your switch/router equipment for IP/MAC data, e.g. https://nav.uninett.no/, which can be part of your mainstream network monitoring tools (and integrate IPv4 and IPv6 cleanly if dual-stack).

Tim