Subject: [v6ops] Home NAPT44 - How many ports?

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Wed, 5 Jun 2013 13:14:06 +0000

Some of you may recall our discussion (during the last IETF) around "how many TCP/UDP ports are enough with NAPT44" per home, as ISPs move into A+P paradigm. ~500, ~1000, ~3000???

Well, I started monitoring my home router and plotting the NAPT44 port utilization on a minute-by-minute basis. You may find it here - http://www.employees.org/~rajiva

In short, port range of 500 seems ok, though 1000 would be more than enough for my home. Suffice to say, this is just a sample representation, since the port utilization would vary home to home, based on number of active devices, type of applications, the degree of simultaneous device or application usage etc.

If any of you are doing similar monitoring, then please share.

Cheers,
Rajiv

PS: Thanks to Erik Kline, who explained (with sufficient details) how to use google charting for my data. And thanks to Xun Wang & Shaoshuai Dai for helping me out significantly.

PS: My home has 3-4 active devices.

---

From: "Poscic, Kristian (Kristian)" <[email-masked]>
Date: Wed, 5 Jun 2013 13:32:53 +0000

Thanks. Can you tell us in general what applications did you use for this?
This heavily depends on the application type in use...p2p apps, etc. Since some apps spawn a large number of TCP ports for example.

So the question is to what degree do you think is your sample representative of a general user in any region?

For example does it cover 30% of users for an ISP in NA while it covers 80% of users for another ISP in APAC for example?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Rajiv Asati (rajiva)
Sent: Wednesday, June 05, 2013 6:14 AM
To: [email-masked]; Softwires-wg list ([email-masked]); [email-masked]
Cc: Erik Kline ([email-masked])
Subject: [BEHAVE] Home NAPT44 - How many ports?

Cheers,
Rajiv

PS: My home has 3-4 active devices.
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: Michael Richardson <[email-masked]>
Date: Wed, 05 Jun 2013 09:51:37 -0400

>>>>> "rajiva" == rajiva  <Rajiv> writes:
    rajiva> In short, port range of 500 seems ok, though 1000 would be
    rajiva> more than enough for my home. Suffice to say, this is just a
    rajiva> sample representation, since the port utilization would vary
    rajiva> home to home, based on number of active devices, type of
    rajiva> applications, the degree of simultaneous device or
    rajiva> application usage etc. 

You are a home of how many computers?  How many active people?
(I don't assume those are 1:1...)
I guess you have no IPv6 running?
SIP? Skype? VPN (what kind? does it terminate on a desktop, or on your
"router"?) 

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Michael Richardson <[email-masked]>
Date: Wed, 05 Jun 2013 12:23:35 -0400

>>>>> "repenno" == repenno  <Reinaldo> writes:
    repenno> On the other hand, as Rajiv captured,the number of
    repenno> UDP sessions can be much larger than the number of
    repenno> TCP. Because the way 
    repenno> dynamic webpages are constructed today, there are sometimes
    repenno> literally 100s 
    repenno> of DNS requests to download a single page.

If one is doing CGN, wouldn't it be reasonable to point customers' at 
a recursive DNS server with an interface inside the CGN?

This seems to also suggest that having a *caching* recursive DNS(SEC,
HOMENET+, mDNS+) server inside the customer router is also a big win.

---

From: kaname nishizuka <[email-masked]>
Date: Thu, 06 Jun 2013 03:15:57 +0900

With regard to the DNS packets, shortening the time-out of NAT table is 
another good solution.

In larger environment, we tested that when the time-out of DNS was 
shortened to 3sec, the impact of such DNS requests was much smaller than 
TCP sessions.
3 sec is sufficient  round-trip time in general situation.
I don't think it's necessary to place a recursive DNS server inside the CGN.

Though there are differences between Home NAPT44 and CGN, it will work 
well in both case.
That is because there are many devices in home and those seldom access 
the web site within a short time simultaneously.

regards,
--
kaname

(2013/06/06 1:27), Reinaldo Penno (repenno) wrote:
>
> On 6/5/13 1:23 PM, "Michael Richardson" <[email-masked]> wrote:
>
> Yes. That's what I suggest. But some people use, say, Google's
> DNS/OpenDns/etc and in some other cases the network is not setup correctly.
>
> Yes, it is.

-- 
----
Kaname Nishizuka
Innovative Architecture Center
NTT Communications Corporation
+81-50-3812-4704

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Wed, 5 Jun 2013 18:45:46 +0000

Kristian, 

> This heavily depends on the application type in use...p2p apps, etc. Since
> some apps spawn a large number of TCP ports for example.

In my home, it is 99% web applications - predominant being OTT video consumption (besides SSL VPN for work).  Wrt p2p, we aggressively use p2p telephony (e.g. vonage, skype, facetime).

> So the question is to what degree do you think is your sample
> representative of a general user in any region?

It is quite subjective to answer, but I think that it represents a reasonable chunk of the home internet usage around the world.

Cheers,
Rajiv

> From: Poscic, Kristian (Kristian) [mailto:[email-masked]]
> Sent: Wednesday, June 05, 2013 9:33 AM
> To: Rajiv Asati (rajiva); [email-masked]; Softwires-wg list
> ([email-masked]); [email-masked]
> Subject: RE: Home NAPT44 - How many ports?
> 
> This heavily depends on the application type in use...p2p apps, etc. Since
> some apps spawn a large number of TCP ports for example.
> 
> So the question is to what degree do you think is your sample
> representative of a general user in any region?
> 
> For example does it cover 30% of users for an ISP in NA while it covers 80%
> of users for another ISP in APAC for example?
> 
> Some of you may recall our discussion (during the last IETF) around "how
> many TCP/UDP ports are enough with NAPT44" per home, as ISPs move into
> A+P paradigm. ~500, ~1000, ~3000???
> 
> Well, I started monitoring my home router and plotting the NAPT44 port
> utilization on a minute-by-minute basis. You may find it here -
> http://www.employees.org/~rajiva
> 
> In short, port range of 500 seems ok, though 1000 would be more than
> enough for my home. Suffice to say, this is just a sample representation,
> since the port utilization would vary home to home, based on number of
> active devices, type of applications, the degree of simultaneous device or
> application usage etc.
> 
> PS: Thanks to Erik Kline, who explained (with sufficient details) how to use
> google charting for my data. And thanks to Xun Wang & Shaoshuai Dai for
> helping me out significantly.
>

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Wed, 5 Jun 2013 18:51:35 +0000

Reinaldo,

I agree with you. Until I enabled DNS proxy on my router, I noticed that UDP NAT exceeded TCP NAT entries in few occasions. Since DNS proxy got enabled, UDP NAT entries became negligible.

One interesting observation is how the lowest number of TCP NAT entries stayed within the range throughout the night time (when the devices were not manually used) based on how many apps (on the smartphones) were left running. For ex, ~200 TCP ports on April 13-14, or ~30 TCP ports June 4.

Cheers,
Rajiv

> From: Reinaldo Penno (repenno)
> Sent: Wednesday, June 05, 2013 11:44 AM
> To: Poscic, Kristian (Kristian); Rajiv Asati (rajiva); [email-masked]; Softwires-
> wg list ([email-masked]); [email-masked]
> Subject: Re: [BEHAVE] Home NAPT44 - How many ports?
> 
> Yes, there are regional differences. But even then, in general, 90% of the
> active users can be covered by 1000 ports. I have been collecting data for
> many years, and actually the number of TCP ports consumed have been
> going Down due to a number of factors.
> 
> On the other hand, as Rajiv captured,the number of UDP sessions can be
> much larger than the number of TCP. Because the way dynamic webpages
> are constructed today, there are sometimes literally 100s of DNS requests to
> download a single page.
> 
> 
> 
> On 6/5/13 10:32 AM, "Poscic, Kristian (Kristian)"
> <[email-masked]> wrote:
> 
> >This heavily depends on the application type in use...p2p apps, etc.
> >Since some apps spawn a large number of TCP ports for example.
> >
> >For example does it cover 30% of users for an ISP in NA while it covers
> >80% of users for another ISP in APAC for example?
> >
> >Some of you may recall our discussion (during the last IETF) around
> >"how many TCP/UDP ports are enough with NAPT44" per home, as ISPs
> move
> >into
> >enough for my home. Suffice to say, this is just a sample
> >representation, since the port utilization would vary home to home,
> >based on number of active devices, type of applications, the degree of
> >simultaneous device or application usage etc.
> >
> >PS: Thanks to Erik Kline, who explained (with sufficient details) how
> >to use google charting for my data. And thanks to Xun Wang & Shaoshuai
> >Dai for helping me out significantly.
> >

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Wed, 5 Jun 2013 18:57:05 +0000

> >If one is doing CGN, wouldn't it be reasonable to point customers' at a
> >recursive DNS server with an interface inside the CGN?
> 

And in some cases, it is not possible depending on where the NAT function is placed and where the DNS server is placed. I recently ran into this in a large mobile network design. 

Nonetheless, it is desired, but it is not really a big deal, since UDP NAT usage tends to be a lot less than that TCP NAT usage (barring few exceptions).

> >HOMENET+, mDNS+) server inside the customer router is also a big win.

Well, DNS resolver with or without proxy is a big win, I would say. 

Cheers,
Rajiv

> Sent: Wednesday, June 05, 2013 12:28 PM
> To: Michael Richardson; [email-masked]
> Cc: Poscic, Kristian (Kristian); Rajiv Asati (rajiva); Softwires-wg list
> ([email-masked]); [email-masked]; Erik Kline ([email-masked])
> >If one is doing CGN, wouldn't it be reasonable to point customers' at a
> >recursive DNS server with an interface inside the CGN?
>

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Wed, 5 Jun 2013 19:03:27 +0000

Hi Michael,

Total 8 computing devices. Usually 2-4 active devices.

My ISP is yet to enable IPv6 in my location, and I have purposely disabled HE IPv6 to collect my IPv4 NAT data of this round, before enabling my HE IPv6 to contrast the IPv4 NAT usage.

Host based IPSec VPN or SSL VPN on one device. 
A lots of Vonage & Skype & FT usage.
Predominantly OTT video consumption.

Cheers,
Rajiv

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Michael Richardson
> Sent: Wednesday, June 05, 2013 9:52 AM
> To: Rajiv Asati (rajiva)
> Cc: Softwires-wg list ([email-masked]); Erik Kline ([email-masked]);
> [email-masked]; [email-masked]

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Wed, 5 Jun 2013 19:04:43 +0000

Kaname-san,

That's a good suggestion, though the captured data suggests that UDP NAT exhaustion is not a problem, but TCP NAT is.

Cheers,
Rajiv

> From: kaname nishizuka [mailto:[email-masked]]
> Sent: Wednesday, June 05, 2013 2:16 PM
> To: Reinaldo Penno (repenno)
> Cc: Michael Richardson; [email-masked]; Softwires-wg list
> ([email-masked]); Poscic, Kristian (Kristian); [email-masked]; Erik Kline
> ([email-masked]); Rajiv Asati (rajiva)

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Wed, 5 Jun 2013 15:44:25 +0000

Yes, there are regional differences. But even then, in general, 90% of the
active users can be covered by 1000 ports. I have been collecting data for
many years, and actually the number of TCP ports consumed have been going
Down due to a number of factors.

On the other hand, as Rajiv captured,the number of
UDP sessions can be much larger than the number of TCP. Because the way
dynamic webpages are constructed today, there are sometimes literally 100s
of DNS requests to download a single page.

On 6/5/13 10:32 AM, "Poscic, Kristian (Kristian)"
<[email-masked]> wrote:

>active devices, type of applications, the degree of simultaneous device
>or application usage etc.
>
>PS: Thanks to Erik Kline, who explained (with sufficient details) how to
>use google charting for my data. And thanks to Xun Wang & Shaoshuai Dai
>for helping me out significantly.
>

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Wed, 5 Jun 2013 16:27:59 +0000

Yes, it is.

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Wed, 5 Jun 2013 19:25:16 +0000

that's right.

Depending on how much stuff you have running there might be long term TCP
connections to mail servers, IM servers, Etc.

With the 'connected home' I'm assuming this will go up.

On 6/5/13 3:51 PM, "Rajiv Asati (rajiva)" <[email-masked]> wrote:

>Reinaldo,
>
>I agree with you. Until I enabled DNS proxy on my router, I noticed that
>UDP NAT exceeded TCP NAT entries in few occasions. Since DNS proxy got
>enabled, UDP NAT entries became negligible.
>
>One interesting observation is how the lowest number of TCP NAT entries
>stayed within the range throughout the night time (when the devices were
>not manually used) based on how many apps (on the smartphones) were left
>running. For ex, ~200 TCP ports on April 13-14, or ~30 TCP ports June 4.
>
>Cheers,
>Rajiv
>
>
>> >Behalf Of Rajiv Asati (rajiva)

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Wed, 5 Jun 2013 19:27:38 +0000

There are some interesting measurements on this "background TCP
radiation", i.e., how much state (and bandwidth) a home consumes even when
there is no active use.

On 6/5/13 3:57 PM, "Rajiv Asati (rajiva)" <[email-masked]> wrote:

>And in some cases, it is not possible depending on where the NAT function
>is placed and where the DNS server is placed. I recently ran into this in
>a large mobile network design.
>
>Nonetheless, it is desired, but it is not really a big deal, since UDP
>NAT usage tends to be a lot less than that TCP NAT usage (barring few
>exceptions).
>
>> >]     [email-masked]  http://www.sandelman.ca/        |   ruby on
>>rails
>> >   [
>> >
>

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Thu, 6 Jun 2013 13:43:24 +0000

Good point. I agree. 
And hopefully, most of the connected home would be on IPv6 (and not on IPv4) in the next few yrs . :)

Cheers,
Rajiv

> Sent: Wednesday, June 05, 2013 3:25 PM
> To: Rajiv Asati (rajiva); Poscic, Kristian (Kristian); [email-masked]; Softwires-
> Depending on how much stuff you have running there might be long term
> TCP connections to mail servers, IM servers, Etc.
> 
> >I agree with you. Until I enabled DNS proxy on my router, I noticed
> >that UDP NAT exceeded TCP NAT entries in few occasions. Since DNS proxy
> >got enabled, UDP NAT entries became negligible.
> >
> >stayed within the range throughout the night time (when the devices
> >were not manually used) based on how many apps (on the smartphones)
> >were left running. For ex, ~200 TCP ports on April 13-14, or ~30 TCP ports
> June 4.
> >
> >Cheers,
> >Rajiv
> >
> >
> >> To: Poscic, Kristian (Kristian); Rajiv Asati (rajiva);
> >>[email-masked];
> >>Softwires-
> >> Yes, there are regional differences. But even then, in general, 90%
> >>of the  active users can be covered by 1000 ports. I have been
> >>collecting data for  many years, and actually the number of TCP ports
> >>consumed have been  going Down due to a number of factors.
> >>
> >> On the other hand, as Rajiv captured,the number of UDP sessions can
> >>be  much larger than the number of TCP. Because the way dynamic
> >>webpages  are constructed today, there are sometimes literally 100s of
> >>DNS requests to  download a single page.
> >>
> >>
> >>
> >> >For example does it cover 30% of users for an ISP in NA while it
> >> >covers 80% of users for another ISP in APAC for example?
> >> >
> >> >Well, I started monitoring my home router and plotting the NAPT44
> >> >port utilization on a minute-by-minute basis. You may find it here -
> >> >based on number of active devices, type of applications, the degree
> >> >of simultaneous device or application usage etc.
> >> >
> >> >PS: Thanks to Erik Kline, who explained (with sufficient details)
> >> >how to use google charting for my data. And thanks to Xun Wang &
> >> >Shaoshuai Dai for helping me out significantly.
> >> >

---

From: Dan Wing <[email-masked]>
Date: Thu, 6 Jun 2013 08:43:23 -0700

On Jun 5, 2013, at 6:14 AM, Rajiv Asati (rajiva) <[email-masked]> wrote:

> In short, port range of 500 seems ok, though 1000 would be more than enough for my home.

I see several spikes in your data over 500 ports.  During those times, applications would be unable to function (unable to get a port).  April 29/30 is a long time where that occurs very visibly, but there are shorter spikes elsewhere such as on April 17 and April 18.  If you had only 500 ports on those days, creating a new TCP mapping would have been impossible, impacting ability to send or receive email, order books from Amazon.com, and so on.  I am surprised you conclude that "500 seems ok" when such a limit would interfere with your network use on those days.

What is the maximum number of mappings supported by your NAPT device?  Some residential-class NATs have a limit of 1024 mappings.

-d

> Suffice to say, this is just a sample representation, since the port utilization would vary home to home, based on number of active devices, type of applications, the degree of simultaneous device or application usage etc.
>

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Thu, 6 Jun 2013 22:41:44 +0000

Hi Dan,

> and so on.  I am surprised you conclude that "500 seems ok" when such a
> limit would interfere with your network use on those days.

I based that statement ("...seems ok,") on the very fact that the number of times the NAT utilization exceeded 500 mappings (equating to 500 ports, in my setup) in the sample period (~2 months) was relatively quite low. So, if the NAT device was limited to only 500 mappings, then the experience would have been ok for 99% of the time and degraded 1% of the time. This is an important consideration, IMO.

For ex, in the last 2 weeks, the number of times NAT mappings exceeded 500 were:

June 3 - 1 time
May 29 - 1 time
May 28 - 3 times
May 26 - 1 time
May 23 - 1 time
May 22 - 2 times
May 21 - 3 times
 
Of course, 1000 ports (resulting in 1000+ mappings) would have been more than enough to accommodate the times when the mappings exceeded 500, but stayed within 1000 (except once).

> What is the maximum number of mappings supported by your NAPT device?
> Some residential-class NATs have a limit of 1024 mappings.

My NAPT device seemingly can use upto 64K ports. :)

Cheers,
Rajiv

> From: Dan Wing (dwing)
> Sent: Thursday, June 06, 2013 11:43 AM
> To: Rajiv Asati (rajiva)
> Cc: [email-masked]; Softwires-wg list ([email-masked]);
> [email-masked]; Erik Kline ([email-masked])
> enough for my home.
> I see several spikes in your data over 500 ports.  During those times,
> applications would be unable to function (unable to get a port).  April 29/30
> is a long time where that occurs very visibly, but there are shorter spikes
> elsewhere such as on April 17 and April 18.  If you had only 500 ports on
> those days, creating a new TCP mapping would have been impossible,
> impacting ability to send or receive email, order books from Amazon.com,
> and so on.  I am surprised you conclude that "500 seems ok" when such a
> limit would interfere with your network use on those days.
> 
> What is the maximum number of mappings supported by your NAPT device?
> Some residential-class NATs have a limit of 1024 mappings.
> 
> -d
> 
> > Suffice to say, this is just a sample representation, since the port
> utilization would vary home to home, based on number of active devices,
> type of applications, the degree of simultaneous device or application
> usage etc.
> >

---

From: Owen DeLong <[email-masked]>
Date: Thu, 6 Jun 2013 17:54:13 -0500

At the point where we start calling any form of NAT "non-degraded" service, we have already strayed so far from rational thought that it is difficult to believe any rational conclusion can come from it.

ANY NAT is a degraded service. More NAT is inherently more degraded, even if it doesn't suffer an additional lack of available port numbers.

Owen

On Jun 6, 2013, at 5:41 PM, "Rajiv Asati (rajiva)" <[email-masked]> wrote:

> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: John Mann <[email-masked]>
Date: Fri, 7 Jun 2013 10:02:24 +1000

Hi,

On 7 June 2013 08:41, Rajiv Asati (rajiva) <[email-masked]> wrote:

> I based that statement ("...seems ok,") on the very fact that the number
> of times the NAT utilization exceeded 500 mappings (equating to 500 ports,
> in my setup) in the sample period (~2 months) was relatively quite low. So,
> if the NAT device was limited to only 500 mappings, then the experience
> would have been ok for 99% of the time and degraded 1% of the time. This is
> an important consideration, IMO.
>

I think a more-interesting statistic would be "how many connection setups
would have failed".
But I don't think you can measure that just by polling concurrent
connections at specific times.
It might take e.g. netflow exporting and analysis ...

However "number of concurrent connections that couldn't have been setup"
would be useful in gauging the impact
e.g. on May 29 there was one spike of 734 concurrent connections, then
report that as 234 potential failures.

Of course, 1000 ports (resulting in 1000+ mappings) would have been more
> than enough to accommodate the times when the mappings exceeded 500, but
> stayed within 1000 (except once).
>
>

Is that a combined limit of TCP and UDP and ICMP, or independent?

> "how
> to use

---

From: Dan Wing <[email-masked]>
Date: Thu, 6 Jun 2013 17:19:01 -0700

On Jun 6, 2013, at 5:02 PM, John Mann <[email-masked]> wrote:

> I think a more-interesting statistic would be "how many connection setups would have failed".
> But I don't think you can measure that just by polling concurrent connections at specific times.
> However "number of concurrent connections that couldn't have been setup" would be useful in gauging the impact
> e.g. on May 29 there was one spike of 734 concurrent connections, then report that as 234 potential failures.
> 

The study at http://eggert.org/papers/2010-imc-hgw-study.pdf only analyzed TCP bindings.

-d

---

From: Branimir Rajtar <[email-masked]>
Date: Fri, 7 Jun 2013 07:31:32 +0000

Hi all,

I've been working quite some time with Home Gateways and in my experience the older models (3+ years) typically support 1000-2000 simultaneous sessions, while the newer ones go up to 4000, some even up to 9000.

Branimir

From: [email-masked] [mailto:[email-masked]] On Behalf Of Dan Wing
Sent: Friday, June 07, 2013 2:19 AM
To: John Mann
Cc: Softwires-wg list ([email-masked]); [email-masked]; [email-masked]; Rajiv Asati (rajiva)
Subject: Re: [BEHAVE] [v6ops] Home NAPT44 - How many ports?

On Jun 6, 2013, at 5:02 PM, John Mann <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

On 7 June 2013 08:41, Rajiv Asati (rajiva) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Dan,

June 3 - 1 time
May 29 - 1 time
May 28 - 3 times
May 26 - 1 time
May 23 - 1 time
May 22 - 2 times
May 21 - 3 times

-d

Cheers,
Rajiv

> Cc: [email-masked]<mailto:[email-masked]>; Softwires-wg list ([email-masked]<mailto:[email-masked]>);
> [email-masked]<mailto:[email-masked]>; Erik Kline ([email-masked]<mailto:[email-masked]>)
> On Jun 5, 2013, at 6:14 AM, Rajiv Asati (rajiva) <[email-masked]<mailto:[email-masked]>> wrote:
>
> impacting ability to send or receive email, order books from Amazon.com<http://Amazon.com>,
> > [email-masked]<mailto:[email-masked]>

_______________________________________________
v6ops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/v6ops

<HTML><P><FONT face=Arial color=#999999 size=1>

IZJAVA O ODRICANJU ODGOVORNOSTI: Sadržaj ove poruke i eventualno priloženih datoteka je povjerljiv i namijenjen je samo osobama ili subjektima koji su navedeni u adresi. Ukoliko ste primili ovu poruku greškom, molimo Vas, obavijestite pošiljatelja, a poruku i sve njene privitke odmah, bez čitanja, trajno uklonite s računala. Bilo kakvo prenošenje, kopiranje ili distribucija informacija sadržanih u poruci trećim osobama je zabranjeno i može biti zakonski kažnjivo. Sadržaj, stavovi i mišljenja izneseni u poruci su autorovi i ne predstavljaju nužno stavove HT - Hrvatskih telekomunikacija d.d. HT ne prihvaća nikakvu odgovornost za eventualnu štetu nastalu primitkom ove poruke i priloga sadržanih u poruci.

</FONT></P><P><FONT face=Arial color=#999999 size=1>

 DISCLAIMER:The contents of this email as well as any files attached to it are confidential and intended solely for individuals or entities which they are addressed to. If you have received this email message in error, please notify the sender and permanently remove the message and all attached files from the computer. Any disclosure, copying or distribution of all or a part of information contained herein to or by third parties is prohibited and may be unlawful. Please note that any views or opinions presented in this message are solely those of the author and do not necessarily represent the views and opinions of Croatian Telecom Inc. Croatian Telecom Inc. accepts no liability for any potential damage caused by this message and files attached to it.

</FONT></P></HTML>

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Fri, 7 Jun 2013 18:09:06 +0000

There are certain port allocation methods where extending the port block is tricky, such as (Stateless) Deterministic NAT.

From: "Poscic, Kristian (Kristian)" <[email-masked]<mailto:[email-masked]>>
Date: Fri, 7 Jun 2013 16:06:13 +0000
To: John Mann <[email-masked]<mailto:[email-masked]>>, "Rajiv Asati (rajiva)" <[email-masked]<mailto:[email-masked]>>
Cc: "Softwires-wg list ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Dan Wing (dwing)" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [BEHAVE] [v6ops] Home NAPT44 - How many ports?

But why is this a problem in CGN?
You initially allocate a port block of 500ports to the subscriber and then they can dynamically extend this on as needed basis (allocate a new port block).

To me the value of this exercise is to determine what will this initial port block size be, not at which point the service will be denied since this can be easily extended.

For RGs, it is what it is, if they have the limit of 500mapping, then yes, this is the problem.
But for CGN it shouldn’t be.

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of John Mann
Sent: Thursday, June 06, 2013 5:02 PM
To: Rajiv Asati (rajiva)
Cc: Softwires-wg list ([email-masked]<mailto:[email-masked]>); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Dan Wing (dwing)
Subject: Re: [BEHAVE] [v6ops] Home NAPT44 - How many ports?

Hi,

June 3 - 1 time
May 29 - 1 time
May 28 - 3 times
May 26 - 1 time
May 23 - 1 time
May 22 - 2 times
May 21 - 3 times

Cheers,
Rajiv

_______________________________________________ Behave mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/behave

---

From: "Poscic, Kristian (Kristian)" <[email-masked]>
Date: Fri, 7 Jun 2013 16:06:13 +0000

For RGs, it is what it is, if they have the limit of 500mapping, then yes, this is the problem.
But for CGN it shouldn't be.

From: [email-masked] [mailto:[email-masked]] On Behalf Of John Mann
Sent: Thursday, June 06, 2013 5:02 PM
To: Rajiv Asati (rajiva)
Cc: Softwires-wg list ([email-masked]); [email-masked]; [email-masked]; Dan Wing (dwing)
Subject: Re: [BEHAVE] [v6ops] Home NAPT44 - How many ports?

Hi,

June 3 - 1 time
May 29 - 1 time
May 28 - 3 times
May 26 - 1 time
May 23 - 1 time
May 22 - 2 times
May 21 - 3 times

Cheers,
Rajiv

---

From: Mikael Abrahamsson <[email-masked]>
Date: Mon, 17 Jun 2013 07:28:53 +0200 (CEST)

> Some residential-class NATs have a limit of 1024 mappings.

I read some RFQ answers for residential gateways lately and at least the 
devices there seemed to support around 2048-4096 mapping.

Other numbers I've heard kicked around is for larger populations of fixed 
line customers (CGN for ADSL and similar tech), one needs to support 
around 30 connections per customer on average. This goes down a bit when 
it's a single mobile device (without tethering), then it's more like 4-6 
TCP connections needed on average.

If I was going to support a student dorm I'm pretty sure the above values 
would be a lot higher though, especially compared to a retirement home 
Wifi :)

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Benedikt Stockebrand <[email-masked]>
Date: Mon, 17 Jun 2013 10:46:20 +0000

Hi Dan and lists,

Dan Wing <[email-masked]> writes:

> I see several spikes in your data over 500 ports.  [...]  If you had
> only 500 ports on those days, creating a new TCP mapping would have
> been impossible, impacting ability to send or receive email, order
> books from Amazon.com, and so on.

...or make an emergency phone call using SIP---which currently spooks
triple play providers at least here in Germany, not only because it is
bad press but disrupting emergency calls is in some cases considered a
criminal offense here.

Otherwise, in November I saw a presentation by Alain Fiocco (also Cisco)
pointing out that a single Bittorrent client already needs about 700
simultaneous connections.

Cheers,

    Benedikt

-- 
			 Business Grade IPv6
		    Consulting, Training, Projects

Benedikt Stockebrand, Dipl.-Inform.        http://www.stepladder-it.com/