Subject: [v6ops] Interest in energy consumption of IPv6 smartphones (vs. IPv4) (was: BCP 202, RFC 7772 on Reducing Energy Consumption of Router Advertisements)

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 1 Jun 2016 14:40:19 +0200

Hi v6ops,

I wonder whether there may be interest in evaluating the energy 
consumption of an IPv6 application on smartphones, compared to its IPv4 
counterpart.

I suspect the difference may be negligible but I am not sure.

It would be good to avoid a situation in which the end user prefers IPv4 
on the smartphone because IPv6 empties the battery.

Alex

Le 11/02/2016 à 20:12, [email-masked] a écrit :
> A new Request for Comments is now available in online RFC libraries.
>
>         BCP 202
>         RFC 7772
>
>         Title:      Reducing Energy Consumption of Router
>                     Advertisements
>         Author:     A. Yourtchenko,
>                     L. Colitti
>         Status:     Best Current Practice
>         Stream:     IETF
>         Date:       February 2016
>         Mailbox:    [email-masked],
>                     [email-masked]
>         Pages:      6
>         Characters: 12555
>         See Also:   BCP 202
>
>         I-D Tag:    draft-ietf-v6ops-reducing-ra-energy-consumption-03.txt
>
>         URL:        https://www.rfc-editor.org/info/rfc7772
>
>         DOI:        http://dx.doi.org/10.17487/RFC7772
>
> Frequent Router Advertisement messages can severely impact host power
> consumption.  This document recommends operational practices to avoid
> such impact.
>
> This document is a product of the IPv6 Operations Working Group of the IETF.
>
>
> BCP: This document specifies an Internet Best Current Practices for the
> Internet Community, and requests discussion and suggestions for
> improvements. Distribution of this memo is unlimited.
>
> This announcement is sent to the IETF-Announce and rfc-dist lists.
> To subscribe or unsubscribe, see
>   https://www.ietf.org/mailman/listinfo/ietf-announce
>   https://mailman.rfc-editor.org/mailman/listinfo/rfc-dist
>
> For searching the RFC series, see https://www.rfc-editor.org/search
> For downloading RFCs, see https://www.rfc-editor.org/retrieve/bulk
>
> Requests for special distribution should be addressed to either the
> author of the RFC in question, or to [email-masked].  Unless
> specifically noted otherwise on the RFC itself, all RFCs are for
> unlimited distribution.
>
>
> The RFC Editor Team
> Association Management Solutions, LLC
>
>

---

From: Adeel Sadiq <[email-masked]>
Date: Wed, 1 Jun 2016 17:51:49 +0500

Dear Alexandre

Thank you for your concern.

I think we'll have to look into it by making different test scenarios, both
with IPv4 and IPv6. Like maybe we need less/more RAs when an IPv6-only
network needs to connect to IPv4-only network, or vice versa, or any
possible combination of the two.

Regards

Adeel Sadiq

On Wed, Jun 1, 2016 at 5:40 PM, Alexandre Petrescu <
[email-masked]> wrote:

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Nabil Benamar <[email-masked]>
Date: Wed, 1 Jun 2016 14:05:37 +0100

Hi Alex,

Thank you for rising this issue. I'm interested in working on the energy
consumption in IPv6 and compare it with IPv4.

Best regards
Nabil Benamar
-------------------
نبيل بنعمرو

http://nabilbenamar.ipv6-lab.net/

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 1 Jun 2016 16:13:49 +0000

I personally would find that interesting. As you note, we recently posted an RFC about managing power by managing activity. Andrew Yourtchenko has been interested in the chattiness of IPv6 implementations in WiFi, the issue being that it is a shared medium (not unlike an Ancient yellow Ethernet cable, and very unlike a switched network), so every hiccup reverberates throughout the network. I would expect that the issue affects mobile wireless in interesting ways. How chatty are we, and what needs to be adjusted?

Do you have something to share?

> On Jun 1, 2016, at 5:40 AM, Alexandre Petrescu <[email-masked]> wrote:
> 
> Hi v6ops,
> 
> I wonder whether there may be interest in evaluating the energy consumption of an IPv6 application on smartphones, compared to its IPv4 counterpart.
> 
> It would be good to avoid a situation in which the end user prefers IPv4 on the smartphone because IPv6 empties the battery.
> 
> Alex
>

---

From: joel jaeggli <[email-masked]>
Date: Wed, 1 Jun 2016 10:02:24 -0700

On 6/1/16 9:13 AM, Fred Baker (fred) wrote:
> I personally would find that interesting. As you note, we recently
> posted an RFC about managing power by managing activity. Andrew
> Yourtchenko has been interested in the chattiness of IPv6
> implementations in WiFi, the issue being that it is a shared medium
> (not unlike an Ancient yellow Ethernet cable, and very unlike a
> switched network), so every hiccup reverberates throughout the
> network. I would expect that the issue affects mobile wireless in
> interesting ways. How chatty are we, and what needs to be adjusted?

Energy management is a widely distributed problem. there are a number of
areas where IETF participants have been peripherally or directly involved.

Building or network level power management was an activity of the
operations and management area.

Scheduling on air interfaces would tend to fall to other SDO's though as
fred notes, multicast contention and protocol chattiness are
considerations for protocols that fall within the IETF scope, there is
also scope for transport or IRTF related exploration probably.

joel

>> consumption of an IPv6 application on smartphones, compared to its
>> IPv4 counterpart.
>> 
>> It would be good to avoid a situation in which the end user prefers
>> IPv4 on the smartphone because IPv6 empties the battery.
>> 
>> Alex
>> 
>>> BCP 202 RFC 7772
>>> Title:      Reducing Energy Consumption of Router Advertisements 
>>> Author:     A. Yourtchenko, L. Colitti Status:     Best Current
>>> Practice Stream:     IETF Date:       February 2016 Mailbox:
>>> [email-masked], [email-masked] Pages:      6 Characters:
>>> 12555 See Also:   BCP 202
>>> 
>>> I-D Tag:
>>> draft-ietf-v6ops-reducing-ra-energy-consumption-03.txt
>>> 
>>> Frequent Router Advertisement messages can severely impact host
>>> power consumption.  This document recommends operational
>>> practices to avoid such impact.
>>> 
>>> BCP: This document specifies an Internet Best Current Practices
>>> for the Internet Community, and requests discussion and
>>> suggestions for improvements. Distribution of this memo is
>>> unlimited.
>>> 
>>> This announcement is sent to the IETF-Announce and rfc-dist
>>> lists. To subscribe or unsubscribe, see 
>>> For searching the RFC series, see
>>> https://www.rfc-editor.org/search For downloading RFCs, see
>>> https://www.rfc-editor.org/retrieve/bulk
>>> 
>>> Requests for special distribution should be addressed to either
>>> the author of the RFC in question, or to
>>> [email-masked].  Unless specifically noted otherwise
>>> on the RFC itself, all RFCs are for unlimited distribution.
>>> 
>>> 
>>> The RFC Editor Team Association Management Solutions, LLC
>>> 
>>> 
>> 
>> _______________________________________________ v6ops mailing list 
>> [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
> 
> 
> 
> _______________________________________________ v6ops mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 2 Jun 2016 10:33:45 +0200

> interesting ways. How chatty are we, and what needs to be adjusted?

It would be interesting to look at how IPv6 link and network protocol
behaviour may consume more or less energy.  ND efficiency,
energy-efficient IP paths in access and core networks, path-energy
discovery: are topics very interesting to explore.

Other operational question may be whether the full use of IPv6 on a
smartphone (disable IPv4) draws its battery more, less, or just as when
only IPv4 is used.  It may need some measurement of application
behaviour.  Recently energy-specific APIs became available on smartphone
OSs, supposing they're working ok on IPv6.

> Do you have something to share?

Well not at this time.  We are currently exploring the
application-specific measurement part with a few people.  Maybe that can
lead to an Internet Draft.

Alex

>> It would be good to avoid a situation in which the end user
>> prefers IPv4 on the smartphone because IPv6 empties the battery.
>>
>> Alex
>>

---

From: Nabil Benamar <[email-masked]>
Date: Thu, 2 Jun 2016 10:37:14 +0100

Hi All,

Since there is no dual stack on 3g/4g in my side, I can only test with
wifi. Create a tunnel with HE.net for example and then connect a smartphone
on IPv6 only..make the measurements and then switch to IPv4 only repeat the
steps.....energy measurements are application specific!

I would like to ask the members of the list which is the best application
to use for energy consumption on Android ?

It would also be interesting to measure with different mobile OS !

Best regards
Nabil Benamar
-------------------
نبيل بنعمرو

---

From: Olivier MJ Crepin-Leblond <[email-masked]>
Date: Thu, 2 Jun 2016 12:22:11 +0200

Hello all,

it is also worth noting that 3G & 4G in particular appears to drain
battery more than 2G. Results could be flawed because due to novelty, in
most places 4G signal strength is not yet at the level of 2G or 3G
signal strength. A study under controlled environment would be somehow
interesting indeed although I fail to see the end goal for performing
such a study? Do we want to prove that longer addresses mean more power
requirements? I would have thought the end point really relates to
chipset architecture, not bits transmitted.
Kindest regards,

Olivier

On 02/06/2016 11:37, Nabil Benamar wrote:
> wifi. Create a tunnel with HE.net for example and then connect a
> smartphone on IPv6 only..make the measurements and then switch to IPv4
> only repeat the steps.....energy measurements are application specific!
>
> I would like to ask the members of the list which is the best
> application to use for energy consumption on Android ?
>
> On Thu, Jun 2, 2016 at 9:33 AM, Alexandre Petrescu
> <[email-masked] <mailto:[email-masked]>>
> wrote:
>
>             On Jun 1, 2016, at 5:40 AM, Alexandre Petrescu
>             <[email-masked]
>             <mailto:[email-masked]>> wrote:
>
>             Hi v6ops,
>
>             Le 11/02/2016 à 20:12, [email-masked]
>             <mailto:[email-masked]> a écrit :
>
>                 [email-masked] <mailto:[email-masked]>,
>                 [email-masked] <mailto:[email-masked]> Pages: 
>                     6 Characters:
>                 12555 See Also:   BCP 202
>
>                 I-D Tag:
>                 This document is a product of the IPv6 Operations
>                 Working Group
>                 of the IETF.
>
>
>                 [email-masked]
>                 <mailto:[email-masked]>.  Unless
>                 specifically noted otherwise
>              [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

-- 
Olivier MJ Crépin-Leblond, PhD
http://www.gih.com/ocl.html

---

From: "Heatley, Nick" <[email-masked]>
Date: Thu, 2 Jun 2016 11:01:42 +0000

Hi, (other than avoiding RA time issues) do the real benefits come when apps are changed, less session keepalives in a nat-free environment?
It is all about the apps opportunity. They need to behave differently when IPv6-only.
Nick

From: v6ops [mailto:[email-masked]] On Behalf Of Olivier MJ Crepin-Leblond
Sent: 02 June 2016 11:22
To: Nabil Benamar; Alexandre Petrescu
Cc: [email-masked]
Subject: Re: [v6ops] Interest in energy consumption of IPv6 smartphones (vs. IPv4)

Hello all,

it is also worth noting that 3G & 4G in particular appears to drain battery more than 2G. Results could be flawed because due to novelty, in most places 4G signal strength is not yet at the level of 2G or 3G signal strength. A study under controlled environment would be somehow interesting indeed although I fail to see the end goal for performing such a study? Do we want to prove that longer addresses mean more power requirements? I would have thought the end point really relates to chipset architecture, not bits transmitted.
Kindest regards,

Olivier

Since there is no dual stack on 3g/4g in my side, I can only test with wifi. Create a tunnel with HE.net for example and then connect a smartphone on IPv6 only..make the measurements and then switch to IPv4 only repeat the steps.....energy measurements are application specific!

I would like to ask the members of the list which is the best application to use for energy consumption on Android ?

Best regards
Nabil Benamar
-------------------
نبيل بنعمرو

On Thu, Jun 2, 2016 at 9:33 AM, Alexandre Petrescu <[email-masked]<mailto:[email-masked]>> wrote:

Alex

On Jun 1, 2016, at 5:40 AM, Alexandre Petrescu
<[email-masked]<mailto:[email-masked]>> wrote:

Hi v6ops,

Alex

Le 11/02/2016 à 20:12, [email-masked]<mailto:[email-masked]> a écrit :
A new Request for Comments is now available in online RFC
libraries.

BCP 202 RFC 7772

Title:      Reducing Energy Consumption of Router Advertisements
 Author:     A. Yourtchenko, L. Colitti Status:     Best Current
Practice Stream:     IETF Date:       February 2016 Mailbox:
[email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]> Pages:      6 Characters:
12555 See Also:   BCP 202

This document is a product of the IPv6 Operations Working Group
of the IETF.

Requests for special distribution should be addressed to either
the author of the RFC in question, or to
[email-masked]<mailto:[email-masked]>.  Unless specifically noted otherwise
on the RFC itself, all RFCs are for unlimited distribution.

_______________________________________________ v6ops mailing list
 [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/v6ops

_______________________________________________
v6ops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/v6ops

v6ops mailing list

[email-masked]<mailto:[email-masked]>

--

NOTICE AND DISCLAIMER
This email contains BT information, which may be privileged or confidential. It's meant only for the individual(s) or entity named above. 
If you're not the intended recipient, note that disclosing, copying, distributing or using this information is prohibited. 
If you've received this email in error, please let me know immediately on the email address above. Thank you.

We monitor our email system, and may record your emails.

EE Limited 
Registered office:Trident Place, Mosquito Way, Hatfield, Hertfordshire, AL10 9BW
Registered in England no: 02382161

EE Limited is a wholly owned subsidiary of:

British Telecommunications plc
Registered office: 81 Newgate Street London EC1A 7AJ
Registered in England no: 1800000

---

From: Mark Andrews <[email-masked]>
Date: Fri, 03 Jun 2016 12:17:20 +1000

While reducing power consumtion is a good thing, we will be wasting
peoples time to compare IPv6 vs IPv4 power consumption.  Don't we
have better things to do than to waste peoples time on the academic
exercise which will produce nothing useful.

Mark
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]