Subject: [v6ops] Looking for comments in a charter update

From: Fred Baker <[email-masked]>
Date: Thu, 16 Feb 2017 14:26:18 -0800

The chairs and ADs have been discussing a possible charter update. We're interested in your comments - yea, nay, other topics, and all that. See attached.

In short, we have watched the discussions relevant to v6ops change over time. At one point, the predecessor working group was developing overlay and transition technologies, and v6ops was chartered in part to say that *that* discussion was pretty much done as IPv6 moved into native deployment. There were (and are) still interactions with the IPv4 network, but the focus has moved.

We are now seeing real IPv6-only deployments and progress toward more:
https://blog.apnic.net/2017/01/19/ipv6-only-at-microsoft/
https://arstechnica.com/apple/2015/06/apple-to-ios-devs-ipv6-only-cell-service-is-coming-soon-get-your-apps-ready/
http://www.internetsociety.org/deploy360/resources/case-study-facebook-moving-to-an-ipv6-only-internal-network/
https://engineering.linkedin.com/blog/2016/11/ipv6-inside-linkedin-part-iii--the-elephant-in-the-room
https://blog.apnic.net/2017/01/31/chinas-first-ipv6-backbone-network-connect-1200-campuses/

On my phone, I observe that I am IPv6-only (and have a DNS server with a ULA address). Google reports that the vast majority of accesses it receives from Verizon use IPv6. Several measurement sources indicate that they see over 5% of traffic in 33 countries using IPv6, and greater than 20% in six countries. Belgium...

https://www.vyncke.org/ipv6status/compare.php?metric=p&countries=be,us,gr,de,ch,lu,ec,gb,ee,pt,ca,pe,in,jp,fr,no,br,my,fi,tt,cz,nl,ie,au,ro,nz,hu,zw,si,gt,sa,vn,ax
https://www.vyncke.org/ipv6status/compare.php?metric=p&countries=be,us,gr,de,ch,lu

In addition to "what if we turn IPv4 off", we are starting to see creative thinking about opportunities that arise when we do. For example, what if we run a prefix to a host (RFC 7934), and use addresses to identify containers or processes? Tom Herbert presented to us on a different data center model in draft-herbert-nvo3-ila.

So we want to explicitly add and invite a topic: what issues and opportunities do we encounter as we turn down IPv4? What are, if you will, the carrots and the sticks?

One thought that I have as I click "send" has to do with markets. When IPv6 was designed, we mostly thought about service providers and what belonged in someone's favorite computer. We now also think about content providers, data center operation, residential, enterprise, and IoT markets - which overlap but have differing requirements. It might be of value to not tiptoe around that. Is this, or something else, important to bring into a revised charter?

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 17 Feb 2017 10:02:55 +0100

Hi Fred,

One of the main issues is the lack of support from the IETF specs of mechanisms such as 464XLAT and MAP, so operators and end users can go to the market and buy a router with not only supports DS-Lite but also those “IPv6-only in the WAN” protocols.

Can we somehow include this in the chapter? The ideal way will to update RFC6204 as already discussed in the list, or work in a new document to describe that situation.

I’m happy to volunteer for that, as already indicated several times.

Regards,
Jordi

-----Mensaje original-----
De: v6ops <[email-masked]> en nombre de Fred Baker <[email-masked]>
Responder a: <[email-masked]>
Fecha: jueves, 16 de febrero de 2017, 23:26
Para: IPv6 Ops WG <[email-masked]>
Asunto: [v6ops] Looking for comments in a charter update

    

    

    One thought that I have as I click "send" has to do with markets. When IPv6 was designed, we mostly thought about service providers and what belonged in someone's favorite computer. We now also think about content providers, data center operation, residential, enterprise, and IoT markets - which overlap but have differing requirements. It might be of value to not tiptoe around that. Is this, or something else, important to bring into a revised charter?
    _______________________________________________
    v6ops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/v6ops

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Fred Baker <[email-masked]>
Date: Fri, 17 Feb 2017 03:09:54 -0800

I'd be happy to entertain a draft proposing what you have in mind. I just said that in private mail. I no longer work for a major routing vendor, but I can tell you that the obvious ones do have translation products, and are working with their customers on IPv6-only operation. They understand "IPv6-only" to mean "no IPv4", not "translation", though. Their customers are drumming that into their heads.

> On Feb 17, 2017, at 1:02 AM, JORDI PALET MARTINEZ <[email-masked]> wrote:
> 
> Hi Fred,
>