Subject: Re: [v6ops] draft-ietf-v6ops-ula-usage-considerations

From: james woodyatt <[email-masked]>
Date: Thu, 2 Feb 2017 13:39:13 -0800

On Jan 31, 2017, at 12:46, Ron Bonica <[email-masked]> wrote:
> 
> Ack. ULA-only is OK when disconnected from the Internet.

When *persistently* disconnected from the Internet. I suspect there isn’t consensus about what to say for networks that connect to the Internet intermittantly and ephemerally.

--james woodyatt <[email-masked] <mailto:[email-masked]>>

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 3 Feb 2017 13:44:13 +1300

> When *persistently* disconnected from the Internet. I suspect there isn’t consensus about what to say for networks that connect to the Internet intermittantly and ephemerally.

Why not? My ISP sometimes fails to give me an IPv6 prefix when I reboot the CE. On those
days, the CE announces a ULA prefix. Everything works just fine. If a GUA prefix
crops up later, the ULA is quickly depreffed and everything still works just fine.

ULAs are basically harmless domestic animals. NPTv6 is a Frankenstein monster, of
course.

   Brian

---

From: Lorenzo Colitti <[email-masked]>
Date: Fri, 3 Feb 2017 10:22:14 +0900

On Fri, Feb 3, 2017 at 6:39 AM, james woodyatt <[email-masked]> wrote:

> When *persistently* disconnected from the Internet.
>

... and where any access to resources outside the ULA domain does not occur
via IP packets but by higher-level intermediaries such as application-layer
proxies.

---

From: "Liubing (Leo)" <[email-masked]>
Date: Sat, 4 Feb 2017 04:14:07 +0000

Hi Ron and all,

Sorry for the late reply, I was just back from the Chinese New Year holidays.

I'll make a new version to see if the WG could make a final consensus. 
Thanks much for all the comments in the mailing list and your guidance on this work.

Best regards,
Bing

> -----Original Message-----
> From: v6ops [mailto:[email-masked]] On Behalf Of Ron Bonica
> Sent: Tuesday, January 31, 2017 11:23 PM
> To: IPv6 Ops WG
> Subject: [v6ops] draft-ietf-v6ops-ula-usage-considerations
> 
> Folks,
> 
> Some time ago, I queried the WG's disposition regarding
> draft-ietf-v6ops-ula-usage-considerations
> (https://mailarchive.ietf.org/arch/search/?email_list=v6ops&index=x6OmZJ
> 1n2F0rBX6iq5GHRBHWRO0&gbt=1). I think that the consensus was:
> 
> - Continue as informational
> - Recommend against ULA-only
> - Attempt to find some set of recommendations upon which the WG can
> agree.
> 
> So, if the authors are so disposed, I encourage them to produce a new
> version of the draft, leveraging what we learned during this email thread.
> 
>                                                            Ron
> 
> 
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: james woodyatt <[email-masked]>
Date: Mon, 6 Feb 2017 11:39:36 -0800

> ULAs are basically harmless domestic animals. NPTv6 is a Frankenstein monster, of

Do we really think we have rough consensus that ULA-only in the *temporarily* disconnected state is OPTIONAL as opposed to NOT RECOMMENDED? Enough to make an assertive statement to that effect?

I remember a debate during the predecessor to RFC 7084 over the language in requirement L-13, and my recollection is that the tortured language in that requirement is the result of a compromise about this very question. Some participants wanted to zero the Valid Lifetime of the withdrawn prefix delegation, while others wanted to leave it valid for up to two hours. We ended up allowing both and not making any statement at all about what is recommended and what is truly optional.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 7 Feb 2017 17:43:00 +1300

> Do we really think we have rough consensus that ULA-only in the *temporarily* disconnected state is OPTIONAL as opposed to NOT RECOMMENDED? Enough to make an assertive statement to that effect?

Yes. If I drop off the Internet for X minutes, why on earth would some RFC
tell me I should not use a ULA during that time? Its lifetime will be
renewed as necessary, whereas any residual GUA will eventually vanish,
and probably SHOULD NOT be used anyway, because it might already belong to
someone else.

Note that the value of X is by definition unknowable. It might be 1 or it
might be 100,000.

> I remember a debate during the predecessor to RFC 7084 over the language in requirement L-13, and my recollection is that the tortured language in that requirement is the result of a compromise abo…

Indeed. Just like trying to define 'temporarily', because it's unknown and
unpredictable how long the disconnection might last. It's going to be a
pragmatic implementation choice.

    Brian