Subject: Re: [v6ops] Outcomes from v6ops@IETF98

From: Tim Chown <[email-masked]>
Date: Sat, 1 Apr 2017 23:41:06 +0000

Hi,

> On 31 Mar 2017, at 22:43, Brian E Carpenter <[email-masked]> wrote:
> 
> On 30/03/2017 09:40, Fred Baker wrote:
>> I have attached a pdf of the proposed charter as it ended this afternoon. I invite public commentary (to [email-masked]), and if you support using it as it stands, please say so..
> 
> Looks good to me.
> 
>> One question I intended to ask and didn't get to was the appropriateness of an interim meeting, perhaps in mid-May. It would primarily address draft-ietf-v6ops-ula-usage-considerations and draft-petrescu-v6ops-ipv6-power-ipv4, and potentially draft-ietf-v6ops-design-choices if it is updated. There is an argument for leaving these to IETF 99, and potentially booking a second slot for that discussion. Your opinions?
> 
> I find it hard to answer without seeing a list of open issues for each draft.

Seconded. Is the intention a physical or virtual meeting, or both?

>> We have two WGLCs in progress or about to be so. The WGLC on draft-ietf-v6ops-unique-ipv6-prefix-per-host, which Ron opened on 14 March, will end on 9 April. We will then open a WGLC on draft-ietf-v6ops-v4v6-xlat-prefix, to end 23 April.
>> 
>> I believe that the discussion today supported adoption of the following as working group drafts:
>> draft-ali-ipv6rtr-reqs (as draft-ietf-v6ops-ipv6rtr-reqs)
>> draft-palet-v6ops-rfc7084-bis (as draft-ietf-v6ops-rfc7084-bis)
>> draft-pauly-v6ops-happy-eyeballs-update (as draft-ietf-v6ops-happy-eyeballs-update)
> 
> I'm OK with adopting all three. I think from the discussion that happy-eyeballs-update
> should perhaps be named differently, with Intended status: Informational, since
> putting it on the standards track would probably take some heavy lifting. As a
> report on enhancements it could progress quickly.

Agreed. 

I really like the updated happy eyeballs document. How about “Happy IPs Towards Enhanced Resilience” or HIPsTER?  

Tim

---

From: Fred Baker <[email-masked]>
Date: Sun, 2 Apr 2017 09:51:33 -0700

> On Apr 1, 2017, at 4:41 PM, Tim Chown <[email-masked]> wrote:

I was thinking in terms of webex or equivalent, somewhere in May 8-18. If folks want to have a meeting, I have to announce it 30 days in advance, which means I'll send a doodle poll and we'll figure out when to have it during this coming week. To my small mind, June is late enough that we may as well delay for July.

My *guess* at an agenda in July includes
    draft-ietf-v6ops-ula-usage-considerations if needed
    draft-ietf-v6ops-design-choices if updated and needed
    draft-petrescu-v6ops-ipv6-power-ipv4 if needed

    draft-ietf-v6ops-happy-eyeballs-update
    draft-ietf-v6ops-rfc7084-bis
    draft-ietf-v6ops-ipv6rtr-reqs

Plus possible additional work submitted between now and then. Note the "if needed"; they might be an argument for a second slot if we don't have an interim meeting, and if we do have one, would only be on the agenda if updated and there is working group interest.

If you look at https://tools.ietf.org/rfcdiff?url2=draft-ietf-v6ops-ula-usage-considerations-02.txt, you will see that the authors have done some pretty heavy-duty changes to the document. I think the question would be (and this could be in email or verbally) what additional changes people would like to see. I'd invite a thorough review of the document as it stands. I'll note that "let's deprecate ULA or tell people to never use it" doesn't fit with current operational practice; when my phone is not attached to a WiFi, the DNS address my provider offers me is a ULA address. "Don't NAT", fine, but "don't ULA" as a blanket statement is inconsistent with operational practice in some providers, and "ULA implies NAT" is just silly. It implies that the systems so addressed are not normally advertised in BGP, nothing more and nothing less.

draft-petrescu-v6ops-ipv6-power-ipv4 is a brand new draft, slipped in just under the wire. The first question is whether the working group is interested; there wasn't time for that discussion to happen before IETF 98. If we ARE interested, what do we think of it?

draft-ietf-v6ops-design-choices didn't get updated for this meeting, and sooner or later will simply drop off radar. Folks have periodically said that they find it interesting and potentially useful, but the authors have largely run out of steam. So at least part of the question is "what is the future for this draft?".

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sun, 02 Apr 2017 23:11:54 +0200

Hi Fred,

+1 for the new chapter.

Regarding the interim meeting, do we really need that? I don’t think so, and for some of the participants, it may be an extra cost that not everybody can afford, or for some may be even difficult to attend even remotely if organized with so short notice as May with already a few meetings organized from long time ago … unless, is a short meeting that we can coordinate for example with RIPE (8-12 May, Budapest) or LACNIC (22-26 May, Foz do Iguaçú) meetings which are being hold also in May, and they can spare a meeting room for us for 3-4 hours? Of course, this is only valid if many of the intended participants are also there.

Regarding the new WG items, I have the same understanding that the 3 documents have been adopted. In fact, I just submitted a new version as WG 00 …

Regards,
Jordi

-----Mensaje original-----
De: v6ops <[email-masked]> en nombre de Fred Baker <[email-masked]>
Responder a: v6ops list <[email-masked]>
Fecha: miércoles, 29 de marzo de 2017, 22:40
Para: v6ops list <[email-masked]>
Asunto: [v6ops] Outcomes from v6ops@IETF98

    

    None of these can be considered to be "done". I would encourage people with comments to make them to the list, carrying the draft name in the subject line, and including suggested text for anything specific.
    
    _______________________________________________
    v6ops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/v6ops

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Tim Chown <[email-masked]>
Date: Sun, 2 Apr 2017 22:08:53 +0000

Hi Fred,

> On 2 Apr 2017, at 17:51, Fred Baker <[email-masked]> wrote:
> 
> 

OK; as Jordi says, I doubt many people would travel just for this. Mid-to-late May sounds right. The age-old problem is picking which part of the world to inconvenience the most; I guess looking at the locale of the bulk of the authors is the fairest way? 

> Plus possible additional work submitted between now and then. Note the "if needed"; they might be an argument for a second slot if we don't have an interim meeting, and if we do have one, would onl…

I’d assume we have a draft cutoff one week before the meeting so update could be discussed?  Worst case we’d then ensure an extra cycle of work before Prague.

> draft-petrescu-v6ops-ipv6-power-ipv4 is a brand new draft, slipped in just under the wire. The first question is whether the working group is interested; there wasn't time for that discussion to ha…

It would be more interesting if the reasons for the additional power consumption were identified and discussed - there’s no sign of this that I can see in the document - are there recommendations for reducing power consumption for IPv6, different to IPv4?

> draft-ietf-v6ops-design-choices didn't get updated for this meeting, and sooner or later will simply drop off radar. Folks have periodically said that they find it interesting and potentially usefu…

I think there’s good material, well written, in design-choices; it would be a shame to lose it. It would complement draft-ali-ipv6rtr-reqs quite nicely. I note the first -00 was nearly 5 years ago though!

Tim

---

From: Fred Baker <[email-masked]>
Date: Sun, 2 Apr 2017 20:39:06 -0700

> On Apr 2, 2017, at 3:08 PM, Tim Chown <[email-masked]> wrote:
> 
> OK; as Jordi says, I doubt many people would travel just for this.

Who is suggesting that they travel?

---

From: Joel Jaeggli <[email-masked]>
Date: Sun, 2 Apr 2017 22:20:14 -0700

Sent from my iPhone

> On Apr 2, 2017, at 20:39, Fred Baker <[email-masked]> wrote:
> 
> 

Almost all interims at this point are virtual so I assumed likewise.

That said notification of the date for them is typically 2 or more weeks not 4 per IESG guidance. 

Regards 
Joel

---

From: Tim Chown <[email-masked]>
Date: Mon, 3 Apr 2017 10:47:46 +0000

> On 3 Apr 2017, at 04:39, Fred Baker <[email-masked]> wrote:
> 

I only asked whether the meeting was physical, virtual, or a mix, and agreeing above that virtual-only is the best option in this case.

As it happens, Ive attended more physical interim meetings than virtual ones.

Tim

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 3 Apr 2017 15:20:57 +0200

Le 03/04/2017 à 00:08, Tim Chown a écrit :
[...]
>> draft-petrescu-v6ops-ipv6-power-ipv4 is a brand new draft, slipped
>>  in just under the wire. The first question is whether the working
>>  group is interested; there wasn't time for that discussion to
>> happen before IETF 98. If we ARE interested, what do we think of
>> it?
>
> It would be more interesting if the reasons for the additional power
>  consumption were identified and discussed - there’s no sign of this
>  that I can see in the document -

Right - no such sign in the document, although on the email list someone
(Jen and colleagues?) tried an explanation several months ago -
something related to the header size being larger.

> are there recommendations for reducing power consumption for IPv6,
> different to IPv4?

At this time no recommendation we wrote.  We are first doing our
best make the figures are correct, wondering whether somebody else
could confirm or infirm.

Another organisation presented with these figures indicated these may
represent bad news.

Alex

---

From: Jen Linkova <[email-masked]>
Date: Fri, 7 Apr 2017 15:53:20 +0200

> something related to the header size being larger.

I think you are referring to this thread:
https://www.ietf.org/mail-archive/web/v6ops/current/msg25223.html

-- 
SY, Jen Linkova aka Furry