Subject: [v6ops] New drafts

From: Fred Baker <[email-masked]>
Date: Thu, 15 Jun 2017 07:07:24 -0700

We have several new drafts that the chairs would like working group discussion on, if only to gauge interest. Jen sent a note regarding hers a moment ago. Jordi has, following feedback, divided 70844bis, and we are looking for commentary on each.

	2017-06-14	draft-linkova-v6ops-conditional-ras
	2017-06-12	draft-palet-v6ops-rfc7084-bis-transition
	2017-06-11	draft-palet-v6ops-rfc7084-bis2
	2017-06-11	draft-palet-v6ops-rfc7084-bis4-hncp

https://tools.ietf.org/html/draft-ietf-v6ops-rfc7084-bis
  "Basic Requirements for IPv6 Customer Edge Routers", Jordi Palet,
  2017-06-12

https://tools.ietf.org/html/draft-palet-v6ops-rfc7084-bis-transition
  "Transition Requirements for IPv6 Customer Edge Routers", Jordi Palet,
  2017-06-12

https://tools.ietf.org/html/draft-palet-v6ops-rfc7084-bis2
  "Minimum Requirements for IPv6-only Customer Edge Routers", Jordi Palet,
  2017-06-11

https://tools.ietf.org/html/draft-palet-v6ops-rfc7084-bis4-hncp
  "Basic Requirements for IPv6 Customer Edge Routers with HNCP", Jordi Palet,
  2017-06-11

---

From: [email-masked]
Date: Fri, 16 Jun 2017 08:34:40 +0200

>  "Basic Requirements for IPv6 Customer Edge Routers", Jordi Palet,

I would prefer to see two IPv6 CE documents.
One updated 7084 with HNCP requirements and the transition mechanisms taken out.
One only for the transition mechanisms. Although that might have some overlap with draft-ietf-softwire-unified-cpe

The first is closest to Jordi's rfc7084-bis4-hncp (although there are not HNCP requirements there yet).
The second rfc7084-bis-transition. Although I have issues with the approach of recommending all options and not making a choice. When the IETF leaves it to the market to decide, because it cannot reach consensus, then we should consider that, given this is the closest thing we have to a "recommendations to the market" style document.

I also have issues with the author of these documents replacing the original author set with himself in the documents.

Cheers,
Ole

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 16 Jun 2017 20:07:15 +0200

Hi Ole,

Let me explain how this started.

Long time ago, I asked in the list to the authors to work on this. As I got no answer, I asked the authors writing them to the emails in the RFC copied the chairs and ADs.

I asked them several times, even during the Seoul meeting I asked to meet there. I never got an answer. I never understood that attitude, I think is really impolite. I always answer my emails … and even more if those are questions related to the IETF work.

So, I asked the chairs about how to proceed, they suggested me to ask the RFC editor for the XML file and take over that work. I’ve never been in that situation, but I checked similar situations and saw that the authors get replaced and there is some text recognizing them.

In fact, this is the same situation in between you as co-author of RFC6204 and RFC7084, right?

I guess it is related to the need to avoid the need for each “older” author to ack when a new version is uploaded, right?

I’m not feeling there is anything wrong, so if I’m wrong, please explain it, and fine to change whatever is needed, as usual.

I guess you’re referring anyway to the authors of the actual –bis which is a WG item or even those that I have submitted last week removing the transition stuff, because if you look at the content of the one for the transition it is probably over 90% new, right?

If you have any suggestions about the HNCP part, or how to approach the transition, please let us know. For the transition, I suggested moving to MUST at least for some of them when I started this work, but the list didn’t liked that idea. I also think if we do that, we should also have almost everything as MUST in the 7084-bis (w/o the transition).

Regards,
Jordi

-----Mensaje original-----
De: v6ops <[email-masked]> en nombre de <[email-masked]>
Responder a: <[email-masked]>
Fecha: viernes, 16 de junio de 2017, 8:34
Para: Fred Baker <[email-masked]>
CC: IPv6 Operations <[email-masked]>
Asunto: Re: [v6ops] New drafts

    

    Cheers,
    Ole
    _______________________________________________
    v6ops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/v6ops

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Noah <[email-masked]>
Date: Sat, 17 Jun 2017 11:49:36 +0300

Hi Fred

Thank you for sharing this drafts.

Do we also have similar ones for end user devices ref:

1.Android with updates Linux Kernel
2.MacOS/Windows

Noah

On 15 Jun 2017 5:07 p.m., "Fred Baker" <[email-masked]> wrote:

We have several new drafts that the chairs would like working group
discussion on, if only to gauge interest. Jen sent a note regarding hers a
moment ago. Jordi has, following feedback, divided 70844bis, and we are
looking for commentary on each.

https://tools.ietf.org/html/draft-palet-v6ops-rfc7084-bis4-hncp
  "Basic Requirements for IPv6 Customer Edge Routers with HNCP", Jordi
Palet,
  2017-06-11

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sat, 17 Jun 2017 11:12:26 +0200

Hi Noah,

There is a document for that of course, but it belongs to another WG:

https://datatracker.ietf.org/doc/draft-ietf-6man-rfc6434-bis

Regards,
Jordi

-----Mensaje original-----
De: v6ops <[email-masked]> en nombre de Noah <[email-masked]>
Responder a: <[email-masked]>
Fecha: sábado, 17 de junio de 2017, 10:49
Para: Fred Baker <[email-masked]>
CC: IPv6 Operations <[email-masked]>
Asunto: Re: [v6ops] New drafts

    Hi Fred

    
    Noah

---

From: Fred Baker <[email-masked]>
Date: Sat, 17 Jun 2017 13:25:03 -0700

> On Jun 17, 2017, at 1:49 AM, Noah <[email-masked]> wrote:
> 
> Hi Fred
> 

I'm not sure I understand your question. 

As Jordi points out, there is an update to IPv6 Node Requirements in 6man. This document is an important part of the basis for the IPv6 Ready Logo program, the US Government "Planning Guide/Roadmap Toward IPv6 Adoption", and RIPE 554.  It is not specific to any given platform; it is intended to describe all platforms. If you're looking for something specific to Android, Linux, MacOS, Windows, or anything else (such as perhaps iOS or IoT MCU RTOS's), no, we don't have product-specific documents, and they are not part of our charter.

Does that address what you're looking for, or are you looking for something else?

---

From: Noah <[email-masked]>
Date: Mon, 19 Jun 2017 17:34:45 +0300

Hi Fred

As Jordi points out, there is an update to IPv6 Node Requirements in 6man.
This document is an important part of the basis for the IPv6 Ready Logo
program, the US Government "Planning Guide/Roadmap Toward IPv6 Adoption",
and RIPE 554.  It is not specific to any given platform; it is intended to
describe all platforms. If you're looking for something specific to
Android, Linux, MacOS, Windows, or anything else (such as perhaps iOS or
IoT MCU RTOS's), no, we don't have product-specific documents, and they are
not part of our charter.

What Jordi shared earlier is what I was looking for and got the answer in
there.

Does that address what you're looking for, or are you looking for something
else?

It does clarify and thank you for your feeback.

Noah