Subject: [v6ops] comments on draft-ietf-v6ops-rfc7084-bis-02

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 5 Jun 2017 16:28:51 +0000

I've reviewed draft-ietf-v6ops-rfc7084-bis-02 and these are my comments.

General: While I support providing CE router vendors with information on IPv6 transition technologies, I think that an RFC7084-bis is not the right way to do this, and this particular draft tries to do more than just add those transition technologies; some of these additional items I don't support. I think this draft weakens RFC7084 by adding such a lengthy list of transition technologies and adding other requirements and text that are not broadly useful. I would prefer a stand-alone document that described just the transition technologies.

Specific comments:
3. Usage scenarios
I don't find this new and very lengthy section to be more useful than the existing simple statement of "This document defines basic IPv6 features for a residential or small-office router". I question the need to expand the original simple sentence into this lengthy section (6 bullets and 8 paragraphs).
I don't understand what "exporting IPv6 services" means. I don't understand why discussion of IPv4 NAT configuration is particularly relevant as part of preamble discussion for the requirements in this draft.

5.1 General Requirements, G-5
I don't understand what additional functionality G-5 provides that was not covered by G-4. G-5 seems redundant.

5.5.  IPv4 Multicast Support
I disagree with recommending this functionality in all CE Routers. It is very definitely not necessary in a basic CE router. 

8. ANNEX A: Code Considerations
I disagree with much of the editorializing and assumptions made in this section and would prefer to see this section removed. Every CE Router vendor (and ISP) must decide for themselves whether using open source code is appropriate for them. Licenses must be carefully examined, as some license can be very problematic for vendors and for ISPs that ship the vendor's products. Claiming that existence of open source code means cost of developing code is negligible ["negligent" is probably not the intended word] is unsubstantiated and therefore inappropriate. Claiming that "only integration and testing cost may become a minor issue" is also inaccurate and inappropriate. The more code a CE router has, the more testing that has to be done, and this cannot be assumed to be minor. It also creates usability and support issues, if the functionality is presented via the UI. Every additional feature adds cost to these very low margin devices.

Barbara

---

From: Tore Anderson <[email-masked]>
Date: Tue, 6 Jun 2017 07:06:03 +0200

* "STARK, BARBARA H" <[email-masked]>

> General: While I support providing CE router vendors with information
> on IPv6 transition technologies, I think that an RFC7084-bis is not
> the right way to do this, and this particular draft tries to do more
> than just add those transition technologies; some of these additional
> items I don't support. I think this draft weakens RFC7084 by adding
> such a lengthy list of transition technologies and adding other
> requirements and text that are not broadly useful. I would prefer a
> stand-alone document that described just the transition technologies.

I wholeheartedly agree.

Tore

---

From: [email-masked]
Date: Tue, 6 Jun 2017 08:47:40 +0200

What Barbara said.
A good start would be to put these requirements in its own document.

Ole

> On 5 Jun 2017, at 18:28, STARK, BARBARA H <[email-masked]> wrote:
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Tore Anderson <[email-masked]>
Date: Tue, 6 Jun 2017 09:22:00 +0200

> I don't understand what additional functionality G-5 provides that
> was not covered by G-4. G-5 seems redundant.

G-4 only requires the CE router to set the Router Lifetime to 0 in any
RAs it originates. A significant amount of time might elapse between
the loss of the WAN connectivity and the transmission of the next
periodic unsolicited RA. During this time, the IPv6 CE router would
attract and blackhole IPv6 traffic.

The key word in G-5 is «immediately». This ensures the hosts are
notified as soon as possible that the IPv6 CE router is no longer able
to provide access to the IPv6 Internet, allowing them to fail over to
other IPv6 routers and/or IPv4 in a much more graceful manner.

Tore