Subject: Re: [v6ops] FW: New Version Notification for draft-palet-v6ops-ipv6-only-01.txt

From: Lee Howard <[email-masked]>
Date: Fri, 04 Aug 2017 10:20:35 -0400

Top posting review (as individual, not co-chair):
I’m skipping grammar edits; we’ll get to that later.

"we MUST NOT talk about a whole network having a "single and uniform"
status regarding IPv6,”
I don’t think you mean rfc2119 MUST NOT. I think you mean “we are unable
to” or “can not.” I would suggest removing rfc2119 language from the
document; it’s a terminology doc, not a specification.
I also disagree with the point: a network may be as small as two hosts,
and could well have a uniform state.

I’d cut most of the context; I don’t think it’s necessary to understand
the definitions, and I it’s redundant with statements elsewhere.

I’m confused by the reference to forwarding IP at layer 2. Rather, I would
say:
IPv6-only	There is no connectivity to IPv4 through any transition
technology.
IPv6-only host	IPv4 is unconfigured and/or disabled on all interfaces on
the host.
IPv6-only router IPv4 is disabled and/or unconfigured and not forwarded on
any interface.
IPv6-only LAN	IPv4 is disabled and/or unconfigured on all hosts on the LAN.
IPv6-only WAN	There is no transition mechanism available anywhere on the
WAN.

Thus, and IPv6-only host may exist on a WAN that is not IPv6-only. An
IPv6-only host might exist on an IPv6-only LAN that is part of a WAN that
is not IPv6-only.

In addition, I propose:
Native dual-stack	Both IPv4 and IPv6 are natively configured.
Transitional dual-stack	IPv6 is natively configured, but IPv4 works only
via a transition mechanism.
Dual-stack		Both IPv4 and IPv6 are reachable; method is not specified.

I’m not sure we need terms for native IPv6+NATted IPv4 (most common case
today), or for native IPv4 plus transitional IPv6 (6rd, DS-Lite). They
could be subsumed under “transitional dual-stack.”

Lee

On 8/3/17, 4:31 AM, "v6ops on behalf of JORDI PALET MARTINEZ"
<[email-masked] on behalf of [email-masked]> wrote:

>Hi,
>
>I’ve posted a new version of this document.
>
>https://datatracker.ietf.org/doc/draft-palet-v6ops-ipv6-only/
>
>Comments welcome!
>
>Regards,
>Jordi
> 
>
>-----Mensaje original-----
>De: <[email-masked]>
>Responder a: <[email-masked]>
>Fecha: jueves, 3 de agosto de 2017, 10:28
>Para: Jordi Palet <[email-masked]>, Jordi Palet Martinez
><[email-masked]>
>Asunto: New Version Notification for draft-palet-v6ops-ipv6-only-01.txt
>
>    
>    A new version of I-D, draft-palet-v6ops-ipv6-only-01.txt
>    has been successfully submitted by Jordi Palet Martinez and posted to
>the
>    IETF repository.
>    
>    Name:		draft-palet-v6ops-ipv6-only
>    Revision:	01
>    Title:		IPv6-only Terminology Definition
>    Document date:	2017-08-03
>    Group:		Individual Submission
>    Pages:		5
>    URL:          
>https://www.ietf.org/internet-drafts/draft-palet-v6ops-ipv6-only-01.txt
>    Status:       
>https://datatracker.ietf.org/doc/draft-palet-v6ops-ipv6-only/
>    Htmlized:     
>https://tools.ietf.org/html/draft-palet-v6ops-ipv6-only-01
>    Htmlized:     
>https://datatracker.ietf.org/doc/html/draft-palet-v6ops-ipv6-only-01
>    Diff:         
>https://www.ietf.org/rfcdiff?url2=draft-palet-v6ops-ipv6-only-01
>    
>    Abstract:
>       This document clarify the terminology regarding the usage of
>       expressions such as "IPv6-only", in order to avoid confusions when
>       using them in IETF and other documents, in reference to what is the
>       actual functionalities being used (not the actual protocol
>support).
>    
>                  
>            
>    
>    
>    Please note that it may take a couple of minutes from the time of
>submission
>    until the htmlized version and diff are available at tools.ietf.org.
>    
>    The IETF Secretariat
>    
>    
>
>
>
>**********************************************
>IPv4 is over
>Are you ready for the new Internet ?
>http://www.consulintel.es
>The IPv6 Company
>
>This electronic message contains information which may be privileged or
>confidential. The information is intended to be for the use of the
>individual(s) named above. If you are not the intended recipient be aware
>that any disclosure, copying, distribution or use of the contents of this
>information, including attached files, is prohibited.
>
>
>
>_______________________________________________
>v6ops mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/v6ops

---

From: Tim Chown <[email-masked]>
Date: Fri, 4 Aug 2017 14:29:41 +0000

Hi Jordi,

Also slacking with top-post…

It occurs to me reading Lee’s comments you might want to look at https://tools.ietf.org/html/rfc4852

And the terminology section there, and Table 1, for some inspiration.

I really miss Jim :/

Tim 

> On 4 Aug 2017, at 15:20, Lee Howard <[email-masked]> wrote:
>

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 04 Aug 2017 17:33:49 +0200

Hi Lee,

Thousands thanks for the comments!

Below in-line

Regards,
Jordi

-----Mensaje original-----
De: Lee Howard <[email-masked]>
Responder a: <[email-masked]>
Fecha: viernes, 4 de agosto de 2017, 16:20
Para: <[email-masked]>, <[email-masked]>
Asunto: Re: [v6ops] FW: New Version Notification for draft-palet-v6ops-ipv6-only-01.txt

[Jordi] Agreed, will do a new version in a couple of days or so (hoping there are new inputs by then) and can change that across all the document.

[Jordi] I was thinking that the “in general” before that sentence setup that context, but will find out something to make it not contradicting your point, which obviously I agree. Maybe: “… in most of the cases, except maybe some very simple networks, it is difficult to find whole networks which have a "single and uniform" status regarding IPv6, at least not in the early deployment stages.“

[Jordi] While I see your point, I’m trying to make sure that folks reading the document from scratch, don’t get the appropriate context. I think many of us, which have already done *real* deployment in several networks, worked with different technologies, etc., have this context clear, but I’m not really sure about “foreigners”. I need to think about this, maybe having most of this text in an annex …

[Jordi] I got this comment already yesterday. Initially I responded that maybe “forwarding” is not the right term, and then I was thinking myself about networks using MPLS or other “access” technologies, which are instead of layer 2, layer 3, or can be both, etc,, … so instead considering something like “network transporting natively IPv6-only”.

[Jordi] I think we don’t agree here with some of the definitions. For example, IPv6-only you basically say “no IPv4 at all”, but actually what I’m trying to say is that, in that part of the network, let’s take the example of the access network, in a cellular operator that only provides single stack IPv6 PDP context, but is providing a NAT64 and the smartphones have CLAT. So for me, if I say “IPv6-only-WAN”, I’m meaning that the WAN link is only “transporting natively IPv6 traffic”, but that doesn't preclude the operator have a NAT64 so the user device apps can access to end-IPv6-only-sites. It may even happen that the NAT64 is an external service, not in this operator itself. So taking your definitions, “no transition” means that you “disable” the possibility of having some IPv4 “transported somehow as IPv6”.
Note that what you’re suggesting could end-up meaning that the operator of an IPv6-only network “disables” (or somehow filters), the capability of transporting IPv4 on top of the IPv6 infrastructure.
So will you agree that what we mean with IPv6-only is that there is ONLY IPv6 *native* support, but other protocols (IPv4) can be transported using the IPv6 network?.

[Jordi] I think that works as well with my previous definition of native support. An IPv6-only host has not IPv4 configured (even if the stack is dual-stack, this is irrelevant here), and it may be connected to a non-IPv6-only WAN, etc.. 
    
    In addition, I propose:

[Jordi] native dual-stack and dual-stack are fine. However transitional dual-stack we may want to say if the “transport” is native IPv4 or native IPv6 – furthermore, I think if we agree in my previous point about the definition of IPv6-only, we don’t need this, because becomes irrelevant.

[Jordi] Agree on this.
    
    Lee

    

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.