Subject: [v6ops] FW: New Version Notification for draft-palet-v6ops-ipv6-only-01.txt

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 03 Aug 2017 10:31:28 +0200

Hi,

I’ve posted a new version of this document.

https://datatracker.ietf.org/doc/draft-palet-v6ops-ipv6-only/

Comments welcome!

Regards,
Jordi

-----Mensaje original-----
De: <[email-masked]>
Responder a: <[email-masked]>
Fecha: jueves, 3 de agosto de 2017, 10:28
Para: Jordi Palet <[email-masked]>, Jordi Palet Martinez <[email-masked]>
Asunto: New Version Notification for draft-palet-v6ops-ipv6-only-01.txt

    A new version of I-D, draft-palet-v6ops-ipv6-only-01.txt
    has been successfully submitted by Jordi Palet Martinez and posted to the
    IETF repository.
    
    Name:		draft-palet-v6ops-ipv6-only
    Revision:	01
    Title:		IPv6-only Terminology Definition
    Document date:	2017-08-03
    Group:		Individual Submission
    Pages:		5
    URL:            https://www.ietf.org/internet-drafts/draft-palet-v6ops-ipv6-only-01.txt
    Status:         https://datatracker.ietf.org/doc/draft-palet-v6ops-ipv6-only/
    Htmlized:       https://tools.ietf.org/html/draft-palet-v6ops-ipv6-only-01
    Htmlized:       https://datatracker.ietf.org/doc/html/draft-palet-v6ops-ipv6-only-01
    Diff:           https://www.ietf.org/rfcdiff?url2=draft-palet-v6ops-ipv6-only-01
    
    Abstract:
       This document clarify the terminology regarding the usage of
       expressions such as "IPv6-only", in order to avoid confusions when
       using them in IETF and other documents, in reference to what is the
       actual functionalities being used (not the actual protocol support).

    
    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at tools.ietf.org.
    
    The IETF Secretariat

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Philip Homburg <[email-masked]>
Date: Thu, 03 Aug 2017 10:47:52 +0200

> https://datatracker.ietf.org/doc/draft-palet-v6ops-ipv6-only/

There is nothing IPv6-only about NAT64. So please stop doing this.

The only definition of IPv6-only that makes sense in the long term is when
there is no access to the IPv4 network at all. That is literally IPv6-only.

Anything else is just bound to confuse people outside our small group.

What we are discussing are IPv4 over IPv6 tunneling/translation techniques.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 03 Aug 2017 10:54:08 +0200

I don’t agree.

As one of the co-chairs confirmed in the last meeting (and actually somehow called for this work), many folks even within IETF/v6ops are using IPv6-only for very different things.

This is creating in many situations conversations that talk about different issues but we don’t realize it until we wasted too much time. I think there is a need to make sure that we all use the same terminology.

So, this is not about NAT64, it is about the correct usage of IPv6-only, scoping it to the right part/s of the network or even the complete network end-to-end.

Anyway, let’s see others opinions.

Regards,
Jordi

---

From: Stephen Strowes <[email-masked]>
Date: Thu, 3 Aug 2017 11:34:59 +0200

I agree with this line:

"we MUST NOT use the terminology "IPv6-only" in a generic way".

Agreed. I find that expanding "IPv6-only" to include mechanisms such as 
NAT64 is contradictory and confusing.

I don't think it's useful to state, for example, that an "IPv6-only 
access network" MAY have means to access the IPv4 network. But I do 
think it's useful to state that a network is, say, IPv6+NAT64.

S.

On 03/08/2017 10:54, JORDI PALET MARTINEZ wrote:
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 03 Aug 2017 12:50:14 +0200

Hi Stephen,

Thanks for your input.

However, I’ve a question regarding your last paragraph, just in case I’m not getting it correctly.

If we state something such as “IPv6+specific transition” mechanism (your example IPv6+NAT64), we can have “tons” of possible variations, instead of half a dozen or so, and in some cases, the transition mechanism can be deployed in different parts of the network (the NAT64 can be in the core, upstream router, etc.). So I think that speaking about a specific mechanism instead of which part of the network is IPv6-only. You see my point or I’m missing anything?

Saying it in another way, do you think the actual examples referring to what specific part of the network are IPv6-only, is fine or that will miss a relevant part of the picture somehow?

Regards,
Jordi

-----Mensaje original-----
De: Stephen Strowes <[email-masked]>
Responder a: <[email-masked]>
Fecha: jueves, 3 de agosto de 2017, 11:35
Para: <[email-masked]>, <[email-masked]>
Asunto: Re: [v6ops] FW: New Version Notification for draft-palet-v6ops-ipv6-only-01.txt

    I agree with this line:

    
    
    S.

---

From: Stephen Strowes <[email-masked]>
Date: Thu, 3 Aug 2017 13:55:14 +0200

Hi,

> If we state something such as “IPv6+specific transition” mechanism (your example IPv6+NAT64), we can have “tons” of possible variations, instead of half a dozen or so, and in some cases, the transi…

I see your point but I'm not suggesting a combinatorial approach to 
describing networks.

I am suggesting that if you describe an IPv6 network which offers a 
means to reach v4 networks as "IPv6-only", then the terminology is wrong.

Section 5 refers to cellular networks, devices, and transition 
technologies. Although I know I can look at some of these networks and 
describe traffic in and out of my device as being IPv6-only, to refer to 
those networks as "IPv6-only" would be misleading. I can't imagine that 
description would ever be useful to folks outside of some very specific 
contexts.

S.

---

From: Tim Chown <[email-masked]>
Date: Thu, 3 Aug 2017 12:11:53 +0000

On 3 Aug 2017, at 12:55, Stephen Strowes <[email-masked]> wrote:
> I see your point but I'm not suggesting a combinatorial approach to describing networks.
> 
> I am suggesting that if you describe an IPv6 network which offers a means to reach v4 networks as "IPv6-only", then the terminology is wrong.
> 
> Section 5 refers to cellular networks, devices, and transition technologies. Although I know I can look at some of these networks and describe traffic in and out of my device as being IPv6-only, to refer to those networks as "IPv6-only" would be misleading. I can't imagine that description would ever be useful to folks outside of some very specific contexts.

I suppose another way of looking at it is to ask on which elements of a network IPv4 support can be dropped, so that only IPv6 packets are carried, and only IPv6 needs to be configured and managed.

In that sense, a network can be "IPv6 only” even though customer IPv4 traffic is being tunnelled or translated (either double with CLAT, or single with DNS64 shenanigans) through it.

Tim

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 03 Aug 2017 14:43:05 +0200

[Jordi] This is actually the way I’m looking at it: If the access network is IPv6-only, it means IPv4 is not configured/managed there, but of course, there may be IPv4 traffic carried out in IPv6 packets.
 … so not sure if I’m not using the right wording if folks didn’t got it?

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 03 Aug 2017 14:52:18 +0200

I think I found the way to make it more clear for the next version.

I have changed the last paragraph in section 2 from:
      From that perspective, we define the "IPv6-only" status depending on
      if there is actual layer-2 forwarding of IPv4.

To:
      From that perspective, we define the "IPv6-only" status in a given part(s) 
      of a network, depending on if there is actual layer-2 forwarding of IPv4, so 
      IPv4 is not configured neither managed.

Regards,
Jordi

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 03 Aug 2017 15:02:30 +0200

Hi Stephen,

Now I see your point, but I think is clear reading the text I just posted:

What I’m going to do is to take that paragraph out of the actual “context” section, and create a new one to stress it: “Definition of IPv6-only”.

Furthermore, what I’ve at section 5 is referring to a specific part, IPv6-only WAN, and again I read it correctly (others may tell if I’m wrong), because the example of an IPv6-only cellular WAN/access network is a network that is transporting only IPv6 at layer-2.

-----Mensaje original-----
De: Stephen Strowes <[email-masked]>
Responder a: <[email-masked]>
Fecha: jueves, 3 de agosto de 2017, 13:55
Para: <[email-masked]>, <[email-masked]>
Asunto: Re: [v6ops] FW: New Version Notification for draft-palet-v6ops-ipv6-only-01.txt

    Hi,

    

    S.

---

From: Stephen Strowes <[email-masked]>
Date: Thu, 3 Aug 2017 15:47:05 +0200

> I suppose another way of looking at it is to ask on which elements of a network IPv4 support can be dropped, so that only IPv6 packets are carried, and only IPv6 needs to be configured and managed.

This would be a nice characterisation. And when cast in that light, 
strongly related to parts of 
https://tools.ietf.org/html/draft-ietf-sunset4-gapanalysis

S.