Subject: [v6ops] Fwd: I-D Action: draft-ietf-v6ops-unique-ipv6-prefix-per-host-07.txt

From: DY Kim <[email-masked]>
Date: Fri, 4 Aug 2017 11:04:22 +0900

In regards to the wording "provider managed shared network”.

Does ‘provider’ here mean exclusively any commercial ISPs or the kind? Can it also be interpreted as ‘site managed shared network’ where site could be any AS?

---
DY

> Begin forwarded message:
> 
> Subject: [v6ops] I-D Action: draft-ietf-v6ops-unique-ipv6-prefix-per-host-07.txt
> Date: 4 August 2017 at 10:20:53 GMT+9
> To: [email-masked]
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the IPv6 Operations WG of the IETF.
> 
>        Title           : Unique IPv6 Prefix Per Host
>        Authors         : John Jason Brzozowski
>                          Gunter Van De Velde
> 	Filename        : draft-ietf-v6ops-unique-ipv6-prefix-per-host-07.txt
> 	Pages           : 8
> 	Date            : 2017-07-31
> 
> Abstract:
>   In some IPv6 environments, the need has arisen for hosts to be able
>   to utilize a unique IPv6 prefix, even though the link or media may be
>   shared.  Typically hosts (subscribers) on a shared network, either
>   wired or wireless, such as Ethernet, WiFi, etc., will acquire unique
>   IPv6 addresses from a common IPv6 prefix that is allocated or
>   assigned for use on a specific link.
> 
>   In most deployments today, IPv6 address assignment from a single IPv6
>   prefix on a shared network is done by either using IPv6 stateless
>   address auto-configuration (SLAAC) and/or stateful DHCPv6.  While
>   this is still viable and operates as designed, there are some large
>   scale environments where this concept introduces significant
>   performance challenges and implications, specifically related to IPv6
>   router and neighbor discovery.
> 
>   This document outlines an approach utilising existing IPv6 protocols
>   to allow hosts to be assigned a unique IPv6 prefix (instead of a
>   unique IPv6 address from a shared IPv6 prefix).  Benefits of unique
>   IPv6 prefix over a unique IPv6 address from the service provider
>   include improved subscriber isolation and enhanced subscriber
>   management.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-v6ops-unique-ipv6-prefix-per-host/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-v6ops-unique-ipv6-prefix-per-host-07
> https://datatracker.ietf.org/doc/html/draft-ietf-v6ops-unique-ipv6-prefix-per-host-07
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-v6ops-unique-ipv6-prefix-per-host-07
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: "Brzozowski, John" <[email-masked]>
Date: Fri, 4 Aug 2017 10:27:25 +0000

The concept in the I-D applies to any and all types of layer 3 networks where IPv6 is supported.  We have discussed enterprise and mobile use cases with other potential adopters.  This is not exclusive to SP Wi-Fi networks that are open or closed.

John
+1-484-962-0060

From: v6ops <[email-masked]> on behalf of DY Kim <[email-masked]>
Date: Thursday, August 3, 2017 at 22:04
To: v6ops <[email-masked]>
Subject: [v6ops] Fwd: I-D Action: draft-ietf-v6ops-unique-ipv6-prefix-per-host-07.txt

---
DY

Begin forwarded message:

Subject: [v6ops] I-D Action: draft-ietf-v6ops-unique-ipv6-prefix-per-host-07.txt
Date: 4 August 2017 at 10:20:53 GMT+9
To: [email-masked]<mailto:[email-masked]>

Abstract: