Subject: [v6ops] Experiments over Happy Eyeballs

From: "Grenier Pierre-Jean (ASP)" <[email-masked]>
Date: Tue, 8 Aug 2017 18:30:16 +0200

Hi all!

I know you are reviewing a proposal for updating the RFC6555 about the Happy Eyeballs. I recently designed a tool to experiment over any implementation of the algorithm and showed it to David Schinazi and Tommy Pauly, who wrote the draft. They suggested I should let you know about it.

So here it is: http://ds.ds.6cn-prs.6cn.io. It allows the user to introduce delays over A and AAAA DNS answers, but most importantly over the SYN-ACK answers from the server. You can thus manipulate the delays that directly influence a Happy Eyeballs' decision. In other terms: it allows you to test your implementation of Happy Eyeballs, or compare the efficiency of two different implementations (see how often you go over IPv4 or IPv6, see how long the client had to wait between the initial request and the final answer, etc.).

I hope this can be helpful. Please feel free to use it if needed.

Regards,
— Pierre-Jean Grenier

---

From: Ca By <[email-masked]>
Date: Tue, 08 Aug 2017 19:36:52 +0000

Neat tool.

Using an ipv6-only iphone on 11 beta, i was not able to trigger an ipv4
result with high delay numbers. No failures either, it was always success
on v6.

It would be interesting if you could update the tool to exercise some of
the functions in section 7 of the I-D, especially 7.2 using the “Last
Resort”

Thanks,
Cameron

On Tue, Aug 8, 2017 at 11:07 AM Grenier Pierre-Jean (ASP) <
[email-masked]> wrote:

> Hi all!
>
> I know you are reviewing a proposal for updating the RFC6555 about the
> Happy Eyeballs. I recently designed a tool to experiment over any
> implementation of the algorithm and showed it to David Schinazi and Tommy
> Pauly, who wrote the draft. They suggested I should let you know about it.
>
> So here it is: http://ds.ds.6cn-prs.6cn.io. It allows the user to
> introduce delays over A and AAAA DNS answers, but most importantly over the
> SYN-ACK answers from the server. You can thus manipulate the delays that
> directly influence a Happy Eyeballs' decision. In other terms: it allows
> you to test your implementation of Happy Eyeballs, or compare the
> efficiency of two different implementations (see how often you go over IPv4
> or IPv6, see how long the client had to wait between the initial request
> and the final answer, etc.).
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>