Subject: Re: [v6ops] Turning on IPv6 Routers

From: Lee Howard <[email-masked]>
Date: Thu, 03 Aug 2017 08:24:49 -0400

On 7/20/17, 5:25 PM, "v6ops on behalf of Nick Hilliard"
<[email-masked] on behalf of [email-masked]> wrote:

>Fred Baker wrote:
>> "If IPv4 router operation is enabled by default, enable IPv6 router
>> operation by default."
>
>this is undoubtedly well-intentioned, and the idealist bit in me
>sympathises with the principal.  However with my enable hat on, a
>recommendation like this isn't going to fix any problem associated with
>ipv6 adoption.

I completely disagree, but it’s dependent on where the router exists.
For a home gateway router, “IPv6 on by default” would increase the number
of people using IPv6, although I have no way to estimate the impact.

For an enterprise edge router, “IPv6 on by default” might accidentally get
IPv6 deployed. There’s potential risk if “IPv6 firewall on by default”
isn’t also enabled, but this is mentioned in the Security Considerations
section.

In data centers and core networks, there isn’t a strong case either way,
because those configurations should be tightly managed, and accidentally
enabling IPv6 is unlikely to leak anywhere else.

>
>The problems with ipv6 adoption revolve entirely around cost/benefit.

Well, yes, but not always in the way I think you mean it.
Tens of millions of people use IPv6 daily without ever having done a
cost-benefit analysis.

>Pressing problems still include things that should have been resolved
>years ago, e.g. vendors charging extra for ipv6 support (today's
>bugbear: provisioning system vendors, please note that charging extra
>for basic ipv6 functionality is destructive in the long term and
>corrosive for your customer relationships)

Yeah, that’s a bad vendor relationship, and a vendor doing that must be
pretty confident that their customer otherwise loves their product and
isn’t tempted to find an alternative vendor.

>
>As a separate issue, from an operational point of view, implicit
>enabling of functionality in one area when it's explicitly enabled in
>another is something that needs to be handled carefully because
>otherwise you can end up violating the principal of least astonishment.

Anyone astonished by IPv6 working needs to be astonished.

Lee

>
>Nick
>
>_______________________________________________
>v6ops mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: "Ackermann, Michael" <[email-masked]>
Date: Thu, 3 Aug 2017 13:07:39 +0000

Just a quick 2 cents from the Enterprise perspective. 

Unfortunately (IMHO),  most Enterprises expressly and purposely turn IPv6 off in routers.     As mentioned,  the business case(s) are still not obvious and it is thus seen only as excessive traffic and potential problems.  

Please don't shoot the messenger.  

Thanks

Mike

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Lee Howard
Sent: Thursday, August 3, 2017 8:25 AM
To: Nick Hilliard <[email-masked]>; Fred Baker <[email-masked]>
Cc: IPv6 Ops WG <[email-masked]>; 6man WG <[email-masked]>; [email-masked]
Subject: Re: [v6ops] Turning on IPv6 Routers

I completely disagree, but it’s dependent on where the router exists.
For a home gateway router, “IPv6 on by default” would increase the number of people using IPv6, although I have no way to estimate the impact.

For an enterprise edge router, “IPv6 on by default” might accidentally get
IPv6 deployed. There’s potential risk if “IPv6 firewall on by default”
isn’t also enabled, but this is mentioned in the Security Considerations section.

In data centers and core networks, there isn’t a strong case either way, because those configurations should be tightly managed, and accidentally enabling IPv6 is unlikely to leak anywhere else.

Well, yes, but not always in the way I think you mean it.
Tens of millions of people use IPv6 daily without ever having done a cost-benefit analysis.

>corrosive for your customer relationships)

Yeah, that’s a bad vendor relationship, and a vendor doing that must be pretty confident that their customer otherwise loves their product and isn’t tempted to find an alternative vendor.

Lee

>Nick

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

The information contained in this communication is highly confidential and is intended solely for the use of the individual(s) to whom this communication is directed. If you are not the intended recipient, you are hereby notified that any viewing, copying, disclosure or distribution of this information is prohibited. Please notify the sender, by electronic mail or telephone, of any unintended receipt and delete the original message without making any copies.
 
 Blue Cross Blue Shield of Michigan and Blue Care Network of Michigan are nonprofit corporations and independent licensees of the Blue Cross and Blue Shield Association.

---

From: Simon Hobson <[email-masked]>
Date: Thu, 3 Aug 2017 19:46:28 +0100

> Unfortunately (IMHO),  most Enterprises expressly and purposely turn IPv6 off in routers.     As mentioned,  the business case(s) are still not obvious and it is thus seen only as excessive traffic…

From my perspective in a small It services business, that's the case. WHile many, probably all, client sites will be running IPv6 at a LL level - I don't think that any of them realise it's there, and all of them would probably turn the feature off if a router defaulted to providing IPv6 connectivity on the grounds of "too complicated".
I'll add that IME very few small business networks have things like properly setup DNS, so it's really really common to have to access things by IP address.

> Please don't shoot the messenger.  

I'm not, I think I'm stood there alongside you as a wider target.