Subject: [v6ops] Ben Campbell's No Objection on draft-ietf-v6ops-rfc6555bis-06: (with COMMENT)

From: Ben Campbell <[email-masked]>
Date: Tue, 24 Oct 2017 19:30:04 -0700

Ben Campbell has entered the following ballot position for
draft-ietf-v6ops-rfc6555bis-06: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-v6ops-rfc6555bis/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Substantive Comments:

- I agree with Adam's comments about normative language.

-4, 2nd paragraph, last sentence:
"across networks" and "network changes" are ambiguous. I think you are talking
about moving a device from one access network to another, but "across networks"
could be interpreted to mean "sending the data across networks". "Network
changes" could refer to changes in network configuration.

-10: I don't understand what you mean by "direct" vs "indirect" security
considerations.

Editorial Comments:

- Abstract: Please mention that this obsoletes 6555 in the abstract. (The intro
already does so.)

- 7.2, last paragraph: The pattern "... recommended at 2 seconds" does not make
grammatical sense. I would assume there are missing words, but I see the same
pattern occur several times in the document. I suggest "recommended to be..."

---

From: Tommy Pauly <[email-masked]>
Date: Fri, 27 Oct 2017 07:07:54 -0700

> On Oct 24, 2017, at 7:30 PM, Ben Campbell <[email-masked]> wrote:
> 

Hi Ben,

Thanks for the comments! The update at:

https://tools.ietf.org/html/draft-ietf-v6ops-rfc6555bis-07 <https://tools.ietf.org/html/draft-ietf-v6ops-rfc6555bis-07>

Should address all of these. Responses inline.

Thanks,
Tommy

> - I agree with Adam's comments about normative language.

Yes, us too. These have been cleaned up.
> changes" could refer to changes in network configuration.

Fixed the wording to be more clear that the information shouldn't be shared between different interfaces, and that changing a device's network attachment should clear the data.
> -10: I don't understand what you mean by "direct" vs "indirect" security

Removed the line about "direct" security considerations.
> - Abstract: Please mention that this obsoletes 6555 in the abstract. (The intro

Mentioned.
> pattern occur several times in the document. I suggest "recommended to be..."

Switched to "to be" throughout the document.

---

From: Ben Campbell <[email-masked]>
Date: Mon, 30 Oct 2017 20:38:40 -0500

Thanks, that all sounds good.

Ben.

> On Oct 27, 2017, at 9:07 AM, Tommy Pauly <[email-masked]> wrote:
> 
> 
> 
> https://tools.ietf.org/html/draft-ietf-v6ops-rfc6555bis-07
>

---

From: Warren Kumari <[email-masked]>
Date: Tue, 31 Oct 2017 13:28:02 -0400

> Thanks, that all sounds good.

Awesome, thank you Ben (and IESG, WG, authors, etc!)

W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf