Subject: Re: [v6ops] Secdir last call review of draft-ietf-v6ops-rfc6555bis-05

From: Tommy Pauly <[email-masked]>
Date: Fri, 20 Oct 2017 15:04:21 -0700

Hello Brian,

Thanks for your review! We've just posted a new version of the draft that includes an extra section in the security considerations.

https://tools.ietf.org/html/draft-ietf-v6ops-rfc6555bis-06 <https://tools.ietf.org/html/draft-ietf-v6ops-rfc6555bis-06>
https://www.ietf.org/rfcdiff?url2=draft-ietf-v6ops-rfc6555bis-06 <https://www.ietf.org/rfcdiff?url2=draft-ietf-v6ops-rfc6555bis-06>

The references in RFC 6555 to Same-Origin Policy point to RFC 6454. That document actually only references that the policy gates schemes, hosts, and ports—not IP addresses directly. Relying on consistent IP address results from hostname resolution as a security property would be a problem that arises any time a new DNS query is made, so we believe that Happy Eyeballs does not actually expose any new concern here. Using TLS to validate the identity of a server, along with validation of the same host, port, and scheme, should avoid any concern with using different DNS results.

The comment I've added to the security considerations indicates that implementations should not assume that addresses will be consistent for a hostname as a security property, and that Happy Eyeballs may make it more likely in some scenarios that an address will change between connection attempts.

Thanks,
Tommy

> On Sep 28, 2017, at 9:15 AM, Brian Weis <[email-masked]> wrote:
> 
> Reviewer: Brian Weis
> Review result: Has Nits
> 
> I have reviewed this document as part of the security directorate's ongoing
> effort to review all IETF documents being processed by the IESG. These comments
> were written primarily for the benefit of the security area directors. Document
> editors and WG chairs should treat these comments just like any other last call
> comments.
> 
>> From the Introduction, "This document expands on "Happy Eyeballs" [RFC6555], a
> technique of reducing user-visible delays on dual-stack hosts." It lists a set
> of steps by which a client can asynchronously perform IPv6 and IPv4 DNS
> queries, and also semantics on how to handle the replies such that the user
> delay is minimized.
> 
> The Security Considerations section simply states "This memo has no direct
> security considerations.", and I believe this is true. However, I wonder about
> "indirect" security considerations. RFC 6555 warns several times against
> breaking a browser's same-origin policy, which seems to me to be an "indirect"
> security consideration. I realize that browser policies have changed
> considerably since RFC 6555 was published, and I personally do not know if
> same-origin is still in general use or whether there are other newer but
> similar issues of which an implementor should be aware. But if there are, then
> this section should note them. Otherwise, I consider the document ready to be
> published.
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: "Brian Weis (bew)" <[email-masked]>
Date: Sat, 21 Oct 2017 00:23:35 +0000

Hi Tommy,

Thanks for the background info. Your new text in the Security Considerations looks great to me, and I consider this document Ready to publish.

Thanks,
Brian

On Oct 20, 2017, at 3:04 PM, Tommy Pauly <[email-masked]<mailto:[email-masked]>> wrote:

Hello Brian,

https://tools.ietf.org/html/draft-ietf-v6ops-rfc6555bis-06
https://www.ietf.org/rfcdiff?url2=draft-ietf-v6ops-rfc6555bis-06

Thanks,
Tommy

On Sep 28, 2017, at 9:15 AM, Brian Weis <[email-masked]<mailto:[email-masked]>> wrote:

Reviewer: Brian Weis
Review result: Has Nits

_______________________________________________
v6ops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/v6ops

--
Brian Weis
Security, CSG, Cisco Systems
Telephone: +1 408 526 4796
Email: [email-masked]<mailto:[email-masked]>