Subject: [v6ops] FW: New Version Notification for draft-palet-v6ops-ipv6-only-02.txt

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 17 Oct 2017 14:19:22 +0200

I’ve posted a new version of this document.

https://datatracker.ietf.org/doc/draft-palet-v6ops-ipv6-only/?include_text=1

As usual, inputs welcome!

Regards,
Jordi

-----Mensaje original-----
De: <[email-masked]>
Responder a: <[email-masked]>
Fecha: martes, 17 de octubre de 2017, 14:18
Para: Jordi Palet <[email-masked]>, Jordi Palet Martinez <[email-masked]>
Asunto: New Version Notification for draft-palet-v6ops-ipv6-only-02.txt

    A new version of I-D, draft-palet-v6ops-ipv6-only-02.txt
    has been successfully submitted by Jordi Palet Martinez and posted to the
    IETF repository.
    
    Name:		draft-palet-v6ops-ipv6-only
    Revision:	02
    Title:		IPv6-only Terminology Definition
    Document date:	2017-10-16
    Group:		Individual Submission
    Pages:		5
    URL:            https://www.ietf.org/internet-drafts/draft-palet-v6ops-ipv6-only-02.txt
    Status:         https://datatracker.ietf.org/doc/draft-palet-v6ops-ipv6-only/
    Htmlized:       https://tools.ietf.org/html/draft-palet-v6ops-ipv6-only-02
    Htmlized:       https://datatracker.ietf.org/doc/html/draft-palet-v6ops-ipv6-only-02
    Diff:           https://www.ietf.org/rfcdiff?url2=draft-palet-v6ops-ipv6-only-02
    
    Abstract:
       This document defines the terminology regarding the usage of
       expressions such as "IPv6-only", in order to avoid confusions when
       using them in IETF and other documents, in reference to what is the
       actual functionalities being used (not the actual protocol support).

    
    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at tools.ietf.org.
    
    The IETF Secretariat

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Azael Fernandez Alcantara <[email-masked]>
Date: Tue, 17 Oct 2017 12:26:01 -0500

Hi Jordi,

Some comments:

- I think a short "Definition of IPv4-only" would be useful to include.

- Just a typing error in the beginning of the 2nd paragraph in 2. Context
It says: "Even if ossible".

- In 4. Dual-stack

I would change "IPv4 and IPv6 are reachable" with "IPv4 and IPv6 are 
reachable and used".   Not just natively something is used.

BEST,
SALUDOS,
_________________________
Azael Fernandez Alcantara
_________________________________________________________________
Mensaje enviado sin acentos

>    until the htmlized version and diff are available at tools.ietf.org.
.
.
>
>
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 17 Oct 2017 19:43:09 +0200

Hi Azael,

Thanks a lot! Responding below in-line.

Saludos,
Jordi

-----Mensaje original-----
De: Azael Fernandez Alcantara <[email-masked]>
Responder a: <[email-masked]>
Fecha: martes, 17 de octubre de 2017, 19:26
Para: JORDI PALET MARTINEZ <[email-masked]>
CC: <[email-masked]>
Asunto: Re: [v6ops] FW: New Version Notification for draft-palet-v6ops-ipv6-only-02.txt

    Hi Jordi,
    
    Some comments:

[Jordi] I wanted to avoid it. I think it is obvious out of the rest of the context and terms … let’s see what others believe.

[Jordi] I’ve corrected it in my internal -03 version …
    
    - In 4. Dual-stack

[Jordi] Actually is done that way on purpose. The target of the document is IPv6-only. So, for example, even if a CPE or WAN link is dual-stack, it can be actually used for IPv6-only. Or a CPE is dual-stack, the link is IPv6-only, but the hosts are IPv6-only. Etc. In those cases, to be a dual-stack device may be using transition or not, but will be “pingable” using IPv6 or IPv4, even if one of them is not necessarily used.
    
    BEST,
    SALUDOS,

    .
    .

---

From: Fred Baker <[email-masked]>
Date: Tue, 17 Oct 2017 11:06:00 -0700

> On Oct 17, 2017, at 10:43 AM, JORDI PALET MARTINEZ <[email-masked]> wrote:
> 

A little rumination in context. Hats off.

To me, an IPv4-only thing is a thing that can only communicate using IPv4. That would be true of an IPv4-only host, an IPv4-only LAN, or an IPv4-only network. In each case, there is a question of perspective: if an ISP only offers a subscriber IPv4 addresses or prefixes, then the subscriber is IPv4-only from the ISP's perspective, even though it might be using something else internally or when communicating via some other connectivity. If we are speaking from the perspective of the host itself, it might mean that it is perfectly capable of communicating using something else, but it has only been provisioned with an IPv4 address, or it can communicate with peers on its LAN using something else, but the router is IPv4-only, and so when it communicates with devices beyond the router (or they try to communicate with it), IPv4 is the only thing that works.

So, suggested text:

IPv4-only: only capable of or provisioned to communicate using IPv4. The description is always from a perspective, whether the perspective of a host or network seeking to communicate, or that of another host or network describing a communication peer.

---

From: George Michaelson <[email-masked]>
Date: Wed, 18 Oct 2017 08:24:24 +1000

Not that anyone doesn't understand this, but a 'network' could quite
possibly "not support" IPv4 and still have IPv4 packets on it. So, you
can expect to see ARP. you can expect to see DHCP requests. You can
even see half-open TCP.

Diagnostically, the state of being 'IPv6 only' doesn't mean there is
no IPv4 packet types on the wire. it just means they aren't being
supported, carried forward, responded to by deliberate deployment
choices. No router is being proffered, no DNS service is being
proferred.

But if somebody turns up an IPv4 DHCP server, responds to ARP, and
offers a default route, You are not necessarily blocking them.

An IPv4 *blocked* network would be one, which uses lower level (layer
2) switch or other methods to refuse to forward frames which carry
IPv4 and associated (ARP) traffic.

Thats different.

-G

---

From: Azael Fernandez Alcantara <[email-masked]>
Date: Tue, 31 Oct 2017 11:34:35 -0600

Hi,

I agree with the short definition of IPv4-only proposed by Fred.

BEST,
SALUDOS,
_______
Azael
UNAM
Mexico

> To me, an IPv4-only thing is a thing that can only communicate using 
> IPv4. That would be true of an IPv4-only host, an IPv4-only LAN, or an 
> IPv4-only network. In each case, there is a question of perspective: if 
> an ISP only offers a subscriber IPv4 addresses or prefixes, then the 
> subscriber is IPv4-only from the ISP's perspective, even though it might 
> be using something else internally or when communicating via some other 
> connectivity. If we are speaking from the perspective of the host 
> itself, it might mean that it is perfectly capable of communicating 
> using something else, but it has only been provisioned with an IPv4 
> address, or it can communicate with peers on its LAN using something 
> else, but the router is IPv4-only, and so when it communicates with 
> devices beyond the router (or they try to communicate with it), IPv4 is 
> the only thing that works.
>
> So, suggested text:
>
> IPv4-only: only capable of or provisioned to communicate using IPv4. The 
> description is always from a perspective, whether the perspective of a 
> host or network seeking to communicate, or that of another host or 
> network describing a communication peer.
>