Subject: [v6ops] I-D Action: draft-pioxfolks-6man-pio-exclusive-bit.txt

From: "Mudric, Dusan (Dusan)" <[email-masked]>
Date: Fri, 20 Oct 2017 13:56:57 +0000

Hi,

https://tools.ietf.org/html/draft-pioxfolks-6man-pio-exclusive-bit-02#section-5.2.2.2
It is free to assign any address formed
   from an exclusive prefix to any available interface

Is it? What if a host has two interfaces connected to two ISPs that assign exclusive prefixes? Each interface would end up with two ‘exclusive’ prefixes. Can they be still called ‘exclusive’?

Regards,
Dusan.

---

From: Erik Kline <[email-masked]>
Date: Sat, 21 Oct 2017 11:53:08 +0900

On 20 October 2017 at 22:56, Mudric, Dusan (Dusan) <[email-masked]> wrote:
> Is it? What if a host has two interfaces connected to two ISPs that assign
> exclusive prefixes? Each interface would end up with two ‘exclusive’
> prefixes. Can they be still called ‘exclusive’?

In the sense that no other node on either network will receive traffic
to any address within the prefix(es), yes.

---

From: "Mudric, Dusan (Dusan)" <[email-masked]>
Date: Mon, 30 Oct 2017 14:38:07 +0000

Hi Erik,

Please see below for more questions and comments.

Thanks,
Dusan.

> -----Original Message-----
> From: Erik Kline [mailto:[email-masked]]
> Sent: Friday, October 20, 2017 10:53 PM
> To: Mudric, Dusan (Dusan)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [v6ops] I-D Action: draft-pioxfolks-6man-pio-exclusive-bit.txt
> 

[[Dusan]] Why would the host assign the exclusive prefix from one interface (connected to one local link) to another interface (connected to a second local link)? Should not the prefix be used on the local link? Using a prefix from the first link on a second link means the host can create an address on the second link that starts with the first prefix. A packet with that source address can be dropt by the edge router connected to the second link.

Second question: I think this draft is important for hosts using draft-templin-v6ops-pdhost or draft-ietf-v6ops-unique-ipv6-prefix-per-host. Is there a plan to advance the draft?

Thanks,
Dusan.