Subject: [v6ops] "No IPv4" experiment

From: Lee Howard <[email-masked]>
Date: Mon, 13 Nov 2017 16:41:09 +0800

I’ve heard some side channel conversation about the experiment.

I hope people have opened tickets. Reminder:
https://tickets.meeting.ietf.org/newticket

What did people think of this experiment?

Personally, I had some trouble. I like to stay logged in during the WG
meeting so I can keep an eye on Jabber, and preview slides and documents. I
was bounced off the NAT64 SSID several times, and automatically reconnected
to ‘ietf’.  

Lee

---

From: Fred Baker <[email-masked]>
Date: Mon, 13 Nov 2017 16:57:09 +0800

> On Nov 13, 2017, at 4:41 PM, Lee Howard <[email-masked]> wrote:
> 
> Personally, I had some trouble.

Personally, I have been on NAT64 since arriving on Friday, and have had no issues.

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 13 Nov 2017 21:59:53 +1300

> was bounced off the NAT64 SSID several times, and automatically reconnected

It's been stable for me; you have a WiFi problem I think, not a NAT64
problem. I've seen two of the predicted problems (corporate VLAN fails,
literal IPv4 addresses fail) but otherwise so far, so good. My tickets
are at
https://tickets.meeting.ietf.org/ticket/1170
https://tickets.meeting.ietf.org/ticket/1168
https://tickets.meeting.ietf.org/ticket/1159

    Brian

---

From: Andrew Sullivan <[email-masked]>
Date: Mon, 13 Nov 2017 04:04:06 -0500

On Mon, Nov 13, 2017 at 09:59:53PM +1300, Brian E Carpenter wrote:

> problem.

I've had a lot of transient failures with the DNS server on
2001:67c:370:229::7 when using NAT64, and that looks like an outage.
I haven't managed to get something reproducible enough for opening a
ticket.  But the interaction of NAT64 and DNS64 means that the whole
deal is really susceptible to DNS timeout problems.

A

-- 
Andrew Sullivan
[email-masked]

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 13 Nov 2017 17:04:34 +0800

I’d troubles as well, my VPN was connecting and disconnecting, and most of the time didn’t wanted to connect, so it was really disturbing and I give up after 30 minutes, not being able to send/receive emails, and not doing my work.

I still believe IETF network must never be used for experimenting. We want to duplicate what is real in customer networks (dual-stack with private addresses, unfortunately for a while).

It surprised me, because during the hackathon, I tested the same VPN (OpenVPN to the same server, which actually is a LEDE router) and it always worked.

It may be a specific implementation problem of the NAT64 used in the IETF network (in the hackathon we used VPP-NAT64), or some WiFi problem in that room, so I will try again during the week.

Regards,
Jordi

-----Mensaje original-----
De: v6ops <[email-masked]> en nombre de Fred Baker <[email-masked]>
Responder a: <[email-masked]>
Fecha: lunes, 13 de noviembre de 2017, 16:57
Para: Lee Howard <[email-masked]>
CC: <[email-masked]>
Asunto: Re: [v6ops] "No IPv4" experiment

    
    Personally, I have been on NAT64 since arriving on Friday, and have had no issues.
    _______________________________________________
    v6ops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/v6ops

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Tim Chown <[email-masked]>
Date: Mon, 13 Nov 2017 09:49:07 +0000

There is a list of NAT64 tickets at https://tickets.meeting.ietf.org/wiki/nat64

Tim 

> On 13 Nov 2017, at 09:04, JORDI PALET MARTINEZ <[email-masked]> wrote:
>