Subject: Re: [v6ops] GTP questions

From: Alexandre Petrescu <[email-masked]>
Date: Sun, 12 Nov 2017 13:10:53 +0100

Hi Mikael,

Sorry for late reply.

Le 29/09/2017 à 10:44, Mikael Abrahamsson a écrit :
> On Fri, 29 Sep 2017, Alexandre Petrescu wrote:
> 
>> I would like to ask whether by 3GPP specs the GTP packets can 
>> optionally be transported in IPv6 messages?
>> 
>> 3GPP spec "GTP" Rel 15 of September 2017 says this:
>>> UDP/IP is the only path protocol defined to transfer GTP
>>> messages in the version 1 of GTP. A User Datagram Protocol (UDP)
>>> compliant with IETF RFC 768 [13] shall be used.
>> 
>> In practice, a packet capture on PGW shows an IPv6 DHCPv6-PD 
>> Solicit message, preceded by a GTP-U Header, which is itself 
>> preceded by a "GTPU Rx PDU" which is an IPv4 UDP packet.
>> 
>> The UDPv4 port number that transports GTP packets is 2152,
>> reserved at IANA and at that 3GPP spec.
> 
> It's an implementation detail whether this is carried over IPv4 or 
> IPv6. UDP can be carried by both. If you read 29.060 it talks about 
> GTP over both IPv4 and IPv6:
> 
> "If an IPv4/IPv6 capable SGSN received IPv4 GGSN addresses from the 
> old SGSN, it shall include IPv4 addresses in the fields SGSN Address 
> for Control Plane and SGSN Address for User Traffic and IPv6 
> addresses in the fields Alternative SGSN Address for Control Plane 
> and Alternative SGSN Address for User Traffic. Otherwise, an 
> IPv4/IPv6 capable SGSN shall use only SGSN IPv6 addresses if it has 
> GGSN IPv6 addresses available. If the GGSN supports IPv6 below GTP, 
> it shall store and use the IPv6 SGSN addresses for communication
> with the SGSN and ignore the IPv4 SGSN addresses. If the GGSN
> supports only IPv4 below GTP, it shall store and use the IPv4  SGSN
> addresses for communication with the  SGSN and ignore the IPv6 SGSN
> addresses. When active contexts are being redistributed due to load
> sharing, G-PDUs that are in transit across the Gn-interface are in
> an undetermined state and may be lost."
> 
> "below GTP" seems to indicate what protocol GTP is run over.

YEs, I can agree to read it that way, but it can be a little bit of a
stretch.  GTP Rel15 Sept. 2017 clearly says only RFC768.  If it wanted 
to mean GTP/UDP/IPv6 it could have cited e.g. RFC6936.  Hence the doubt.

But yes, I agree with you that in largest part UDP works over IPv6 as 
over IPv4.

> There is a lot more text in TS 29.060 regarding this, but interested 
> parties can read it and form their own opinion.

I agree.

> To me it's clear that 3GPP has done the work to try to achieve so you
> can standards-based build a network with no IPv4 addresses used for
> infrastructure. If this works in real life in shipping products,
> that's a whole other question.

I agree that real life in shipping products is a whole other question.

I had some discussion with some people, and here are some of my 
deductions.  If I am wrong, I carry the responsibility.

Operator1 in hexagon country: the IPv6 is carried in GTP/UDP/IPv4
Operator2 in country voted out of EU: the IPv6 is carred in GTP/UDP/IPv4.

Among other cellular operators that offer IPv6 to smartphones, I wonder 
about the following:

Is T-Mobile USA carrying the smartphone's IPv6 inside GTP/UDP/IPv4?  Or 
inside GTP/UDP/IPv6?

Is Reliance JIO in India carrying the smartphone's IPv6 inside 
GTP/UDP/IPv4?  Or inside GTP/UDP/IPv6?

My gut feeling is that all do GTP/UDP/IPv4.

My intention with this discussion is twofold: find an operator that does 
GTP/UDP/IPv6 and second to deduce something for the IPv6-only 
terminology draft.

Alex

---

From: Ca By <[email-masked]>
Date: Sun, 12 Nov 2017 15:04:42 +0000

> My gut feeling is that all do GTP/UDP/IPv4.

Your gut is correct, i do not know of any carrier using GTP with ipv6
transport.

That said, i believe the GTP transport network operations is orthogonal to
the network that the UE / customer traffic experiences.

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Mon, 13 Nov 2017 13:12:48 +0000

Pls see inline,

On Nov 12, 2017, at 10:05 AM, Ca By <[email-masked]<mailto:[email-masked]>> wrote:

On Sun, Nov 12, 2017 at 4:11 AM Alexandre Petrescu <[email-masked]<mailto:[email-masked]>> wrote:
Hi Mikael,

Sorry for late reply.

I agree.

Latter. Hopefully, more details will get discussed at the next v6 world Congress in Paris.

Your gut is correct, i do not know of any carrier using GTP with ipv6 transport.

That said, i believe the GTP transport network operations is orthogonal to the network that the UE / customer traffic experiences.

+1.

How do either help out ?

Alex

_______________________________________________
v6ops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/v6ops
_______________________________________________
v6ops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/v6ops

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 13 Nov 2017 14:34:14 +0100

Le 13/11/2017 à 14:12, Rajiv Asati (rajiva) a écrit :
>> On Sun, Nov 12, 2017 at 4:11 AM Alexandre Petrescu 
>> <[email-masked] <mailto:[email-masked]>> 
>> wrote:
>>
>>     Hi Mikael,
>>
>>     Sorry for late reply.
>>

That would be a first time a cellular network operator transports 
smartphone's IPv6 traffic into GTP-IPv6.  All the others transport 
smartphone's IPv6 traffic into GTP-IPv4.

GTP is a an UDP/IPv4 protocol and example packets look like this.  It 
comes from the smartphone and is captured on PGW:
 > INBOUND>>>>>  15:47:48:883 Eventid:142004(3)
 > GTPU Rx PDU, from [IPv4-address]:2152 to [IPv4-address-2]:2152 (129)
 > TEID: 0x80072183, Message type: GTP_TPDU_MSG (0xFF)
 > Sequence Number:: NA
 > GTP HEADER FOLLOWS:
 > [snip]
 > GTP HEADER ENDS.
 >            Payload protocol: IPv6
 > PROTOCOL PAYLOAD FOLLOWS:
 > fe80::b9d9:c10a:2c2d:3c3b.546 > ff02::2.546:  [udp sum ok]
 > IPv6 Header Follows:
 > [snip]
 > PROTOCOL PAYLOAD ENDS.

A fictitious GTP as UDP/IPv6 packet would look like this, remark
the IPv6 addresses 'from' and 'to' in the second line below:
 > INBOUND>>>>>  15:47:48:883 Eventid:142004(3)
 > GTPU Rx PDU, from [IPv6-address]:2152 to [IPv6-address-2]:2152 (129)
 > TEID: 0x80072183, Message type: GTP_TPDU_MSG (0xFF)
 > Sequence Number:: NA
 > GTP HEADER FOLLOWS:
 > [snip]
 > GTP HEADER ENDS.
 >            Payload protocol: IPv6
 > PROTOCOL PAYLOAD FOLLOWS:
 > fe80::b9d9:c10a:2c2d:3c3b.546 > ff02::2.546:  [udp sum ok]
 > IPv6 Header Follows:
 > [snip]
 > PROTOCOL PAYLOAD ENDS.

Does such packet exist.  Why waiting the next v6 world Congress in Paris 
to see that.

>> That said, i believe the GTP transport network operations is 
>> orthogonal to the network that the UE / customer traffic experiences.
> 
> +1.
> 
> 
>>

Well, it would prove me wrong when I am saying there is no such thing as 
an IPv6-only core network in a cellular network.

Also, a well-defined term "IPv6-only" helps me when I approach parties 
proposing them "IPv6".  Sometimes they seem scared of the "IPv6" word, 
so I reassure them it is _not_ "IPv6-only", but it is "IPv6-only" 
together with "IPv4".  Or I may just say "IP".

Ther term "dual stack" is not well understood: some times it means IPv4 
side-by-side with IPv6 in the same computer, whereas other times it 
means a particular translation mechanism between IPv6 and IPv4 including 
some DNS features ("DS Lite", and others).

"IPv6-only" together with "IPv4" would mean something like it works ok 
for everyone without any translation, tunnelling or DNS combinations.

Then there is also this "native" term that would need to be clarified.

And also this level: encapsulated IPv6 in IPv4 does not mean "IPv6-only" 
and does not mean '"IPv6-only" together with IPv4.'

Just some thoughts.

Alex

>>     [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>