Subject: Re: [v6ops] IPv6 and Apple iPhone LTE interface (was: reclassify 464XLAT as standard instead of info)

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 6 Dec 2017 12:00:37 +0100

Le 21/09/2017 à 14:02, Ca By a écrit :
[...]

>>> But you cant have simultaneously CLAT and DHCPv6-PD on the
>> same client.
>>> 
>>> 
>>> I do not agree,  Please state what is structurally preventing 
>>> this. RFC6877 specifically calls for using dhcpv6-pd
>> 
>> RFC is one thing, but many implementations block some RFCs.
>> 
>> What structurally prevents this is that there are very numerous 
>> Android devices.
> 
> Say the same about Apple. Show me Apple running dhcpv6 on LTE 
> interface.

It's hard to say.  Before trying DHCPv6, an iPhone user can not set the
PDP type; so it's not  possible to set it to 'IPv6'.  The operator does
offer IPv6 and advises Android users to put 'IPv6' in the PDP type,
called 'APN protocol'.

Is there an iPhone app that could set the PDP type to 'IPv6', without
jailbreaking?

Alex

---

From: james woodyatt <[email-masked]>
Date: Wed, 6 Dec 2017 10:26:14 -0800

On Dec 6, 2017, at 03:00, Alexandre Petrescu <[email-masked]> wrote:
> 
> Is there an iPhone app that could set the PDP type to 'IPv6', without jailbreaking?

You need a carrier bundle to configure that setting.

--james woodyatt <[email-masked] <mailto:[email-masked]>>

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 7 Dec 2017 12:45:20 +0100

Le 06/12/2017 à 19:26, james woodyatt a écrit :
> On Dec 6, 2017, at 03:00, Alexandre Petrescu 
> <[email-masked] <mailto:[email-masked]>>
> wrote:
>> 

Yes I need it.

That carrier does not offer a bundle to configure that setting for
iPhone.  For Android, the carrier indicates to the user the typical
step-by-step Parameter changing of the "APN protocol" from IPv4 to IPv6.

Alex

---

From: Kossut Tomasz - Hurt <[email-masked]>
Date: Wed, 13 Dec 2017 09:49:21 +0000

Hi,
IPv6-only PDP on Iphones requires DNS64.
Android/windowsphone works with Ipv6-only PDP without DNS64*
*- DNS64 only for ipv4only.arpa to learn/get plat-prefix
Cheers,
tk

-----Original Message-----
From: v6ops [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
Sent: Thursday, December 7, 2017 12:45 PM
To: james woodyatt
Cc: [email-masked] WG
Subject: Re: [v6ops] IPv6 and Apple iPhone LTE interface

Yes I need it.

That carrier does not offer a bundle to configure that setting for iPhone.  For Android, the carrier indicates to the user the typical step-by-step Parameter changing of the "APN protocol" from IPv4 to IPv6.

Alex

_______________________________________________
v6ops mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/v6ops

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 13 Dec 2017 16:21:01 +0100

> IPv6-only PDP on Iphones requires DNS64.

A-ha.

But is it possible to set the IPv6-only PDP on an iPhone without running 
a 'carrier bundle'?

(then I will see about DNS64.)

Alex