Subject: Re: Guaranteeing the Integrity of Bindings

From: John Stracke <[email-masked]>
Date: Wed, 15 Sep 1999 15:27:47 -0400

[email-masked] wrote:

> > > We think that it is not impossible to guarantee integrity of bindings even
> > > in cases like this, if the server is willing to take enough trouble.  It can
> > > store a copy of the target resource locally, and insure that no changes are
> > > allowed except when both servers are accessible.
>
> > It may not be feasible to make a copy of a dynamic resource.
>
> <opinion owner=jlc personal>
> We've barely discussed dynamic resources in general.

It doesn't take much discussion to realize that copying a dynamic resource is not
something that can ever be expressed in a standard protocol; they're far too
implementation-dependent.

--
/================================================================\
|John Stracke    | http://www.ecal.com |My opinions are my own.  |
|Chief Scientist |===============================================|
|eCal Corp.      |"Your reality, sir, is lies & balderdash, and I|
[email-masked]|am pleased to say I have no grasp on it        |
|                |whatsoever!" --Baron Munchausen                |
\================================================================/

---

From: [email-masked]
Date: Wed, 15 Sep 1999 15:27:56 -0400

<opinion owner=jlc personal>
We've barely discussed dynamic resources in general.  They need just as much
clarification and cleanup as locks do/did, but we're not going to be able to
cover them before the end of the month and I believe that's the deadline we
face for the webdav base spec.

I think until we do get that defined, server implementers are just going to
have to experiment with their own ideas about dynamic (content) resources.

As for COPY/MOVE'ing them.  For now we'll just have to leave implementors with
the guidelines that
we have now.  If they don't  think they can support them (or anything else),
then they need to reject
requests that require they support them.    They are going to need to make some
judgement calls here.

When we come back to dynamic resources, we can be more specific about what
is expected.
</opinion>

---

From: "Geoffrey M. Clemm" <[email-masked]>
Date: Wed, 15 Sep 1999 17:52:09 -0400

To give that dead horse one more kick (:-), I agree with John and Jason
that there is little useful we can say about the semantics of dynamic
resources.  The best we can do is give them some standard properties
like "source".

Cheers,
Geoff

   Date: Wed, 15 Sep 1999 15:27:47 -0400
   From: John Stracke <[email-masked]>
   X-Mailer: Mozilla 4.6 [en] (X11; I; Linux 2.0.36 i586)
   X-Accept-Language: en
   Mime-Version: 1.0
   References: <[email-masked]>
   Content-Transfer-Encoding: 7bit
   Resent-From: [email-masked]
   X-Mailing-List: <[email-masked]> archive/latest/3317
   X-Loop: [email-masked]
   Sender: [email-masked]
   Resent-Sender: [email-masked]
   Precedence: list
   X-Lines: 27
   Content-Type: text/plain; charset="us-ascii"; conversions="7bit"
   Content-Length: 1145