Subject: RE: BIND Error Codes

From: "Yaron Goland (Exchange)" <[email-masked]>
Date: Wed, 15 Sep 1999 16:53:23 -0700

Adding yet another error code for this is probably a waste. I think 501 is
the right code but you should add an XML body with an element indicating
what went wrong. You could use a header but the error status is something
(as you are now finding) that people will want to be able to expand in the
future. XML is expandable, headers are not.

		Yaron

> -----Original Message-----
> From: Slein, Judith A [mailto:[email-masked]]
> Sent: Wed, September 15, 1999 11:19 AM
> To: 'WebDAV'
> Subject: BIND Error Codes
> 
> 
> Another in the series of messages from the advanced 
> collections design team:
> 
> We've agreed to remove all normative language about 
> cross-server bindings,
> but we do think it would be useful to say something about the 
> reason why a
> binding cannot be created, especially in the case of an 
> attempt to create a
> cross-server binding.
> 
> We haven't been able to agree on how best to do this.
> 
> Currently the binding spec says that if the server can't guarantee the
> required binding behavior, it must fail the BIND request with 
> a 501 (Not
> Implemented).  Period.  No further explanation.  We could 
> just leave it at
> that, but we think it would be useful to the client to know 
> that the reason
> the BIND can't be done is that the server can't guarantee integrity of
> bindings to resources on another server (for example).
> 
> We could use a different (new) error code for "Can't create 
> cross-server
> binding."
> 
> We could stick with 501, but provide further explanation in 
> the response
> body.
> 
> We could leave the spec as it is.
> 
> Any preferences?
> 
> --Judy
> 
> Judith A. Slein
> Xerox Corporation
> [email-masked]
> (716)422-5169
> 800 Phillips Road 105/50C
> Webster, NY 14580
>

---

From: "Geoffrey M. Clemm" <[email-masked]>
Date: Thu, 16 Sep 1999 08:44:58 -0400

I also prefer the explanatory XML body approach.

Cheers,
Geoff

   From: "Yaron Goland (Exchange)" <[email-masked]>

		   Yaron