Subject: RE: Bindings, Locks, and MOVE

From: "Yaron Goland (Exchange)" <[email-masked]>
Date: Fri, 10 Sep 1999 12:48:15 -0700

To guarantee that a MOVE will work using a GET/PROPFIND/PUT/PROPPATCH/DELETE
or any other sequence of client commands would be to rob servers of their
ability to add value, which is clearly a step too far. This is especially
the case in circumstances where the resource in question is not a file in
disguise but a generic program.

That having been said, in many cases the previous sequence would work just
fine. Unfortunately it is also slow as all hell but in some cases there is
nothing better available.

		Yaron

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, September 10, 1999 9:37 AM
> To: [email-masked]
> Subject: Re: Bindings, Locks, and MOVE
> 
> 
> 
> 
> Do we think clients should be able to effect a cross server 
> "move" with GET,
> PROPFIND/PUT, PROPPATCH/DELETE? Seems like a minimal 
> requirement for authoring
> and publishing. If so, then wouldn't we like the server's 
> MOVE to just something
> similar in a single method to reduce network traffic and 
> client complexity? Are
> we making MOVE way too complicated, full of special cases, 
> etc. I continue to
> believe that any method whose semantics require a list of 
> if-then-else's is
> missing some underlying fundamental principal, will be 
> difficult to implement,
> difficult to test, introduce interoperability problems, and 
> will be hard for
> clients to use. Move with locks and references seems to have 
> crossed the line.
> 
> 
> 
> 
> 
> John Stracke <[email-masked]> on 09/10/99 11:16:38 AM
> 
> To:   [email-masked]
> cc:
> 
> Subject:  Re: Bindings, Locks, and MOVE
> 
> 
> 
> 
> "Yaron Goland (Exchange)" wrote:
> 
> > If you wish to do cross-server
> > MOVEs you will need a new protocol because WebDAV can't do it.
> 
> Disturbing thought from the peanut gallery: cross-host MOVE 
> (i.e., between two
> URLs with different hostnames) is not necessarily 
> cross-server, because they
> could be hosted on the same machine.  So, sometimes, 
> something that looks like
> a cross-server MOVE may work.  But usually it won't.  And, in 
> some cases, a
> user may find it works for a while and then stops, when his 
> admin splits the
> server up.  Or vice versa.  Fun, no? :-)
> 
> --
> /============================================================\
> |John Stracke    |http://www.ecal.com|My opinions are my own.|
> |Chief Scientist |===========================================|
> |eCal Corp.      |I'm a .sig virus...and, boy, am I tired!   |
> [email-masked]|                                           |
> \============================================================/
> 
> 
> 
> 
> 
>

---

From: Greg Stein <[email-masked]>
Date: Fri, 10 Sep 1999 13:39:40 -0700

> nothing better available.

I certainly won't be building any client-side HTTP code into mod_dav. If
the MOVE can't be done within the server, then it will fail. Period.

I fully agree with the part of the charter than Yaron pointed out:
server-server communication is NOT in scope.

There are enough things to do without worrying about this. Jim's server
happens to be able to do cross-server moves because it is a blended
client/server package. I would still like to know if *any* other
server-side only packages are actually *intending* to support any kind
of cross-server functionality.

If not, then take Geoff's stance: allow a MOVE to fail with a "Bad
Gateway" at any time. There. Enough said in the spec. Let's move on.

Cheers,
-g

--
Greg Stein, http://www.lyra.org/