Subject: URI mappings created by bindings

From: "Geoffrey M. Clemm" <[email-masked]>
Date: Mon, 20 Sep 1999 15:37:41 -0400

One of the comments on the Adv. Collection protocol was that 
sections 5.3 and 5.4 were confusing.  I suggest we replace those
two sections with the following text:

----------------------------------------------------

5.3 URI Mappings Created by a BIND

Suppose a BIND request causes a binding from "Binding-Name" to
resource R to be added to a collection, C.  Then if C-MAP is the set
of URL's that were mapped to C before the BIND request, then for all
members, "C-URL" of C-MAP, the URL "C-URL/Binding-Name" is mapped to
resource R following the BIND request.

Note that if a binding is made to the collection itself (or to a
parent of the collection), an infinite number of mappings is
introduced.

5.4 Example: URI Mappings Created by a BIND

For example, if a binding from "index.html" to R is added to the
collection C, and if the following URL's are mapped to C:
   http://www.fuzz.com/A/1
   http://fuzz.com/A/one
then the following new mappings to R are introduced:
   http://www.fuzz.com/A/1/index.html
   http://fuzz.com/A/one/index.html

If a binding from "myself" to C is then added to C,
the following infinite number of additional mappings to C are introduced:
   http://www.fuzz.com/A/1/myself
   http://www.fuzz.com/A/1/myself/myself
   ...
and the following infinite number of additional mappings to R are introduced:
   http://www.fuzz.com/A/1/myself/index.html
   http://www.fuzz.com/A/1/myself/myself/index.html
   ...
   
----------------------------------------------------

Cheers,
Geoff

---

From: "Slein, Judith A" <[email-masked]>
Date: Tue, 21 Sep 1999 10:50:24 -0400

This is a great improvement, I think.  More below.

> -----Original Message-----
> From: Geoffrey M. Clemm [mailto:[email-masked]]
> Sent: Monday, September 20, 1999 3:38 PM
> To: [email-masked]
> Subject: URI mappings created by bindings
> 
> 
> 

<js>
If R is a collection, additional URI mappings are created to the descendents
of R.  For each new URI mapping to R, there is a new URI mapping to each of
its descendents.
</js>
 
> parent of the collection), an infinite number of mappings is

<js>
I get this now that I've looked at the examples, but it might be clearer if
stated a little more formally, as you did in the first paragraph.  "If R is
identical to C or to a parent of C, an infinite number of URI mappings is
introduced."
</js>