Subject: Re: PROPPATCH Error minimization

From: [email-masked]
Date: Thu, 7 Oct 1999 20:42:36 -0400

According to the WebDAV DTD, prop and status are required, and a multistatus
must have at least one response. The optimizations you describe look good, but
the really complicate client implementations.

[email-masked] on 10/07/99 05:44:37 PM

To:   [email-masked]
cc:

Subject:  Re: PROPPATCH Error minimization

Say we invoke PROPATCH so that it sets property1 and property2 on resourceX.

if both of these return an error, I believe we are allowed to return...

...
<HREF>resourceX</HREF>
<PROPSTAT>
   <PROP>
      <property1/><property2/>
   </PROP>
   <STATUS>HTTP/1.1 409 Conflict</STATUS>
</PROPSTAT>
...

but are we allowed to skip the PROP tag if all of the element have the same
result?...

...
<HREF>resourceX</HREF>
<PROPSTAT>
   <STATUS>HTTP/1.1 409 Conflict</STATUS>
</PROPSTAT>
...

And are we allowed to skip the PROPSTAT altogether and just return a status for
the URI?...

...
<HREF>resourceX</HREF>
<STATUS>HTTP/1.1 409 Conflict</STATUS>
...

Or even return it in the response header?

Does this change if the response code is "200 OK" rather than 4XX?

If the spec doesn't already do so, it should provide a guideline here so that
clients know all the possibilities to expect and can code for them.

J.

------------------------------------------
Phone: 914-784-7569,   [email-masked]

---

From: "Geoffrey M. Clemm" <[email-masked]>
Date: Fri, 8 Oct 1999 07:53:16 -0400

I'd suggest we just make it clear that these
optimizations are not allowed.  They save some
bandwidth over the wire, but would complicate both server and client
implementations.

Cheers,
Geoff

   From: [email-masked]

   To:   [email-masked]
   cc:

   ...
   <HREF>resourceX</HREF>
   <PROPSTAT>
      <PROP>
	 <property1/><property2/>
      </PROP>

   ...
   <HREF>resourceX</HREF>
   <PROPSTAT>

   ...
   <HREF>resourceX</HREF>

   J.