Subject: Re: Authentication in existing WebDAV servers

From: [email-masked]
Date: Mon, 1 Nov 1999 10:18:10 -0500

DAV4J just uses Basic Authentication for now. It didn't seem too important
to authenticate users when there isn't any support for ACLs. We plan to do
Digest though.

"Slein, Judith A" <[email-masked]> on 11/01/99 10:01:38 AM

To:   "'WebDAV'" <[email-masked]>
cc:

Subject:  Authentication in existing WebDAV servers

A question for server implementers:

Are current server implementations supporting Digest Authentication?  If
not, what are they doing for authentication?

Judith A. Slein
Xerox Corporation
[email-masked]
(716)422-5169
800 Phillips Road 105/50C
Webster, NY 14580

---

From: "Yaron Goland (Exchange)" <[email-masked]>
Date: Mon, 1 Nov 1999 10:22:51 -0800

IIS 5/Windows 2000 supports basic, digest, NTLM, kerberos and few other
algorithms I don't even remember.

			Yaron

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, November 01, 1999 7:18 AM
> To: [email-masked]
> Subject: Re: Authentication in existing WebDAV servers
> 
> 
> 
>

---

From: Max Rible <[email-masked]>
Date: Mon, 01 Nov 1999 10:37:51 -0800

>not, what are they doing for authentication?

Glyphica supports Digest authentication in our InfoPortal product,
along with Basic and cookies.  (And it took a good bit of hackery
to arrange things so a web browser could be using cookie authentication
and WebDAV could use Digest.  Anyone know where I can find a spec
for Windows NT challenge-response authentication?

-- 
%% Max Rible %% [email-masked] %% http://www.amurgsval.org/~slothman/ %%
%% "Before enlightenment:  sharpen claws, catch mice.                   %%
%%  After enlightenment:  sharpen claws, catch mice."            - me   %%