Subject: Re: more interoperation: Cyberteams Webdav

From: Dana Carson <[email-masked]>
Date: Sat, 13 Nov 1999 06:05:12 -0500

At 9:14 PM +0100 on 11/11/99, Jim Davis wrote:

> Today I tested the Cyberteams webdav server.
> 1) The server returns an invalid Content-Type for a PROPFIND.  The
>content type
> is httpd/unix-directory but should be text/xml

Fixed. Turns out if you ser the output header but not the r->content_type
it overrides the header.

> 2) The server ignores the Depth header (or at least it ignores Depth: 0) on
>  PROPFIND.
> As a result, it returns a great deal more information that one desires

Fixed.

--
Dana Carson
[email-masked]           http://www.cyberteams.com/
[email-masked]                 http://www.toad.net/~dcarson/
Lunar Resources Company          http://www.tlrc.com/
Artemis Society International    http://www.asi.org/

---

From: Jim Whitehead <[email-masked]>
Date: Sun, 14 Nov 1999 12:58:49 -0800

Also caught by the spam filter -- my apologies for not catching this sooner.

- Jim

-----Original Message-----
From: Jim Davis [mailto:[email-masked]]
Sent: Thursday, November 11, 1999 12:16 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Moderator Action] more interoperation: Cyberteams Webdav

I regret to say that this web server is far from compliant with RFC 2518.

I found two problems.

1) The server returns an invalid Content-Type for a PROPFIND.  The content
type
is httpd/unix-directory but should be text/xml

There may be other problems, but I was not able to make any progress beyond
this point.  (In principle, my test code should recover from these two
problems but it does not.  I hope to make it more robust, but still both of
these problems are violations of RFC 2518 and should be fixed.)

telnet www.cyberteams.com 8080
Trying 209.68.7.109...
Connected to cyberteams.com.
Escape character is '^]'.
PROPFIND / HTTP/1.1
Host: www.cyberteams.com
Depth: 0
Authorization: Basic anJkOmYybGRzcDFy
Content-Type: text/xml
Content-Length: 107

<?xml version="1.0"?>
<A:propfind xmlns:A="DAV:">
<A:prop>
<A:resourcetype/>
</A:prop>
</A:propfind>
HTTP/1.1 200 OK
Date: Thu, 11 Nov 1999 19:41:23 GMT
Server: Apache/1.3.6 (Unix) WSD/DAV 0.6.7
X-Powered-By: WSD (http://www.cyberteams.com/)
Content-Length: 3060
Content-Type: httpd/unix-directory
Content-Location: http://qs33.pair.com:8080//
Ms-Author-Via: DAV

<?xml version="1.0" ?>
<D:response xmlns:D="DAV:" xmlns:W="http://www.cyberteams.com/">
<D:href>/</D:href>
<D:propstat>
<D:prop>
<D:resourcetype><D:collection/></D:resourcetype>
</D:prop>
 <D:status>HTTP/1.1 200 OK</D:status></D:propstat>
</D:response>
<D:response>
<D:href>http://qs33.pair.com:8080/Galaxy/</D:href>
<D:propstat>
<D:prop>
<D:resourcetype><D:collection/></D:resourcetype>
</D:prop>
 <D:status>HTTP/1.1 200 OK</D:status></D:propstat>
</D:response>

etc