Subject: Does zope mess with the body in a GET?

From: Jim Davis <[email-masked]>
Date: Mon, 15 Nov 1999 14:12:40 +0100

I did a PUT to foo.html.  I sent 51 characters
"Despite the name, this is a <B>plain text</B> file."

when I did a GET I got back 71 characters, 

"<html><head></head>
Despite the name, this is a <B>plain text</B> file."

Looks to me like Zope added those HTML elements for me.  this seems
undesirable.

What is also bizarre is that if I do  HEAD, I get back length of 51.

So I think Zope must be adding them when I do then GET.

For what it's worth, after the PUT I also did  PROPPATCH to set the type to
text/plain.
But that seemed to have no effect

---

From: Jim Whitehead <[email-masked]>
Date: Tue, 16 Nov 1999 09:09:55 -0800

Another message unfortunately caught by the spam filter.  I have put in a
request to have [email-masked] added to the accept2 list, but it must
not have gone through yet. :-(

- Jim

-----Original Message-----
From: Brian Lloyd [mailto:[email-masked]]
Sent: Tuesday, November 16, 1999 6:19 AM
To: 'Brett McCormick'; Jim Whitehead
Cc: Brian Lloyd; [email-masked]
Subject: RE: Does zope mess with the body in a GET?

> (about "source links")...
>
> When you say people have not "been taking" to that approach, does that
> mean they just don't like it, are not implementing it, or both?
>
> It seems like the best approach to me.  There is no way to determine
> where the content is actually coming from without these links, any
> method we use for this is going to have them.
>
> Has anyone been using or seen any implementations of the source
> resource links?
>
> --brett

Zope provides the src link in its PROPFIND response - but all
current clients apparently ignore it :(

Brian Lloyd        [email-masked]
Software Engineer  540.371.6909
Digital Creations  http://www.digicool.com

---

From: Jim Whitehead <[email-masked]>
Date: Tue, 16 Nov 1999 18:29:25 -0800

Another caught by the spam filter.

- Jim

-----Original Message-----
From: Brett McCormick [mailto:[email-masked]]
Sent: Tuesday, November 16, 1999 3:46 PM
To: Brian Lloyd
Cc: Jim Whitehead; [email-masked]
Subject: RE: Does zope mess with the body in a GET?

Bah, aren't they in violation of the standard then?  Designated as
non-compliant software?

--brett