Subject: can multiple propstat elements within response have same status

From: Jim Davis <[email-masked]>
Date: Mon, 15 Nov 1999 14:22:22 +0100

The DTD allows a response for a given href to have multiple propstats.
But is it required that each such propstat have a different status?

Here's an example of a response frm Zope.  It seems to have grouped the
properties by XML namespace.  So there are three propstats, each with
status 200.

From the RFC, this seems legal to me.  it's a slight nuisance to process
but nothing extreme.  Just thought I'd ask for other opinions.  It is
legal, isn't it?

<?xml version="1.0"?>
<A:multistatus xmlns:A="DAV:">
  <A:response>
    <A:href>/users/jdavis/foo.html</A:href>
    <A:propstat>
      <A:prop>
        <B:defaulttitle xmlns:B="http://www.zope.org/propsets/"/>
      </A:prop>
      <A:status>HTTP/1.1 200 OK</A:status>
    </A:propstat>
    <A:propstat>
      <A:prop>
        <A:creationdate/>
        <A:displayname>foo.html</A:displayname>
        <A:resourcetype/>
        <A:getlastmodified>Mon, 15 Nov 1999 13:05:38 GMT</A:getlastmodified>
        <A:getcontenttype/>
        <A:getcontentlength>51</A:getcontentlength>
        <A:source>
          <A:link>
            <A:src>/users/jdavis/foo.html</A:src>
            <A:dst>/users/jdavis/foo.html/document_src</A:dst>
          </A:link>
        </A:source>
      </A:prop>
      <A:status>HTTP/1.1 200 OK</A:status>
    </A:propstat>
    <A:propstat>
      <A:prop>
        <B:foo xmlns:B="http://nsa.gov/deadprop/foo">fish</B:foo>
      </A:prop>
      <A:status>HTTP/1.1 200 OK</A:status>
    </A:propstat>
  </A:response>
</A:multistatus>

---

From: Greg Stein <[email-masked]>
Date: Mon, 15 Nov 1999 06:53:50 -0800 (PST)

> But is it required that each such propstat have a different status?

Not as far as I know. I don't do it myself, but it doesn't seem to violate
anything that I can think of.

Cheers,
-g

--
Greg Stein, http://www.lyra.org/