Subject: RE: Authentication in existing WebDAV servers

From: "Yaron Goland (Exchange)" <[email-masked]>
Date: Mon, 1 Nov 1999 22:50:20 -0800

The spec says that digest MUST be supported. You can use anything you want,
including nothing.

> -----Original Message-----
> From: Greg Stein [mailto:[email-masked]]
> Sent: Monday, November 01, 1999 6:54 PM
> To: Richard C.
> Cc: 'WebDAV'
> Subject: Re: Authentication in existing WebDAV servers
> 
> 
> On Mon, 1 Nov 1999, Richard C. wrote:
> > I am writing a Java problem to connect to WebDAV server, I am using
> > HTTPClient library, so should I use basic authentication or digest
> > authentication?  
> 
> The WebDAV spec states that Digest authentication must be used.
> 
> However, all clients and servers, that I'm aware of, are 
> flexible in this
> regard. For example, Apache and mod_dav will allow the use of Basic
> authentication.
> 
> Cheers,
> -g
> 
> --
> Greg Stein, http://www.lyra.org/
>

---

From: Greg Stein <[email-masked]>
Date: Mon, 1 Nov 1999 23:46:35 -0800 (PST)

All right... true... the spec is a bit different than I implied. Section
17.1 spells it out. Yes, it must be supported (as opposed to always
required), and yes, you can use anything you want... *IF* you use a secure
channel.

Over plain old HTTP, the spec does state that Basic must not be used.

Yes, I'm being picky here, but you were first :-)

Cheers,
-g

On Mon, 1 Nov 1999, Yaron Goland (Exchange) wrote:
>...