Subject: Authentication in existing WebDAV servers

From: "Slein, Judith A" <[email-masked]>
Date: Mon, 1 Nov 1999 10:01:38 -0500

A question for server implementers:

Are current server implementations supporting Digest Authentication?  If
not, what are they doing for authentication?

Judith A. Slein
Xerox Corporation
[email-masked]
(716)422-5169
800 Phillips Road 105/50C
Webster, NY 14580

---

From: Greg Stein <[email-masked]>
Date: Mon, 1 Nov 1999 13:33:43 -0800 (PST)

> not, what are they doing for authentication?

Yes, Digest auth is part of Apache, so I get to leverage that [for
mod_dav]. I also get whatever other kinds of auth people may have plugged
in, and also things like SSL.

Being based on HTTP definitely has its advantages... I don't have to worry
about any of that stuff!

Cheers,
-g

--
Greg Stein, http://www.lyra.org/

---

From: "Richard C." <[email-masked]>
Date: Mon, 1 Nov 1999 13:50:47 -0800 (PST)

I am writing a Java problem to connect to WebDAV server, I am using
HTTPClient library, so should I use basic authentication or digest
authentication?  

Rich
                          __     
    `       `          .^o ~\  `        `   `                ` 
             ``  `    Y /'~) }      _____          `        `` `
              `       l/  / /    ,-~     ~~--.,_    `         `    ``
         `           `   ( (    /  ~-._         ^.               
         ``      `        \ "--'--.    "-._       \       `    `  
           `           `   "-.________     ~--.,__ ^.             `
                   `    `            \"~r-.,___.-'-. ^.  
          `    `                 `    YI    \\      ~-.\     `      `
                `             `       ||     \\        `\   
            `                  `      ||     // `Be on your guard; stand
      `           `                   ||    //   firm on the faith; be men
       `           `          `       ()   //    of courage; be strong.   
                    `          `      ||  //     `   `
               `                      || ( c     1 Corinthians 16:3
                `        ___._ __  ___I|__`--__._ __  _  
                       "~     ~  "~  ""   ~~"    ~  ~~   
  
ICQ: 22864213
http://members.xoom.com/highpitch

---

From: Greg Stein <[email-masked]>
Date: Mon, 1 Nov 1999 18:53:49 -0800 (PST)

> HTTPClient library, so should I use basic authentication or digest

The WebDAV spec states that Digest authentication must be used.

However, all clients and servers, that I'm aware of, are flexible in this
regard. For example, Apache and mod_dav will allow the use of Basic
authentication.

Cheers,
-g