Subject: webfolders.mydocsonline.com server

From: Joe Orton <[email-masked]>
Date: Sat, 11 Dec 1999 14:03:20 +0000

The PROPFIND response on this server is broken. I send:

PROPFIND / HTTP/1.1
User-Agent: cadaver/0.5.0
Connection: Keep-Alive
Host: webfolders.mydocsonline.com
Content-Type: text/xml
Depth: 0
Content-Length: 152
Authorization: xxxxxxxxxxxxxxxxxxxxxxxxxx

Response body is:

<?xml version="1.0" encoding="utf-8"?>
<D:multistatus xmlns:D="DAV:">
<D:response xmlns:i0="DAV:">
<D:href>/</D:href>
<D:propstat>
<D:prop>
<D:getlastmodified>Oct,  Jan   GMT</D:getlastmodified>
<D:resourcetype><D:collection/></D:resourcetype>
</D:prop>
<D:status>HTTP/1.1 200 OK</D:status>
</D:propstat>
<D:propstat>
<D:prop>
<i0:getcontentlength/>
</D:prop>
<D:status>HTTP/1.1 404 Not Found</D:status>
</D:propstat>
</D:response>
</D:multistatus>

Where the DAV:getlastmodified element is corrupt.

Regards,

joe

---

From: Greg Stein <[email-masked]>
Date: Sat, 11 Dec 1999 06:28:28 -0800 (PST)

On Sat, 11 Dec 1999, Joe Orton wrote:
>...

The MyDocsOnline server is mod_dav (modified, I believe) under the covers.
Looking at the code for getlastmodified, it would seem there is a problem
with the C lib on the server. I'm doing the following:

    sprintf(buf,
	    "%s, %.2d %s %d %.2d:%.2d:%.2d GMT",

I can't see how it would generate the text you saw... very weird. I don't
have a developer contact there, so let's hope they're listening here or
will respond soon with the feedback@ address (so I can help them with the
problem).

Thanx for reporting this, Joe!

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/

---

From: Joe Orton <[email-masked]>
Date: Tue, 21 Dec 1999 19:24:15 +0000

The PROPFIND problem seems to have gone away... I've not heard back about
any bugs being fixed, though.

So, more testing: MKCOL gives 500 internal server error. Request:

MKCOL /foo/ HTTP/1.1
User-Agent: cadaver/0.6.0-dev
Connection: Keep-Alive
Host: webfolders.mydocsonline.com
Authorization: Basic xxx

Response headers:

HTTP/1.1 500 Internal Server Error
Date: Tue, 21 Dec 1999 18:11:50 GMT
Server: Apache/1.3.6 (Unix) DAV/0.9-MyDocs
Connection: close
Transfer-Encoding: chunked
Content-Type: text/html

Regards,

joe