Subject: RE: comments on RFC2518bis-02, sec 13.16

From: Jason Crawford <[email-masked]>
Date: Sun, 22 Sep 2002 09:12:19 -0400

On Sunday, 09/22/2002 at 12:24 ZE2, "Julian Reschke"
<[email-masked]> wrote:
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Jason Crawford
> > Sent: Sunday, September 22, 2002 2:40 AM
> > To: Julian Reschke
> > Cc: [email-masked]
> > Subject: Re: comments on RFC2518bis-02, sec 13.16
> >
> >
> >
> > > 27) Section 13.16
> > >
> > > Remove
> > >
> > > "May contain additional elements not defined in this document."
> > >
> > > That's true for *all* XML in request/response bodies (also reccurs in
> > other
> > > places)
> >
> > It's also said in 13.17.  I'd say leave it.
>
> I think it's wrong. *All* XML elemens may be extended. If we only mention
it
> for specific element, people may read it saying that this is not the case
> anymore.

So how about adding "as with all XML elements"?   Or "as per [ref]"?
I just think it's a good idea to remind folks since they won't always be
aware
of this.  I believe there was even confusion on this list six months ago in
a
compatibility discussion involving the dav:source tag until this was
pointed
out.

---

From: "Julian Reschke" <[email-masked]>
Date: Mon, 23 Sep 2002 08:35:40 +0200

> Sent: Sunday, September 22, 2002 3:12 PM
> To: Julian Reschke
> Cc: [email-masked]
> Subject: RE: comments on RFC2518bis-02, sec 13.16
>
> ...
>

Better.

> compatibility discussion involving the dav:source tag until this was

I still dislike this because if it's mentioned in one place, people may
deduce that it says something about the cases where it doesn't.

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760