Subject: RE: discovering the root of a deep lock

From: "Julian Reschke" <[email-masked]>
Date: Mon, 2 Sep 2002 15:18:36 +0200

OK,

seems that we had consensus on this protocol extension (got OKs from: Geoff
Clemm, Dan Brotsky and Jason Crawford, and no negative feedback).

This should close issue #89 (FINDING_THE_ROOT_OF_A_DEPTH_LOCK).

Lisa, is there any chance that we may be able to get this into the RFC2518
revision? I'm happy to provide a URL of a test server implementing this in
time before the interop meeting.

Regards,

Julian

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760

> -----Original Message-----
> From: Julian Reschke [mailto:[email-masked]]
> Sent: Wednesday, July 10, 2002 9:39 AM
> To: [email-masked]
> Subject: discovering the root of a deep lock
>
>
> (see also issue LOCKS_SHOULD_THEY_USE_AN_IF_HEADER_TO_VERIFY)
>
> Proposed syntax:
>
> 12.1  activelock XML Element
>
> Name:
> activelock
> Namespace:
> DAV:
> Purpose:
> Describes a lock on a resource.
>
>    <!ELEMENT activelock (lockscope, locktype, depth, owner?,
> timeout?, locktoken?, lockroot?) >
>
>
> 12.1.x  lockroot XML Element
>
> Name:
> lockroot
> Namespace:
> DAV:
> Purpose:
> For locks with depth infinity, servers SHOULD report the root of
> the lock using the DAV:lockroot element. This enables clients to
> know the scope of resources affected by a subsequent UNLOCK with
> the given lock token. For lock with depth 0, the DAV:lockroot
> element MUST NOT be present.
>
>    <!ELEMENT lockroot (href) >
>
>
> --
>
> Note: I made it a "SHOULD" in order not to break existing implementations.
>
>
>

---

From: Jason Crawford <[email-masked]>
Date: Mon, 2 Sep 2002 14:06:35 -0400

On Monday, 09/02/2002 at 03:18 ZE2, "Julian Reschke" <nnjulian.
> time before the interop meeting.

I've moved the state of that issue to Edit although I think we need to test
some
interop.

Let's get a few of the folks that will be at the interop to implement this.

J.

------------------------------------------
Phone: 914-784-7569