Subject: RE: Interoperability for DAV:ishidden?

From: "Clemm, Geoff" <[email-masked]>
Date: Wed, 4 Sep 2002 22:59:03 -0400

We'll get DAV:resourceid in the binding draft ... which I *have* 
been working on, but got interrupted by the stuff they pay me to do (:-).

Cheers,
Geoff

-----Original Message-----
From: Eric Sedlar [mailto:[email-masked]]
Sent: Wednesday, September 04, 2002 10:08 PM
To: [email-masked]
Subject: Re: Interoperability for DAV:ishidden?

One property that keeps coming up (also in the Microsoft proposal) is the
resource-ID property, to uniquely identify a resource (generally a GUID).
I'm constantly getting requests from internal groups for this, and I know a
lot of the JSR-170 people are interested in this for content management
apps.

Of course another related requirement is the ability to fetch resources by
ID.  This could be done either by fully utilizing the DAV: namespace, e.g.
DAV:<resourceID> as the URL or by waiting for DASL.

--Eric

---

From: "Clemm, Geoff" <[email-masked]>
Date: Thu, 5 Sep 2002 09:49:51 -0400

Fair enough.  I have no problem deferring it to DAV:advancedsearch.

Cheers,
Geoff

-----Original Message-----
From: Julian Reschke [mailto:[email-masked]]
Sent: Thursday, September 05, 2002 8:42 AM
To: Clemm, Geoff; [email-masked]
Subject: RE: Interoperability for DAV:ishidden?

Well,

that's certainly a *new* requirement that hasn't been mentioned on the DASL
list before.

Is it useful? Yes. Does it belong into DAV:basicsearch? I don't think so.

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Clemm, Geoff
> Sent: Thursday, September 05, 2002 2:35 PM
> To: [email-masked]
> Subject: RE: Interoperability for DAV:ishidden?
>
>
>
> I don't think we have to require that relativeURIs be resolved
> for comparisons (since we can't expect a server to determine
> when two URLs in general are bound to the same resource) but a
> server should be allowed to do so.  The primary need is to be able
> to say "find resources whose xxx:foo property refers to a resource
> whose yyy:bar property has the value zzz" (i.e. to search through
> hrefs the way DAV:expand-property lets you PROPFIND through hrefs.
>
> Cheers,
> Geoff
>
> From: Julian Reschke [mailto:[email-masked]]
> Sent: Thursday, September 05, 2002 8:12 AM
> To: Clemm, Geoff; [email-masked]
> Subject: RE: Interoperability for DAV:ishidden?
>
>
> Correct. Keep in mind that back when DAV:basicsearch was
> designed, there was
> no href-typed DAV: property.
>
> The issue here is to define a meaningful operator -- for instance, at a
> minimum the operator would need to be able to resolve relativeURIs for
> comparisons, right?
>
> Julian
> --
> <green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760
>
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Clemm, Geoff
> > Sent: Thursday, September 05, 2002 2:06 PM
> > To: [email-masked]
> > Subject: RE: Interoperability for DAV:ishidden?
> >
> >
> >
> > The DASL spec doesn't have provisions for searching through
> > a DAV:href reference?  That sounds like an essential piece of
> > functionality
> > for a DAV searching protocol.
> >
> > Cheers,
> > Geoff
> >
> > From: Julian Reschke [mailto:[email-masked]]
> > Sent: Thursday, September 05, 2002 4:17 AM
> > To: Eric Sedlar; [email-masked]
> > Subject: RE: Interoperability for DAV:ishidden?
> >
> >
> >
> > > From: [email-masked]
> > > [mailto:[email-masked]]On Behalf Of Eric Sedlar
> > > Sent: Thursday, September 05, 2002 4:08 AM
> > > To: [email-masked]
> > As Geoff pointed out, this will be available as part of the
> BIND spec. It
> > could be used on systems even when they don't specifically
> > support the BIND
> > method.
> >
> > First of all, the "unique resource ID" just is a URI. Which URI
> scheme is
> > used is up to the server. So it's completely free to assign an
> > HTTP URI, and
> > this obviously could then be used to fetch the ressource. If the
> > resourceId
> > isn't an HTTP URI, WebDAV doesn't give you any direct mean to
> retrieve it.
> >
> > Re: locating a WebDAV ressource by resourceid -- this won't
> work with the
> > current DASL spec (at least not with the DAV:basicsearch grammar), as I
> > expect the property to have DAV:href content -- something in
> > which you can't
> > search using DASL. Therefore, a REPORT (locate-by-resourceid) may be
> > appropriate...
> >
> > Julian
> >
> > --
> > <green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760
> >
>