Subject: Re: I-D Action:draft-reschke-webdav-post-02.txt

From: Julian Reschke <[email-masked]>
Date: Sun, 30 Nov 2008 20:19:00 +0100

Hi,

I have updated my "POST in WebDAV proposal".

At this point I think it's ready for an informal last call. From my 
point of view the remaining questions are:

- is there sufficient community support for this justifying the put the 
element names into the DAV: namespace?

and

- should I keep the sections that talk about the HTTP Link header (which 
is currently being proposed in an I-D which may or may not be ready 
before this proposal is ready)

BR, Julian

[email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 	Title           : Using POST to add Members to Web Distributed Authoring and Versioning (WebDAV) Collections
> 	Author(s)       : J. Reschke
> 	Filename        : draft-reschke-webdav-post-02.txt
> 	Pages           : 15
> 	Date            : 2008-11-30
> 
> The Hypertext Transfer Protocol (HTTP) Extensions for the Web
> Distributed Authoring and Versioning (WebDAV) do not define the
> behavior for the "POST" method when applied to collections, as the
> base specification (HTTP) leaves implementers lots of freedom for the
> semantics of "POST".
> 
> This has led to a situation where many WebDAV servers do not
> implement POST for collections at all, although it is well suited to
> be used for the purpose of adding new members to a collection, where
> the server remains in control of the newly assigned URL.  As a matter
> of fact, the Atom Publishing Protocol (AtomPub) uses POST exactly for
> that purpose.  On the other hand, WebDAV-based protocols such as the
> Calendar Extensions to WebDAV (CalDAV) frequently require clients to
> pick a unique URL, although the server could easily perform that
> task.
> 
> This specification defines a discovery mechanism through which
> servers can advertise support for POST requests with the
> aforementioned "add collection member" semantics.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-reschke-webdav-post-02.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Geoffrey M Clemm <[email-masked]>
Date: Sun, 30 Nov 2008 15:46:33 -0700

I support this draft, and believe the element names should be added into 
the DAV: namespace.

I suggest removing the section that talks about the HTTP Link header, to 
remove this dependency (or at least, marking it somehow as "to be removed 
by editor if the HTTP Link I-D is not ready").

Cheers,
Geoff

> >    Title           : Using POST to add Members to Web Distributed 
> Authoring and Versioning (WebDAV) Collections
> >    Author(s)       : J. Reschke