Subject: Re: [weirds] I-D Action: draft-hollenbeck-dnrd-ap-query-00.txt

From: Dave Piscitello <[email-masked]>
Date: Tue, 1 May 2012 05:07:56 -0700

On May 1, 2012, at 12:13 AM, Murray S. Kucherawy wrote:

>> 
>> Is it something the general public would be interested in? Or is it
>> something a domain industry person wants? If its the former, it is
>> probably a good idea. If it is the latter, then why aren't they using
>> EPP or whatever?
> 
> I would like to be able to, given a domain name, get back a unique identifier for the registrant (owner, for example), with some expectation that it's stable.  Then if some other domain name comes back showing the same registrant ID, I know the two are related.
> 
> Bonus if I can say "give me all records for which the owner's registrant ID is X", but I'm guessing that's a long shot.

This is a business decision or opportunity for anyone who manages registration data or accumulates a sufficiently large data set that it is "interesting" for some form of analysis. What makes this hard today is that you must write over a hundred parsers to do this - and certain Whois responders change their responses (ostensibly to defeat harvesting Whois).

> 
>> In general, the broad internet using community doesn't tend to remember
>> their own identifiers in registries. They only know the natural
>> identifiers, such as domain names or IP addresses. So a look up of
>> registrar's by ID is, in my opinion, a feature to make adopting the
>> protocol harder while not doing much benefit for the broader internet
>> public. But host lookups by IP addresses does seem like something an
>> internet user may want to trouble shoot problems.
> 
> I think you're right for human consumers of the data, but automated systems might have an actual use for it.

No "might" needed. There are actual use cases today. It's just much harder to do than it ought to be.

---

From: Eric Brunner-Williams <[email-masked]>
Date: Tue, 01 May 2012 08:45:23 -0400

On 4/30/12 11:09 AM, Hollenbeck, Scott wrote:
> I've received a private note from someone suggesting that queries for registrar objects by ID and hosts by IP address should be included in this draft. Does that sound reasonable?

no.

a "who is at dotted-quad" is (a) impossible for the server to answer
completely (com and org spindles are operational separated even if
sharing a common business model, etc.) and (b) only useful in the
price-capped, no-other-substantive-policy set of registries, aka the
cnobi set.

the service is best done from bulk access to the cnobi zone files.

-e