Subject: [weirds] the future is restful whois

From: Andy Newton <[email-masked]>
Date: Fri, 4 May 2012 18:59:27 +0000

Just thought people may want to know this.
As of January 2012, queries against ARIN's RESTful Whois system surpassed queries against ARIN's Port 43 Whois system.

-andy

---

From: George Michaelson <[email-masked]>
Date: Sun, 6 May 2012 09:39:24 +0300

Well done. That's a very interesting observation on adoption. Do you have any analysis of where the load is coming from?

Same as Whois? New ips? Apps?

On 04/05/2012, at 9:59 PM, Andy Newton <[email-masked]> wrote:

> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds

---

From: Francisco Obispo <[email-masked]>
Date: Sun, 6 May 2012 11:17:30 -0700

Hi Andy,

Would it be possible for you to share some of the statistics? more specifically User-Agents and how distributed the client base is.

Thanks!

> As of January 2012, queries against ARIN's RESTful Whois system surpassed queries against ARIN's Port 43 Whois system.

Francisco Obispo 
email: [email-masked]
Phone: +1 650 423 1374 || INOC-DBA *3557* NOC
PGP KeyID = B38DB1BE

---

From: Andy Newton <[email-masked]>
Date: Tue, 8 May 2012 14:06:19 +0000

> Same as Whois? New ips? Apps?

I'll see what we have. Last October when we did the measurements we did find that the vast majority of user agents hitting the RESTful service were Javascript apps running in web browsers.

-andy

---

From: Andy Newton <[email-masked]>
Date: Tue, 8 May 2012 14:08:33 +0000

> Would it be possible for you to share some of the statistics? more specifically User-Agents and how distributed the client base is.

I'll see if I can lay my hands on the data. I didn't do the analysis this time around, so it might take awhile. I will tell you that back in October when I looked at the user agents, the majority were Javascript apps use browser apis, and then the next biggest smattering were Python, Java, Cold Fusion, etc… Straight up brewer usage was a very small percentage.

-andy