Subject: Re: [weirds] FW: I-D Action: draft-kong-dnrd-ap-response-json-00.txt

From: Bob Bruen <[email-masked]>
Date: Tue, 12 Jun 2012 13:17:59 -0400 (EDT)

Hi Patrick,

I understand your point, which is why I stated that my point was not a 
technical issue. I am concerned that the technical
decisions made along the way might have a negative impact on the policy 
downstream.

The current whois is swamp of problems, some technical (like formats), but 
mostly policy. The ICANN RAA contract is currently
unenforcable. Legal requirements for registr[ars|ies] do not exist.

I do not want to turn this into a distraction. I just want to see that 
these things are considered as part of the technical
development to limit unintended consequences.

If anyone does want to know more details, please contact me directly.

                  --bob

On Tue, 12 Jun 2012, Patrick Vande Walle wrote:

> On 12/06/12 13:31, Bob Bruen wrote:
> > While this does not detract from your point, and this is not a
> > technical issue, the example of a registry/registrar having a policy
> > of not displaying all or part of a whois record is not acceptable. The
> > complete record should always be available.
> Hi Bob,
>
> My point is that we design a system that needs to be used by more than
> just the registries/registrars  that are under contract with ICANN,
> under their current contractual obligations.   If this is acceptable or
> not is a matter of policy, which is not the goal of this WG.
>
> Hence, the end product needs to be flexible enough to address all
> possible uses,  including the legal requirements that can be put on
> registries and registrars.  What this WG produces should not have a bias
> towards one policy or another.  BTW, this is also reflected in ICANN's
> RFP for an open source implementation :
> http://www.icann.org/en/news/rfps/restful-whois-16may12-en.pdf  (#2.5)
>
> Patrick
>

-- 
Dr. Robert Bruen
http://knujon.org
http://coldrain.net/bruen
+1.802.579.6288

---

From: Eric Brunner-Williams <[email-masked]>
Date: Fri, 15 Jun 2012 18:21:42 -0400

On 6/12/12 1:17 PM, Bob Bruen wrote:
> 
> The current whois is swamp of problems, some technical (like formats),
> but mostly policy. The ICANN RAA contract is currently

there are three assertions above. the first is true, the second false,
the third also false.

the second and third are also irrelevant to the problem of
specification of a reporting mechanism for data held in names and
numbers registries, nominally the non-falseness of the first assertion.

-e

---

From: Bob Bruen <[email-masked]>
Date: Sun, 17 Jun 2012 07:43:10 -0400 (EDT)

Hi Eric,

I guess you missed this article:

http://www.circleid.com/posts/20120312_icanns_contract_not_enforceable_on_whois_accuracy/

ICANN has acknowledged its veracity.

I was not clear in my statements. I meant "unenforcable" and "Legal 
requirements" in terms of whois in the RAA contract.

"Irrelevant?" Maybe.

                   --bob

On Fri, 15 Jun 2012, Eric Brunner-Williams wrote:

> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds
>