Subject: [weirds] Divide and Conquer

From: Olaf Kolkman <[email-masked]>
Date: Tue, 5 Jun 2012 12:37:29 +0200

Dear Colleagues,

Murray and myself have been talking to a few active working participants, with the area director, and among ourselves. 

Based on those discussion, and after coordination with Murray, I would
like to make two proposals for getting work done:

1. Working group drafts and output documents.

Murray has already called for adaption of a number of documents. Those
documents are all input documents. The output of the working group
might find its way into a different set of documents.

A structure that has been proposed to me by Scott H. and Andy N. seems reasonable: 

1. For all implementers:
  1.1 The use of HTTP
  1.2 Details of Redirecting

  1.3 Specification of generic json responses and extensibility mechanism
  1.4 Specification of generic xml responses and extensibility mechanism

2.Numbers:
  2.1 specification of queries
  2.2 specification of specific number-responses json responses

3.Names:
  3.1 specification of queries
  3.2 specification of specific name-related json responses 
and/or
  3.3 specification of specific number-related xml responses

It might be that 1.3 and 1.4 are so minimal that the information
therein is better (dublicated) in 2.2, 3.2, and 3.3.

2. Dealing with the data framework.

I believe that the data framework for the domain name space is one of
the biggest elephants in the room and that making sure we converge to
a comon understanding is critical to success of the working group. It
seems that an enumeration of all data elements that are comonly in use
including comonly used formats. Ray Bellis and Frederico Neves
have made a start with that in a spreadsheet at
https://docs.google.com/spreadsheet/ccc?key=0AjZQpmBlboLWdFBfdERTQm9QQWdrejNtaTBhNmI3SHc#gid=0
and it seems that we can use that as a basis.

Once we have a relatively complete enumeration of all data elements
that are commonly in use we continue with trying to get convergence on
their presentation format (it seems we have to do that irrespective of
encaptulation in json or xml).

One of the important questions that might help to converge while
defining data elements and while determining such data-element can be
queried is whether the query-response protocol is direct match, or
search. The charter is not clear about this, I believe. Hence I
propose that we focus on the low-hanging fruit of direct-match and
that we circumvent any questions of the type 'what type of matching
algorithm to apply?' 

For instance, if we have a person name as a data element then a query
for "Kolkman" might not yield a unique result and some matching
algorithm may need to be applied, the use of a NIC-handle might be
more appropriate in such cases. By agreeing on the principle that we
work towards direct-match we know how to focus our energy.

How does this sound as a first order approach? If folk like this we'll
try to come up with a way to capture the information in the spreadsheet
(or other appropriate tool) and work forward in a structured way.

--Olaf 
  WEIRDS co-chair

NLnet
Labs
Olaf M. Kolkman

www.NLnetLabs.nl
[email-masked]

Science Park 400, 1098 XH Amsterdam, The Netherlands

---

From: Steve Sheng <[email-masked]>
Date: Tue, 5 Jun 2012 11:06:07 -0700

Hi Olaf,

From: Olaf Kolkman <[email-masked]<mailto:[email-masked]>>
To: Web Extensible Internet Registration Data Service Working Group <[email-masked]<mailto:[email-masked]>>
Subject: [weirds] Divide and Conquer

Dear Colleagues,

1. For all implementers:
  1.1 The use of HTTP

2.Numbers:

3.Names:

I support the approach outlined above.

I volunteer to help with this effort, and will produce such list for for gTLD registries and registrars shortly as a starting point. We could also help / facilitate reaching out to ccTLDs if needed.

I volunteer to help with this effort as well. There will be ICANN work on data models (called by the SSAC and Whois review team), I see both efforts similar and perhaps can collaborate / communicate. One thought though, this effort should not prescribe policy (e.g. What mandatory data elements to display), but should merely enable it. (e.g. If your policy asks to display X Y and Z, here is how to do it in a way that supports internationalization).

Agree. Francisco suggested earlier that moving the non direct-match into a second draft that focuses on searches.

--Olaf
  WEIRDS co-chair

NLnet
Labs

Olaf M. Kolkman

www.NLnetLabs.nl<http://www.NLnetLabs.nl>
[email-masked]<mailto:[email-masked]>

---

From: Steve Sheng <[email-masked]>
Date: Tue, 12 Jun 2012 11:39:00 -0700

Hello Olaf and all,

From:  Olaf Kolkman <[email-masked]>
To:  Web Extensible Internet Registration Data Service Working Group
<[email-masked]>
Subject:  [weirds] Divide and Conquer

> and it seems that we can use that as a basis.

I have done an inventory of the data elements that current gTLD registries'
Registration Data Directory Service (RDDS) output.

Attached please find the spreadsheet. This inventory contains 159 data
elements that are: 
  - actual RDDS output of 18 gTLD registries
  - new gTLD RDDS output as specified by ICANN applicant guidebook

Among these 159 data elements, 75 are common elements,  84 are registry
specific elements. This distinction is also highlighted in the excel sheet.

Finally, I have also harmonized  data labels from different gTLD registries
that refer to the same element.

Note, the scope of this exercise is limited to domain queries for gTLD
registries, it does not cover querying name server and registrars, nor does
it cover registrar RDDS in the case of thin registries. If people find this
preliminary exercise useful, I can continue to work on this, and also invite
others to participate to get this done for gTLDs as well as ccTLDs.

Steve

> www.NLnetLabs.nl <http://www.NLnetLabs.nl>
> [email-masked] <mailto:[email-masked]>
>

---

From: "\"Michele Neylon :: Blacknight\"" <[email-masked]>
Date: Tue, 12 Jun 2012 18:51:06 +0000

Steve

It's interesting to see that there is variety even when more than one extension is on the same backend.

Regards

Michele

On 12 Jun 2012, at 19:39, Steve Sheng wrote:

> <June 12 gTLD Registry Data Model.xls>

--
Mr Michele Neylon
Blacknight Solutions
Hosting & Colocation, Brand Protection
http://www.blacknight.com/
http://blog.blacknight.com/
http://mneylon.tel/
Intl. +353 (0) 59  9183072
Locall: 1850 929 929
Direct Dial: +353 (0)59 9183090
Fax. +353 (0) 1 4811 763
Twitter: http://twitter.com/mneylon
-------------------------------
Blacknight Internet Solutions Ltd, Unit 12A,Barrowside Business Park,Sleaty
Road,Graiguecullen,Carlow,Ireland  Company No.: 370845

---

From: "Ning Kong" <[email-masked]>
Date: Wed, 13 Jun 2012 17:51:37 +0800

Hi Steve,

Thanks for your contribution! I hope this work can be continued and I'd like
to join. 

I believe the output of this work can help us to improve the response draft
(e.g. finding out some better names for terms of objects, and even
specifying an absolutely minimum data element set in a response).

Cheers,

Ning

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Steve Sheng
Sent: Wednesday, June 13, 2012 2:39 AM
To: Olaf Kolkman; Web Extensible Internet Registration Data Service Working
Group
Subject: Re: [weirds] Divide and Conquer

Hello Olaf and all, 

 

Dear Colleagues,

Murray and myself have been talking to a few active working participants,
with the area director, and among ourselves. 

 

A structure that has been proposed to me by Scott H. and Andy N. seems
reasonable: 

1. For all implementers:

  1.1 The use of HTTP

2.Numbers:

3.Names:

and/or

 

 

https://docs.google.com/spreadsheet/ccc?key=0AjZQpmBlboLWdFBfdERTQm9QQWdrejN
taTBhNmI3SHc#gid=0

Steve

algorithm to apply?' 

--Olaf 

  WEIRDS co-chair

NLnet
Labs

Olaf M. Kolkman

 <http://www.NLnetLabs.nl> www.NLnetLabs.nl

 <mailto:[email-masked]> [email-masked]

---

From: "John Levine" <[email-masked]>
Date: 13 Jun 2012 14:56:53 -0000

>Registration Data Directory Service (RDDS) output.

Thanks, this is very helpful.  Any chance of a similar comparison of the
query types the various TLDs support?  The specs in the various registry
agreements are susprisingly divergent.

R's,
John

---

From: Steve Sheng <[email-masked]>
Date: Wed, 13 Jun 2012 09:04:58 -0700

Hello John, 

-----Original Message-----
From: John Levine <[email-masked]>
To: "[email-masked]" <[email-masked]>
Cc: Steve Sheng <[email-masked]>
Subject: Re: [weirds] Divide and Conquer

>agreements are susprisingly divergent.

Attached please find the analysis that I sent to the list earlier.

---

From: Steve Sheng <[email-masked]>
Date: Wed, 13 Jun 2012 09:17:25 -0700

Thanks Ning for the offer, let's discuss off-list on how to improve this.
Let's also reach out to Frederico and Ray to see how we can effectively
survey the the ccTLDs.

Steve

From:  Ning Kong <[email-masked]>
To:  Steve Sheng <[email-masked]>, 'Olaf Kolkman'
<[email-masked]>, 'Web Extensible Internet Registration Data Service
Working Group' <[email-masked]>
Subject:  RE: [weirds] Divide and Conquer

> Hi Steve,
>  
> Thanks for your contribution! I hope this work can be continued and I¹d like
> to join. 
> (e.g. finding out some better names for terms of objects, and even specifying
> an absolutely minimum data element set in a response).
>  
>  
> Cheers,
> Ning
>  
> 
> registries, it does not cover querying name server and registrars, nor does it
> cover registrar RDDS in the case of thin registries. If people find this
>> LabsOlaf M. Kolkman