Subject: [weirds] Supporting Objects

From: Olaf Kolkman <[email-masked]>
Date: Wed, 11 Jul 2012 22:11:39 +0200

Colleagues,

(Also see mail with subject: "Setting the WEIRDS IETF 84 agenda")

When we talk about supporting objects in the context of Weirds it seems useful to be in sync about what that means.

I propose that in the context of WEIRDs we talk about MUST support then:
 * the query format is defined
 * the resource format is defined
 * servers MUST be able to parse the request
 * clients MUST be able to parse the answer

However, supporting does not mean that in all cases the objects are passed over the wire. Any of the objects may, depending on local policy, be refused.

What we are set out to do is to define a data model that supports a useful set of objects that can serve environments from the most liberal to the most strict local policy.

Is there consensus on the above, does the above need refinement, or is this not useful at al?

--Olaf, WEIRDs co-chair

_______________________________________________________ 
Olaf Kolkman -- NLnet Labs
http://www.nlnetlabs.nl/

---

From: Jim Galvin <[email-masked]>
Date: Thu, 12 Jul 2012 11:28:15 -0400

-- On July 11, 2012 10:11:39 PM +0200 Olaf Kolkman <[email-masked]> 
wrote regarding [weirds] Supporting Objects --

> What we are set out to do is to define a data model that supports a
> useful set of objects that can serve environments from the most
> liberal to the most strict local policy.

I'm not sure this working group is the right place to define *the* data 
model.  We already have numbers versus names and we know that there is 
different information in each of those.

Could we instead define a framework for the data model (e.g., I like 
the category of objects discussion and maybe we just give examples in 
each)?  This would let each of the communities that would use the 
weirds protocol to define the specifics of its own data model.

Jim

---

From: "John Levine" <[email-masked]>
Date: 12 Jul 2012 17:47:41 -0000

>Could we instead define a framework for the data model 

Not if our goal is to produce something useful.  While it is
true that the models for names and numbers will be different,
it is absolutely essential that we nail down, for each side,
what the query syntax is, and how to parse the results.

The numbers side is mostly done, since they have several
working prototypes that are nearly the same.  If the names
side can't agree on a model, the numbers work will go ahead
separately.

R's,
John

PS: Don't argue, there is specific language in the charter
that anticipates this situation.

---

From: "Linlin Zhou" <[email-masked]>
Date: Mon, 16 Jul 2012 15:53:02 +0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Jim Galvin
> Sent: Thursday, July 12, 2012 11:28 PM
> To: Web Extensible Internet Registration Data Service Working Group
> Subject: Re: [weirds] Supporting Objects
> 
> 
> 
wrote
> regarding [weirds] Supporting Objects --
> 
model.
> We already have numbers versus names and we know that there is different
> information in each of those.
> 
> Could we instead define a framework for the data model (e.g., I like the
> category of objects discussion and maybe we just give examples in each)?
> This would let each of the communities that would use the weirds protocol
to
> define the specifics of its own data model.
> 
I think at least we should have a data element set that are commonly used by
different registries, the other extensions can be defined on its own.

> Jim
> 
> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds