Subject: [weirds] Working Group Documents

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 3 Aug 2012 17:13:23 +0000

I'm still a little confused about the approach we're taking with respect to write our working group documents. During the meeting on Wednesday we saw a slide that described an approach, but we didn't talk about specifics in the context of the current set of individual submission drafts. Can someone describe the document proposal in a bit more detail?

Scott

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Sun, 5 Aug 2012 13:40:52 -0700

> I'm still a little confused about the approach we're taking with respect to write our working group documents. During the meeting on Wednesday we saw a slide that described an approach, but we didn…

In Vancouver, the co-chairs presented a proposed path forward that
included documents that describe framework, transport (including
authentication), query and reply specifications with an aim toward a
convergence as far up the stack as possible, splitting only when
needed toward the "end" where the two major constituents diverge in
their data.  This appeared to be acceptable to the room, inasmuch as a
few people said so and nobody said otherwise.

I believe this means the current documents marked "Call For Adoption"
are, in general, inputs to that idea but may or may not be directly
usable toward those goals.

My view is that the design team(s) we dispatch will use the
presentations in Vancouver and these drafts as input to the proposals
they will bring back to the working group, with the "unified stack"
notion as a guideline.  The team(s) can determine which documents, if
any, are suitable bases going forward, or if from-scratch documents
would be better starting points.

However, I'm also open to suggestions from the working group.

-MSK

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 7 Aug 2012 11:30:10 +0000

> -----Original Message-----
> From: Murray S. Kucherawy [mailto:[email-masked]]
> Sent: Sunday, August 05, 2012 4:41 PM
> To: Hollenbeck, Scott
> Cc: [email-masked]
> Subject: Re: [weirds] Working Group Documents
> 
> > I'm still a little confused about the approach we're taking with
> respect to write our working group documents. During the meeting on
> Wednesday we saw a slide that described an approach, but we didn't talk
> about specifics in the context of the current set of individual
> submission drafts. Can someone describe the document proposal in a bit
> more detail?
> 

OK, so the approach described in this note from 16 May:

http://www.ietf.org/mail-archive/web/weirds/current/msg01071.html

is being reconsidered. Which design team is responsible for producing a proposal? The team described in this note:

http://www.ietf.org/mail-archive/web/weirds/current/msg01444.html

appears to have other responsibilities.

Scott

---

From: SM <[email-masked]>
Date: Tue, 14 Aug 2012 15:02:54 -0700

At 04:30 07-08-2012, Hollenbeck, Scott wrote:
>is being reconsidered. Which design team is responsible for 
>producing a proposal? The team described in this note:
>

Why does the working group need design teams?  Are there any drafts 
which can be used as input?  Please note that I have read the drafts 
posted to figure out whether to head North, South, East or West.

In my individual opinion there has been the usual bickering about 
direction and composition of the design teams.  The current state is 
that nobody is responsible for producing anything by a due date.

May I not-so-humbly suggest that one or two individuals are 
dispatched to write some drafts?  If the individuals cannot come up 
with some proposals that the working group find palatable, they can 
be placed on extended leave.

I think that it is high time to move ahead with the suicide mission. :-)

Regards,
-sm

---

From: Arturo Servin <[email-masked]>
Date: Tue, 14 Aug 2012 17:16:27 -0500

There are two documents by numbers describing the data model and the query. We built those after analysing the different RIR data-models and finding common ground:

draft-newton-et-al-weirds-rir-json-response
draft-newton-et-al-weirds-rir-query

	I suggest that name's people look at them and to the research presented in Vancouver and tell us if the objects described in the I+Ds are re-usable as they are or with amendments.

	Afterwards, a possible outcome would be to describe common objects/queries between names and numbers (if such intersection exists) in a document or just to use numbers as an starting point and extend the model in names documents (if somebody ask me, I prefer the later)

my 20 cents,
as

On 14 Aug 2012, at 17:02, SM wrote:

> Why does the working group need design teams?  Are there any drafts which can be used as input?  Please note that I have read the drafts posted to figure out whether to head North, South, East or West.
> 
> In my individual opinion there has been the usual bickering about direction and composition of the design teams.  The current state is that nobody is responsible for producing anything by a due date.
> 
> May I not-so-humbly suggest that one or two individuals are dispatched to write some drafts?  If the individuals cannot come up with some proposals that the working group find palatable, they can be placed on extended leave.
> 
> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 15 Aug 2012 01:01:37 +0000

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of SM
> Sent: Tuesday, August 14, 2012 6:03 PM
> To: [email-masked]

This is what I'm getting concerned about because we now seem to be in a state of paralysis. For whatever it's worth I'm going to take up Arturos's suggestion and take another look at the RIR drafts with an eye towards identifying the common components. Andy and I should be able to come up with some recommendations after we've had a chance to compare notes.

Scott

---

From: SM <[email-masked]>
Date: Tue, 14 Aug 2012 18:32:50 -0700

Hi Arturo,
At 15:16 14-08-2012, Arturo Servin wrote:
>         There are two documents by numbers describing the data 
> model and the query. We built those after analysing the different 
> RIR data-models and finding common ground:
>
>         I suggest that name's people look at them and to the 
> research presented in Vancouver and tell us if the objects 
> described in the I+Ds are re-usable as they are or with amendments.

These drafts are not working group items.  The "look and research and 
tell us" would look good in a management report where we have to show 
that we are doing something.

>         Afterwards, a possible outcome would be to describe common 
> objects/queries between names and numbers (if such intersection 
> exists) in a document or just to use numbers as an starting point 
> and extend the model in names documents (if somebody ask me, I 
> prefer the later)

I remember hearing the above some time back.  Is anyone working on 
one possible outcome?  When will there be a proposal about that?

Regards,
-sm

---

From: Andy Newton <[email-masked]>
Date: Wed, 15 Aug 2012 01:48:26 +0000

On Aug 14, 2012, at 9:32 PM, SM wrote:

> These drafts are not working group items.  The "look and research and tell us" would look good in a management report where we have to show that we are doing something.

What exactly do you mean by this?

-andy

---

From: Arturo Servin <[email-masked]>
Date: Tue, 14 Aug 2012 23:04:36 -0500

Does it matter that they do not have the "weirds" words on it?

	You asked for some individuals to write some drafts, the drafts are there as part of the numbers work. In my view if we want to reuse some objects we should start by reviewing the work already done. If something is useful for names, let's use it.

Regards.
.as

On 14 Aug 2012, at 20:32, SM wrote:

> I remember hearing the above some time back.  Is anyone working on one possible outcome?  When will there be a proposal about that?
> 
> Regards,
> -sm
>

---

From: SM <[email-masked]>
Date: Tue, 14 Aug 2012 22:30:27 -0700

Hi Arturo,
>         Does it matter that they do not have the "weirds" words on it?

Yes, it does as it means that the WG has a draft to work on.

>         You asked for some individuals to write some drafts, the 
> drafts are there as part of the numbers work. In my view if we want 
> to reuse some objects we should start by reviewing the work already 
> done. If something is useful for names, let's use it.

The work already done is useful as a starting point.  Linlin Zhou 
posted some information for names ( 
http://www.ietf.org/mail-archive/web/weirds/current/msg01470.html 
).  Scott Hollenbeck asked about the approach being taken ( 
http://www.ietf.org/mail-archive/web/weirds/current/msg01455.html 
).  If the following is the equation:

   x = a + b - c

a can be resolved, then b, then c, to get to get the answer for 
x.  You cannot get anywhere without b or c.  What I asked about is 
how to get to that WG draft (x) and when does the WG plan to get there.

Regards,
-sm

---

From: SM <[email-masked]>
Date: Tue, 14 Aug 2012 22:00:43 -0700

Hi Andy,
>What exactly do you mean by this?

There still isn't any WG draft.  From an IETF perspective work gets 
done once there is a WG draft which reflect the WG discussions.

Regards,
-sm

---

From: SM <[email-masked]>
Date: Wed, 15 Aug 2012 01:43:55 -0700

Hi Scott,
At 18:01 14-08-2012, Hollenbeck, Scott wrote:
>This is what I'm getting concerned about because we now seem to be 
>in a state of paralysis. For whatever it's worth I'm going to take 
>up Arturos's suggestion and take
>  another look at the RIR drafts with an eye towards identifying the 
> common components. Andy and I should be able to come up with some 
> recommendations after we've had a chance to compare notes.

That sounds encouraging as you are looking at the two sides of the 
problem instead of one side waiting for the other side to do 
something.  The next question would be when do you expect to be able 
to share the recommendations with the group.

Regards,
-sm

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 15 Aug 2012 10:42:09 +0000

> From: SM [mailto:[email-masked]]
> Sent: Wednesday, August 15, 2012 4:44 AM
> To: Hollenbeck, Scott
> Cc: [email-masked]
> Subject: RE: [weirds] Working Group Documents
> 
> Hi Scott,

Within a few weeks, depending on coordinating schedules with Andy.

Scott

---

From: "Linlin Zhou" <[email-masked]>
Date: Wed, 15 Aug 2012 18:43:10 +0800

> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Arturo Servin
> Sent: Wednesday, August 15, 2012 6:16 AM
> To: SM
> Cc: [email-masked]
> 	I suggest that name's people look at them and to the research
presented
> in Vancouver and tell us if the objects described in the I+Ds are
re-usable as
> they are or with amendments.
> 
> objects/queries between names and numbers (if such intersection exists) in
a
> document or just to use numbers as an starting point and extend the model
in
> names documents (if somebody ask me, I prefer the later)
> 
The object inventory analysis done for names is to help identify common
objects in various name registries. The point is that I don't think we have
consensus on common elements for names. 
I agree that using numbers as a starting point. But I think discussion and
clarification on what elements are common or extension in registries of
names is necessary. Don't we need to do this work first or in parallel?

Regards,
Linlin Zhou

---

From: SM <[email-masked]>
Date: Wed, 15 Aug 2012 06:02:22 -0700

Hi Linlin,
>consensus on common elements for names.

How about looking at the inventory in terms of:

  (i)   Things that people can agree about

  (ii)  Things that people are discussing about

  (iii) Things that people strongly disagree about.

It may be easier to identify the issues then.

>names is necessary. Don't we need to do this work first or in parallel?

If you look at it in terms of whether to do the work first or in 
parallel, that's one more question for the group to answer.  An 
individual could propose something instead (see above).

Regards,
-sm