Subject: [weirds] New Unified DNR/RIR Internet-Drafts

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 31 Aug 2012 12:35:31 +0000

Andy Newton and I have been working on a set of documents that we hope will allow us to start making progress on a unified RIR/DNR approach to queries and responses. The first two of the three documents were just announced:

https://datatracker.ietf.org/doc/draft-hollenbeck-weirds-unified-rdap-query

https://datatracker.ietf.org/doc/draft-newton-weirds-unified-json-response

The third document describes security services and their applications to the protocol. I haven't posted it yet because the reference files for the first two documents (I like to use XML entities that refer to remote files for my document references) aren't yet accessible. I'll publish this third document as soon as I can. When done it will be visible here:

https://datatracker.ietf.org/doc/draft-hollenbeck-weirds-rdap-sec

So, a question for the chairs and group: combined with the "using http" and redirection drafts, do we now have a set that's ready to become working group documents?

Scott

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 31 Aug 2012 13:54:08 +0000

> -----Original Message-----
> From: Hollenbeck, Scott
> Sent: Friday, August 31, 2012 8:36 AM
> To: [email-masked]
> Subject: New Unified DNR/RIR Internet-Drafts
> 
> Andy Newton and I have been working on a set of documents that we hope
> will allow us to start making progress on a unified RIR/DNR approach to
> queries and responses. The first two of the three documents were just
> announced:
> 
> The third document describes security services and their applications
> to the protocol. I haven't posted it yet because the reference files
> for the first two documents (I like to use XML entities that refer to
> remote files for my document references) aren't yet accessible. I'll
> publish this third document as soon as I can. When done it will be
> visible here:
> 

This third document has also been uploaded and announced.

Scott

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 31 Aug 2012 13:18:59 -0700

> So, a question for the chairs and group: combined with the "using http" and redirection drafts, do we now have a set that's ready to become working group documents?

Having not yet spoken to Olaf (who is on vacation), my view is that
this is in line with the vision the chairs presented in Vancouver for
a path forward.  Kudos to you and Andy for taking this initiative.

To the WG: I propose that we adopt these as initial working group
documents toward our milestones.  Note, as usual, that they are merely
starting points and foci for discussion; we need to develop them and
reach working group consensus before they will be advanced for
publication.

I'll place them in Call For Adoption state now.  Please review them
and comment as to whether you believe they are reasonable starting
points for development.

-MSK