Subject: [weirds] simplifying the media type versioning

From: Andy Newton <[email-masked]>
Date: Tue, 14 Aug 2012 14:17:06 +0000

At the meeting in Vancouver, Chris Wright pointed out that versioning with media types does not include versioning of the extensions. To me, that is a valid point.

Using JCK's pleading that we keep this stuff simple, it might be best to define one media type for everything and use the version identifiers in the rdapConformance structure. The danger in doing so is that it would present problems if version 2 was a radical departure from version 1. In my opinion, that probability is low.

Does anybody had a strong opinion against simplifying the media types or see any big issues with doing so?

-andy

---

From: Leif Johansson <[email-masked]>
Date: Tue, 14 Aug 2012 16:56:33 +0200

On 08/14/2012 04:17 PM, Andy Newton wrote:
> At the meeting in Vancouver, Chris Wright pointed out that
> versioning with media types does not include versioning of the
> extensions. To me, that is a valid point.
> 
> Using JCK's pleading that we keep this stuff simple, it might be
> best to define one media type for everything and use the version
> identifiers in the rdapConformance structure. The danger in doing
> so is that it would present problems if version 2 was a radical
> departure from version 1. In my opinion, that probability is low.
> 
> Does anybody had a strong opinion against simplifying the media
> types or see any big issues with doing so?
I think its fine - the worst that can happen is that version 4711 has
to declare a completely new media type.

	Cheers Leif