Subject: [weirds] switching to RFC 5988 link type registry

From: Andy Newton <[email-masked]>
Date: Wed, 10 Oct 2012 13:20:06 +0000

All,

We currently define a structure for linking to registry related things
using URIs. It looks like this:

"uris" :
  [
    {
      "type" : "source",
      "uri" : "http://whois-rws.net/contact/xxxx"
    },
    {
      "type" : "held",
      "uri" : "http://example.net/location/xxxx"
    }
  ]

And we define the types in Appendix A.3
(http://tools.ietf.org/html/draft-ietf-weirds-json-response-00#appendix-A.3
).

Does anybody see a downside to switching to a more Atom like approach and
re-using link types from the RFC 5988 IANA registry? In other words,
instead of doing our own thing move to a pre-established method.

Given the entries in the 5988 registry and what we have, here's the
re-arrangement I see:

'self' - use 'self' from 5988 registry.
'parent' - use 'up' from 5988 registry.
'source' - use 'alternate' from 5988 with an appropriate media type in the
'type' parameter.
'web' - use 'alternate' from 5988 with text/html or text/xhtml or whatever
media type
'rdap' - we may have to register something here, but that may also be an
indication that this type is not needed.
'held' and 'geo' - let the GEOPRIV wonks register these as they are
outside our bailiwick.

Comments and suggestions?

-andy

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 10 Oct 2012 16:06:08 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Andy Newton
> Sent: Wednesday, October 10, 2012 9:20 AM
> To: [email-masked]
> Subject: [weirds] switching to RFC 5988 link type registry
> 
> All,
> 
> Does anybody see a downside to switching to a more Atom like approach
> and re-using link types from the RFC 5988 IANA registry? In other
> words, instead of doing our own thing move to a pre-established method.

I like the idea of reusing an existing approach.

Scott

---

From: Chris Wright <[email-masked]>
Date: Thu, 11 Oct 2012 17:00:00 +1100

Adding my support to this - I thinks its a great idea

Thanks

Chris
On 11/10/12 12:20 AM, "Andy Newton" <[email-masked]> wrote:

>_______________________________________________
>weirds mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/weirds