Subject: [Wpack] FYI - Web Packaging at IETF 104 - in DISPATCH - Fwd: [dispatch] Re-dispatching Web Packaging

From: Dan York <[email-masked]>
Date: Fri, 8 Mar 2019 20:49:27 +0000

FYI, Jeffrey Yasskin has time on the DISPATCH agenda at IETF 104 in Prague. The WG meets at 9:00am (CET) on Monday, March 25.

Here is the message he sent to the DISPATCH list. (The current draft agenda points to this email message.)

--
Dan York
Director of Web Strategy, Internet Society
[email-masked]<mailto:[email-masked]>   +1-802-735-1624
Jabber: [email-masked]<mailto:[email-masked]>  Skype: danyork   http://twitter.com/danyork

http://www.internetsociety.org/

Begin forwarded message:

From: Jeffrey Yasskin <jyasskin=[email-masked]<mailto:jyasskin=[email-masked]>>
Subject: [dispatch] Re-dispatching Web Packaging
Date: February 15, 2019 at 12:30:05 PM EST
To: [email-masked]<mailto:[email-masked]>

Hello Dispatch,

TL;DR: I'd like to request another discussion of Web Packaging at IETF104. We think it'll be ready for a BOF at IETF105, but mnot suggested we take it back here for a second look.

We dispatched Web Packaging, https://github.com/WICG/webpackage/, at IETF99, with the discussion at https://mailarchive.ietf.org/arch/msg/dispatch/lZohQ8ypodcpB2f_jhxoBRMYl0o. On your advice, we split the proposal into two pieces, "signed exchanges", and "bundles". We also created the https://mailarchive.ietf.org/arch/browse/wpack/ mailing list, although it hasn't seen as much activity as the github issue tracker.

The signed exchanges specification is mostly complete, in an IETF draft that specifies the format: https://wicg.github.io/webpackage/draft-yasskin-http-origin-signed-responses.html<https://wicg.github.io/webpackage/draft-yasskin-http-origin-signed-responses..html>, and a WICG draft that specifies how it integrates with Fetch: https://wicg.github.io/webpackage/loading.html. We've implemented that specification in Chromium, run an origin trial in Chrome, and will be shipping the current version in Chrome 73: https://groups.google.com/a/chromium.org/d/topic/blink-dev/gPH_BcOBEtc/discussion.

Despite shipping the current version, we expect standards bodies to make more changes, and we've built in a way to migrate users to new versions of the specification.

The Bundles specification is very roughly sketched, but we expect to flesh that out and start implementing it in the next few months.

The W3C TAG recently discussed the state of things at https://github.com/w3ctag/meetings/blob/gh-pages/2019/02-tokyo/02-06-minutes.md#signed-exchanges-and-bundling.

Mark Nottingham and a representative of the TAG are organizing an "ESCAPE" conference at a TBD date to help publishers organize their feedback on the proposals. This has been pushed back a couple times, but it sounds like it's more solidly planned for either May or July before IETF105.

We think we'll be able to write a WG charter that we can discuss in a BOF at IETF105, with the goal of handing control of the specifications to a more formal group. However, mnot suggested that we come back to DISPATCH to see if anyone's sense of the right plan has changed now that we have a little more experience with the proposals.

Thanks,
Jeffrey
_______________________________________________
dispatch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dispatch

---

From: Jeffrey Yasskin <[email-masked]>
Date: Mon, 11 Mar 2019 15:15:36 -0700

I've also reserved up to 2 hours in the Wednesday afternoon side-meeting
session at 3pm:
https://trac.ietf.org/trac/ietf/meeting/wiki/104sidemeetings#Room:AthensBarcelonaWednesday.
We can go into more detail there, see what use cases folks are interested
in or worried about, start drafting the charter, etc.

Let me know if you want me to be especially prepared to talk about any
particular topics. :)

Jeffrey

On Fri, Mar 8, 2019 at 12:49 PM Dan York <[email-masked]> wrote:

> FYI, Jeffrey Yasskin has time on the DISPATCH agenda at IETF 104 in
> Prague. The WG meets at 9:00am (CET) on Monday, March 25.
>
> [email-masked]   +1-802-735-1624
> Jabber: [email-masked]..org <[email-masked]>  Skype: danyork
> http://twitter.com/danyork
>
> *From: *Jeffrey Yasskin <jyasskin=[email-masked]>
> *Subject: **[dispatch] Re-dispatching Web Packaging*
> *Date: *February 15, 2019 at 12:30:05 PM EST
> *To: [email-masked]
>
> Hello Dispatch,
>
> TL;DR: I'd like to request another discussion of Web Packaging at IETF104.
> We think it'll be ready for a BOF at IETF105, but mnot suggested we take it
> back here for a second look.
>
> We dispatched Web Packaging, https://github.com/WICG/webpackage/
> <https://github..com/WICG/webpackage/>, at IETF99, with the discussion at
> https://mailarchive.ietf.org/arch/msg/dispatch/lZohQ8ypodcpB2f_jhxoBRMYl0o.
> On your advice, we split the proposal into two pieces, "signed exchanges",
> and "bundles". We also created the
> https://mailarchive.ietf.org/arch/browse/wpack/ mailing list, although it
> hasn't seen as much activity as the github issue tracker.
>
> The signed exchanges specification is mostly complete, in an IETF draft
> that specifies the format:
> https://wicg.github.io/webpackage/draft-yasskin-http-origin-signed-responses.html
> <https://wicg.github..io/webpackage/draft-yasskin-http-origin-signed-responses..html>,
> and a WICG draft that specifies how it integrates with Fetch:
> https://wicg..github.io/webpackage/loading.html
> <https://wicg.github.io/webpackage/loading.html>. We've implemented that
> specification in Chromium, run an origin trial in Chrome, and will be
> shipping the current version in Chrome 73:
> https://groups.google.com/a/chromium.org/d/topic/blink-dev/gPH_BcOBEtc/discussion
> .
>
> Despite shipping the current version, we expect standards bodies to make
> more changes, and we've built in a way to migrate users to new versions of
> the specification.
>
> The Bundles specification is very roughly sketched, but we expect to flesh
> that out and start implementing it in the next few months.
>
> The W3C TAG recently discussed the state of things at
> https://github.com/w3ctag/meetings/blob/gh-pages/2019/02-tokyo/02-06-minutes.md#signed-exchanges-and-bundling
> .
>
> Mark Nottingham and a representative of the TAG are organizing an "ESCAPE"
> conference at a TBD date to help publishers organize their feedback on the
> proposals. This has been pushed back a couple times, but it sounds like
> it's more solidly planned for either May or July before IETF105.
>
> We think we'll be able to write a WG charter that we can discuss in a BOF
> at IETF105, with the goal of handing control of the specifications to a
> more formal group. However, mnot suggested that we come back to DISPATCH to
> see if anyone's sense of the right plan has changed now that we have a
> little more experience with the proposals.
>
> Thanks,
> Jeffrey
> [email-masked]
> Wpack mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/wpack
>