Subject: [Wpack] file: package URLs under rename

From: Devin Mullins <[email-masked]>
Date: Fri, 31 Jul 2020 07:09:51 -0700

To expand on Benjamin's question, there is potentially surprising behavior
here. If I download a bundle of a PWA (e.g. a game or a text editor) and
generate some storage, I may be surprised to find that storage disappear
when I rename the bundle on my hard drive.

I'm not sure if this is a use-case that is in scope or a priority for
anybody in this group? But it seems like a usage that would naturally arise
from the browser capability.

I'm not proposing any particular solution. If folks don't feel too strongly
about this, maybe it's fine if we just warn against this usage.

---

From: Jeffrey Yasskin <[email-masked]>
Date: Fri, 31 Jul 2020 07:30:46 -0700

https://github.com/WICG/webpackage/blob/master/explainers/bundle-urls-and-origins.md#downloading-bundles
discusses this question when the browser downloads the bundle, but I
hadn't considered it when the user renames the file outside the
browser. If the format included help for the browser to incrementally
hash the content, that could help to at least tell the user what's
happened...

On Fri, Jul 31, 2020 at 7:10 AM Devin Mullins
<twifkak=[email-masked]> wrote:
>
> To expand on Benjamin's question, there is potentially surprising behavior here. If I download a bundle of a PWA (e.g. a game or a text editor) and generate some storage, I may be surprised to find that storage disappear when I rename the bundle on my hard drive.
>
> I'm not sure if this is a use-case that is in scope or a priority for anybody in this group? But it seems like a usage that would naturally arise from the browser capability.
>
> I'm not proposing any particular solution. If folks don't feel too strongly about this, maybe it's fine if we just warn against this usage.
> _______________________________________________
> Wpack mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/wpack