Subject: [xml2rfc] My installation is broken and I can't seem to find the problem

From: "David R. Oran" <[email-masked]>
Date: Sun, 27 Sep 2020 17:21:01 -0400

all of  xml2rfc python3, and lib magic seem properly installed. Cluebat 
please?

  xml2rfc --html draft-irtf-icnrg-icnping-01.xml
Traceback (most recent call last):
   File "/Library/Frameworks/Python.framework/Versions/3.8/bin/xml2rfc", 
line 5, in <module>
     from xml2rfc.run import main
   File 
"/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/xml2rfc/__init__.py", 
line 14, in <module>
     from xml2rfc.parser import  XmlRfcError, CachingResolver, 
XmlRfcParser, XmlRfc
   File 
"/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/xml2rfc/parser.py", 
line 20, in <module>
     from xml2rfc.writers import base
   File 
"/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/xml2rfc/writers/__init__.py", 
line 10, in <module>
     from xml2rfc.writers.preptool import PrepToolWriter
   File 
"/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/xml2rfc/writers/preptool.py", 
line 41, in <module>
     from xml2rfc.util.mime import get_file_mime_type
   File 
"/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/xml2rfc/util/mime.py", 
line 4, in <module>
     import magic
   File 
"/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/magic.py", 
line 201, in <module>
     raise ImportError('failed to find libmagic.  Check your 
installation')
ImportError: failed to find libmagic.  Check your installation

python3 --version
Python 3.8.1

oran@ORAN-M-51B7 ~ % pip3 --version
pip 20.2.3 from 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/pip 
(python 3.8)

oran@ORAN-M-51B7 ~ % pip3 install --upgrade xml2rfc
Requirement already up-to-date: xml2rfc in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(3.1.1)
Requirement already satisfied, skipping upgrade: 
pycountry!=19.7.15,>=1.8 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from xml2rfc) (19.8.18)
Requirement already satisfied, skipping upgrade: 
google-i18n-address>=2.3.2 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from xml2rfc) (2.3.5)
Requirement already satisfied, skipping upgrade: six>=1.4.1 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from xml2rfc) (1.14.0)
Requirement already satisfied, skipping upgrade: configargparse>=1.2.3 
in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from xml2rfc) (1.2.3)
Requirement already satisfied, skipping upgrade: pyyaml>=5.3.1 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from xml2rfc) (5.3.1)
Requirement already satisfied, skipping upgrade: setuptools>=24.2.0 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from xml2rfc) (41.2.0)
Requirement already satisfied, skipping upgrade: appdirs>=1.4.4 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from xml2rfc) (1.4.4)
Requirement already satisfied, skipping upgrade: html5lib>=1.0.1 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from xml2rfc) (1.0.1)
Requirement already satisfied, skipping upgrade: python-magic>=0.4.18 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from xml2rfc) (0.4.18)
Requirement already satisfied, skipping upgrade: pyflakes>=0.8.1 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from xml2rfc) (2.1.1)
Requirement already satisfied, skipping upgrade: requests>=2.5.0 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from xml2rfc) (2.22.0)
Requirement already satisfied, skipping upgrade: 
intervaltree!=3.0.0,>=2.1.0 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from xml2rfc) (3.0.2)
Requirement already satisfied, skipping upgrade: jinja2<3.0,>=2.11 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from xml2rfc) (2.11.2)
Requirement already satisfied, skipping upgrade: lxml!=4.3.1,>=2.2.8 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from xml2rfc) (4.4.2)
Requirement already satisfied, skipping upgrade: kitchen>=1.2.6 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from xml2rfc) (1.2.6)
Requirement already satisfied, skipping upgrade: webencodings in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from html5lib>=1.0.1->xml2rfc) (0.5.1)
Requirement already satisfied, skipping upgrade: idna<2.9,>=2.5 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from requests>=2.5.0->xml2rfc) (2.8)
Requirement already satisfied, skipping upgrade: certifi>=2017.4.17 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from requests>=2.5.0->xml2rfc) (2020.6.20)
Requirement already satisfied, skipping upgrade: 
urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from requests>=2.5.0->xml2rfc) (1.25.8)
Requirement already satisfied, skipping upgrade: chardet<3.1.0,>=3.0.2 
in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from requests>=2.5.0->xml2rfc) (3.0.4)
Requirement already satisfied, skipping upgrade: 
sortedcontainers<3.0,>=2.0 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from intervaltree!=3.0.0,>=2.1.0->xml2rfc) (2.1.0)
Requirement already satisfied, skipping upgrade: MarkupSafe>=0.23 in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(from jinja2<3.0,>=2.11->xml2rfc) (1.1.1)

oran@ORAN-M-51B7 ~ % pip3 install --upgrade libmagic
Requirement already up-to-date: libmagic in 
/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages 
(1.0)

DaveO

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 28 Sep 2020 00:33:28 +0200

> ImportError: failed to find libmagic. Check your installation

This may not be very comforting, but you are not the only one with that problem:

https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/554 

https://github.com/martinthomson/i-d-template/issues/241

Grüße, Carsten

---

From: "John Levine" <[email-masked]>
Date: 27 Sep 2020 21:02:11 -0400

>ImportError: failed to find libmagic.  Check your installation

In the tradition of software black magic, I found that uninstalling
libmagic and reinstalling it helped.

-- 
Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 28 Sep 2020 12:53:56 +0200

Hi Dave,

Please run 'pip install python-libmagic' to install the missing libmagic
component.  

	Henrik

On 2020-09-27 23:21, David R. Oran wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: "David R. Oran" <[email-masked]>
Date: Mon, 28 Sep 2020 09:03:16 -0400

> Please run 'pip install python-libmagic' to install the missing libmagic
No joy - haven’t had time to try to debug this so if I’m missing something obvious, apologies!

% pip install python-libmagic
Processing ./Library/Caches/pip/wheels/ae/73/bf/1e25e331ecf164ad0a5659cffb76ccb5c2225d069a6f5529ee/python_libmagic-0.4.0-py3-none-any.whl
Collecting cffi==1.7.0
  Using cached cffi-1.7.0.tar.gz (400 kB)
Requirement already satisfied: pycparser in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (from cffi==1.7.0->python-libmagic) (2.19)
Building wheels for collected packages: cffi
  Building wheel for cffi (setup.py) ... error
  ERROR: Command errored out with exit status 1:
   command: /Library/Frameworks/Python.framework/Versions/3.8/bin/python3.8 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/private/var/folders/y3/pcz716n08xj2970059bjsr880000gp/T/pip-install-8sut8fhv/cffi/setup.py'"'"'; __file__='"'"'/private/var/folders/y3/pcz716n08xj2970059bjsr880000gp/T/pip-install-8sut8fhv/cffi/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' bdist_wheel -d /private/var/folders/y3/pcz716n08xj2970059bjsr880000gp/T/pip-wheel-hj6s10rb
       cwd: /private/var/folders/y3/pcz716n08xj2970059bjsr880000gp/T/pip-install-8sut8fhv/cffi/
  Complete output (65 lines):
  /usr/local/Homebrew/Library/Homebrew/version.rb:368:in `initialize': Version value must be a string; got a NilClass () (TypeError)
  	from /usr/local/Homebrew/Library/Homebrew/os/mac/version.rb:26:in `initialize'
  	from /usr/local/Homebrew/Library/Homebrew/os/mac.rb:24:in `new'
  	from /usr/local/Homebrew/Library/Homebrew/os/mac.rb:24:in `version'
  	from /usr/local/Homebrew/Library/Homebrew/os/mac.rb:58:in `prerelease?'
  	from /usr/local/Homebrew/Library/Homebrew/os.rb:21:in `<module:OS>'
  	from /usr/local/Homebrew/Library/Homebrew/os.rb:3:in `<top (required)>'
  	from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
  	from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
  	from /usr/local/Homebrew/Library/Homebrew/global.rb:29:in `<top (required)>'
  	from /usr/local/Homebrew/Library/Homebrew/brew.rb:23:in `require_relative'
  	from /usr/local/Homebrew/Library/Homebrew/brew.rb:23:in `<main>'
  Package libffi was not found in the pkg-config search path.
  Perhaps you should add the directory containing `libffi.pc'
  to the PKG_CONFIG_PATH environment variable
  No package 'libffi' found
  Package libffi was not found in the pkg-config search path.
  Perhaps you should add the directory containing `libffi.pc'
  to the PKG_CONFIG_PATH environment variable
  No package 'libffi' found
  Package libffi was not found in the pkg-config search path.
  Perhaps you should add the directory containing `libffi.pc'
  to the PKG_CONFIG_PATH environment variable
  No package 'libffi' found
  Package libffi was not found in the pkg-config search path.
  Perhaps you should add the directory containing `libffi.pc'
  to the PKG_CONFIG_PATH environment variable
  No package 'libffi' found
  Package libffi was not found in the pkg-config search path.
  Perhaps you should add the directory containing `libffi.pc'
  to the PKG_CONFIG_PATH environment variable
  No package 'libffi' found
  running bdist_wheel
  running build
  running build_py
  creating build
  creating build/lib.macosx-10.9-x86_64-3.8
  creating build/lib.macosx-10.9-x86_64-3.8/cffi
  copying cffi/backend_ctypes.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
  copying cffi/setuptools_ext.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
  copying cffi/__init__.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
  copying cffi/cffi_opcode.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
  copying cffi/vengine_gen.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
  copying cffi/model.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
  copying cffi/ffiplatform.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
  copying cffi/api.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
  copying cffi/vengine_cpy.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
  copying cffi/commontypes.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
  copying cffi/lock.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
  copying cffi/recompiler.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
  copying cffi/cparser.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
  copying cffi/verifier.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
  copying cffi/_cffi_include.h -> build/lib.macosx-10.9-x86_64-3.8/cffi
  copying cffi/parse_c_type.h -> build/lib.macosx-10.9-x86_64-3.8/cffi
  copying cffi/_embedding.h -> build/lib.macosx-10.9-x86_64-3.8/cffi
  running build_ext
  building '_cffi_backend' extension
  creating build/temp.macosx-10.9-x86_64-3.8
  creating build/temp.macosx-10.9-x86_64-3.8/c
  gcc -Wno-unused-result -Wsign-compare -Wunreachable-code -fno-common -dynamic -DNDEBUG -g -fwrapv -O3 -Wall -arch x86_64 -g -DUSE__THREAD -I/usr/include/ffi -I/usr/include/libffi -I/Library/Frameworks/Python.framework/Versions/3.8/include/python3.8 -c c/_cffi_backend.c -o build/temp.macosx-10.9-x86_64-3.8/c/_cffi_backend.o
  c/_cffi_backend.c:15:10: fatal error: 'ffi.h' file not found
  #include <ffi.h>
           ^~~~~~~
  1 error generated.
  error: command 'gcc' failed with exit status 1
  ----------------------------------------
  ERROR: Failed building wheel for cffi
  Running setup.py clean for cffi
Failed to build cffi
Installing collected packages: cffi, python-libmagic
  Attempting uninstall: cffi
    Found existing installation: cffi 1.14.0
    Uninstalling cffi-1.14.0:
      Successfully uninstalled cffi-1.14.0
    Running setup.py install for cffi ... error
    ERROR: Command errored out with exit status 1:
     command: /Library/Frameworks/Python.framework/Versions/3.8/bin/python3.8 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/private/var/folders/y3/pcz716n08xj2970059bjsr880000gp/T/pip-install-8sut8fhv/cffi/setup.py'"'"'; __file__='"'"'/private/var/folders/y3/pcz716n08xj2970059bjsr880000gp/T/pip-install-8sut8fhv/cffi/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /private/var/folders/y3/pcz716n08xj2970059bjsr880000gp/T/pip-record-ud6luecm/install-record.txt --single-version-externally-managed --compile --install-headers /Library/Frameworks/Python.framework/Versions/3.8/include/python3.8/cffi
         cwd: /private/var/folders/y3/pcz716n08xj2970059bjsr880000gp/T/pip-install-8sut8fhv/cffi/
    Complete output (65 lines):
    /usr/local/Homebrew/Library/Homebrew/version.rb:368:in `initialize': Version value must be a string; got a NilClass () (TypeError)
    	from /usr/local/Homebrew/Library/Homebrew/os/mac/version.rb:26:in `initialize'
    	from /usr/local/Homebrew/Library/Homebrew/os/mac.rb:24:in `new'
    	from /usr/local/Homebrew/Library/Homebrew/os/mac.rb:24:in `version'
    	from /usr/local/Homebrew/Library/Homebrew/os/mac.rb:58:in `prerelease?'
    	from /usr/local/Homebrew/Library/Homebrew/os.rb:21:in `<module:OS>'
    	from /usr/local/Homebrew/Library/Homebrew/os.rb:3:in `<top (required)>'
    	from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
    	from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
    	from /usr/local/Homebrew/Library/Homebrew/global.rb:29:in `<top (required)>'
    	from /usr/local/Homebrew/Library/Homebrew/brew.rb:23:in `require_relative'
    	from /usr/local/Homebrew/Library/Homebrew/brew.rb:23:in `<main>'
    Package libffi was not found in the pkg-config search path.
    Perhaps you should add the directory containing `libffi.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libffi' found
    Package libffi was not found in the pkg-config search path.
    Perhaps you should add the directory containing `libffi.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libffi' found
    Package libffi was not found in the pkg-config search path.
    Perhaps you should add the directory containing `libffi.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libffi' found
    Package libffi was not found in the pkg-config search path.
    Perhaps you should add the directory containing `libffi.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libffi' found
    Package libffi was not found in the pkg-config search path.
    Perhaps you should add the directory containing `libffi.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libffi' found
    running install
    running build
    running build_py
    creating build
    creating build/lib.macosx-10.9-x86_64-3.8
    creating build/lib.macosx-10.9-x86_64-3.8/cffi
    copying cffi/backend_ctypes.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
    copying cffi/setuptools_ext.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
    copying cffi/__init__.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
    copying cffi/cffi_opcode.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
    copying cffi/vengine_gen.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
    copying cffi/model.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
    copying cffi/ffiplatform.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
    copying cffi/api.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
    copying cffi/vengine_cpy.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
    copying cffi/commontypes.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
    copying cffi/lock.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
    copying cffi/recompiler.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
    copying cffi/cparser.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
    copying cffi/verifier.py -> build/lib.macosx-10.9-x86_64-3.8/cffi
    copying cffi/_cffi_include.h -> build/lib.macosx-10.9-x86_64-3.8/cffi
    copying cffi/parse_c_type.h -> build/lib.macosx-10.9-x86_64-3.8/cffi
    copying cffi/_embedding.h -> build/lib.macosx-10.9-x86_64-3.8/cffi
    running build_ext
    building '_cffi_backend' extension
    creating build/temp.macosx-10.9-x86_64-3.8
    creating build/temp.macosx-10.9-x86_64-3.8/c
    gcc -Wno-unused-result -Wsign-compare -Wunreachable-code -fno-common -dynamic -DNDEBUG -g -fwrapv -O3 -Wall -arch x86_64 -g -DUSE__THREAD -I/usr/include/ffi -I/usr/include/libffi -I/Library/Frameworks/Python.framework/Versions/3.8/include/python3.8 -c c/_cffi_backend.c -o build/temp.macosx-10.9-x86_64-3.8/c/_cffi_backend.o
    c/_cffi_backend.c:15:10: fatal error: 'ffi.h' file not found
    #include <ffi.h>
             ^~~~~~~
    1 error generated.
    error: command 'gcc' failed with exit status 1
    ----------------------------------------
  Rolling back uninstall of cffi
  Moving to /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/_cffi_backend.cpython-38-darwin.so
   from /private/var/folders/y3/pcz716n08xj2970059bjsr880000gp/T/pip-uninstall-zgvoqdln/_cffi_backend.cpython-38-darwin.so
  Moving to /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/cffi-1.14.0.dist-info/
   from /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/~ffi-1.14.0.dist-info
  Moving to /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/cffi/
   from /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/~ffi
ERROR: Command errored out with exit status 1: /Library/Frameworks/Python.framework/Versions/3.8/bin/python3.8 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/private/var/folders/y3/pcz716n08xj2970059bjsr880000gp/T/pip-install-8sut8fhv/cffi/setup.py'"'"'; __file__='"'"'/private/var/folders/y3/pcz716n08xj2970059bjsr880000gp/T/pip-install-8sut8fhv/cffi/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /private/var/folders/y3/pcz716n08xj2970059bjsr880000gp/T/pip-record-ud6luecm/install-record.txt --single-version-externally-managed --compile --install-headers /Library/Frameworks/Python.framework/Versions/3.8/include/python3.8/cffi Check the logs for full command output.
oran@ORAN-M-51B7 ~ %

DaveO

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 28 Sep 2020 15:17:25 +0200

Hi Dave,

> No joy - haven’t had time to try to debug this so if I’m missing something obvious, apologies!

Mph.  My takeaway is that installation of python-magic depends too much
on other system components and cannot be relied on.  I'm going to revert
the change that introduced a dependency on libmagic.

Best regards,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 28 Sep 2020 16:45:30 +0200

On 2020-09-28, at 15:17, Henrik Levkowetz <[email-masked]> wrote:
> 
> My takeaway is that installation of python-magic

It seems to me you sent Dave on a goose chase by asking him to reinstall python-libmagic, not python-magic...
See also https://github.com/dveselov/python-libmagic/issues/2

> depends too much
> on other system components and cannot be relied on.

You could say that about python-libmagic.  Python-libmagic hasn’t been updated for four years and forces a dependency to an (also four-year old) version of cffi that simply doesn’t install.

xml2rfc-3.2.0 depends on python-magic, though (which seems to work for me).

> I'm going to revert

Thank you.
That is probably the best solution.

Grüße, Carsten