Subject: [xml2rfc] Multiple email addresses in <address/>

From: Greg Mirsky <[email-masked]>
Date: Mon, 22 Feb 2021 10:02:33 -0800

Hi,
not sure if I am asking this question on the proper list. Please advise.
Here's my situation. xml2rfc allows me to list two or more email addresses
in <email/>.
IDnits does not flag that. But in the upload it fails with the following:
Greg Mirsky <[email-masked]; [email-masked]> - ZTE
Corporation - *unknown country*

Invalid email address. A valid email address is required.
My question is, Is it possible to associate two email addresses with an
author? If yes, then how?

Regards,
Greg

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 22 Feb 2021 11:29:53 -0700

On 2/22/21 11:02 AM, Greg Mirsky wrote:
> Here's my situation. xml2rfc allows me to list two or more email
> addresses in <email/>.
> Greg Mirsky <[email-masked] <mailto:[email-masked]>;
> [email-masked] <mailto:[email-masked]>> - ZTE Corporation
> - /unknown country/
> 

Hi Greg,

My understanding is that you can include a comma-separated list.

At some point (soonish?) we will allow multiple <email/> elements within
<address/>...

https://github.com/rfc-format/draft-iab-xml2rfc-v3-bis/issues/4

HTH.

Peter

---

From: Julian Reschke <[email-masked]>
Date: Mon, 22 Feb 2021 19:33:24 +0100

> author? If yes, then how?

What exactly did you try? Two <email> elements, or multiple addresses in
a single element?

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Mon, 22 Feb 2021 19:35:54 +0100

> https://github.com/rfc-format/draft-iab-xml2rfc-v3-bis/issues/4

This is IMHO already implemented (since xml2rfc 2.46.0).

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 22 Feb 2021 19:54:59 +0100

> This is IMHO already implemented (since xml2rfc 2.46.0).

From the horse’s mouth (or really, from its guts, ~/lib/python3.9/site-packages/xml2rfc/data/v3.rnc):

   address =
     element address {
       attribute xml:base { text }?,
       attribute xml:lang { text }?,
       postal?,
       phone?,
       facsimile?,
       email*,
       uri?
     }

Change the ? into a *.
The rest of the rendering should already “just work” (tweaks are still possible, of course).

Maybe I should put this into http://www.tzi.de/~cabo/contact-hack.sh so people can play with it and we hit the road running once this is adopted.

Grüße, Carsten

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 22 Feb 2021 11:05:04 -0800

Hi Julian,
I should have been clearer. I've listed two addresses separated by a
semicolon in a single <email/>. I'll try it with a coma now.

Regards,
Greg

On Mon, Feb 22, 2021, 10:33 Julian Reschke <[email-masked]> wrote:

> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Julian Reschke <[email-masked]>
Date: Mon, 22 Feb 2021 20:03:43 +0100

> semicolon in a single <email/>. I'll try it with a coma now.

No, you really should use multiple <email> elements!

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 22 Feb 2021 20:18:19 +0100

> Change the ? into a *.

Mixing up threads again.

The first part was about the email*, which is indeed in there today.

> commit 83cd6f99bc21a4a69c644871282e9298bee12efc
> Author: [email-masked] <[email-masked]@420659e1-3e8f-4aa3-bc54-b4abac0350f5>
> Date:   Tue Jun 23 17:06:26 2020 +0000
> 
>     Added support for multiple email addresses within an author's address block.  Fixes issue #522.

The second part was about getting the same change for what is now uri?, which should be a uri*.

Grüße, Carsten

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 22 Feb 2021 12:41:16 -0800

Hi Julian,
I gave it, two <email/> in a single <address/>, a try but xml2rfc throws
this error at me:
 INPUT: Line 24: Element address content does not follow the DTD, expecting
(postal? , phone? , facsimile? , email? , uri?), got (postal email email )
And two email addresses in a single <email/> passes xml2rfc and IDnits but
results in the same "Meta-Data error found!" banner as with the semicolon.

Regards,
Greg

---

From: "John Levine" <[email-masked]>
Date: 22 Feb 2021 17:11:32 -0500

In article <[email-masked]> you write:
>-=-=-=-=-=-

Can you check what version of xml2rfc you're using?

R's,
John

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 22 Feb 2021 14:29:11 -0800

Hi John,
it is reported as: Current xml2rfc version is xml2rfc 3.5.0

I'm using whatever is on the https://xml2rfc.tools.ietf.org/

Regards,
Greg

On Mon, Feb 22, 2021 at 2:11 PM John Levine <[email-masked]> wrote:

> In article <
> [email-masked]> you
> write:
> >-=-=-=-=-=-
> >
> >Hi Julian,

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 22 Feb 2021 23:30:38 +0100

On 2021-02-22, at 21:41, Greg Mirsky <[email-masked]> wrote:
> 
> And two email addresses in a single <email/> passes xml2rfc and IDnits but results in the same "Meta-Data error found!" banner as with the semicolon.

I’m not following — where do you get this?

Grüße, Carsten

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 22 Feb 2021 14:34:00 -0800

Hi Carsten,
after I try to use https://datatracker.ietf.org/submit/

Regards,
Greg

On Mon, Feb 22, 2021 at 2:30 PM Carsten Bormann <[email-masked]> wrote:

> > And two email addresses in a single <email/> passes xml2rfc and IDnits
> but results in the same "Meta-Data error found!" banner as with the
> semicolon.
>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 23 Feb 2021 01:56:13 +0100

On 22. Feb 2021, at 23:34, Greg Mirsky <[email-masked]> wrote:
> 
> Hi Carsten,
> after I try to use https://datatracker.ietf.org/submit/ <https://datatracker.ietf.org/submit/>
What do you submit?  XML or TXT (or both)?

Since you mentioned the word “metadata”, I’m guessing that you were submitting TXT and the metadata extractor choked.
Try submitting XML (only!).

Grüße, Carsten

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 22 Feb 2021 17:04:35 -0800

The gate got closed. Will wait to try it ;)

Regards,
Greg

On Mon, Feb 22, 2021 at 4:56 PM Carsten Bormann <[email-masked]> wrote:

> Since you mentioned the word “metadata”, I’m guessing that you were
> submitting TXT and the metadata extractor choked.