Subject: Re: [xml2rfc] [xml2rfc-dev] Unicode box-drawing for a new --table-borders value?

From: Daniel Kahn Gillmor <[email-masked]>
Date: Sat, 30 Jan 2021 11:06:38 -0500

On Sat 2021-01-30 07:22:43 +0200, Lars Eggert wrote:
> I think that would be excellent, but AFAIK Unicode can (still) only be
> used in contact names (see the recent "Unicode in xml2rfc v3" thread
> over on rfc-interest@). I really hope we can just get to an agreement
> to allow Unicode anywhere in the document.

whoops, i've been using unicode (in particular, the box-drawing
characters and a few fancy arrows) to pretty good effect (imho) in
several I-Ds already, for example:

    https://www.ietf.org/archive/id/draft-dkg-lamps-e2e-mail-guidance-00.html#name-multilayer-cryptographic-en

That document would be much harder to read and understand (and probably
much longer) without the compact representations of MIME message
structure.

Reading the thread you reference suggests that those characters are
probably acceptable within an "artwork" or verbatim block, but maybe not
in the regular text.

That would mean unicode *can* show up in other places in the .txt
versions of the RFC, which is the only context where --table-borders
really matters, afaict.  So it seems like the constraints on unicode in
the normal text shouldn't be any formal problem with the .txt
translation.  Does that seem like a plausible analysis?

Hopefully this change would just be a "simple matter of programming" in
xml2rfc itself, and not some sort of policy quagmire.

  --dkg

---

From: Lars Eggert <[email-masked]>
Date: Mon, 1 Feb 2021 16:53:33 +0200

>    https://www.ietf.org/archive/id/draft-dkg-lamps-e2e-mail-guidance-00.html#name-multilayer-cryptographic-en

Ah! You're right, in artwork, there is no issue.

I was trying to use Unicode in the text, which has the restriction I mentioned.

Lars

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 1 Feb 2021 16:01:16 +0100

On 2021-01-30, at 17:06, Daniel Kahn Gillmor <[email-masked]> wrote:
> Signed PGP part

That is how xml2rfc is currently programmed.
This is fine for box-drawing, but not so great for α and β, which need to be referenceable in the text.

(A quick fix to get a preview of what will be possible with an updated policy is in http://www.tzi.de/~cabo/contact-hack.sh — you can simply reinstall xml2rfc if that screws up things for you.  This fix is necessary to build Lars’s 8132bis draft.)

> xml2rfc itself, and not some sort of policy quagmire.

I don’t think there is a change needed to support the artwork in the above-mentioned draft.

Grüße, Carsten