Subject: [xml2rfc] &nbsp; unknown in IETF Secretariat ?

From: Roger Price <[email-masked]>
Date: Mon, 1 Feb 2021 14:12:52 +0100 (CET)

My XML begins with the declaration

  <?xml version='1.0' encoding='UTF-8' ?>
  <!DOCTYPE rfc SYSTEM "rfc2629-xhtml.ent">
  <rfc ...

where rfc2629-xhtml.ent provides a definition for &nbsp;.  These declarations 
are present in the expanded XML I submitted.  After the submission, I checked 
the XML file held by the IETF Secretariat, and instead of seeing the XML file, I 
got the error message:

  XML Parsing Error: undefined entity
  Location: https://www.ietf.org/archive/id/draft-rprice-ups-management-protocol-00.xml
  Line Number 390, Column 53:   <t>Command: <tt>FSD &lt;upsname&gt;</tt>  &nbsp;
                      ----------------------------------------------------^

Is this because the IETF Secretariat does not have a copy of file 
rfc2629-xhtml.ent, or is there something else that I have done wrong?

Roger

---

From: Julian Reschke <[email-masked]>
Date: Mon, 1 Feb 2021 15:03:03 +0100

Am 01.02.2021 um 14:12 schrieb Roger Price:
> where rfc2629-xhtml.ent provides a definition for &nbsp;.  These
> declarations are present in the expanded XML I submitted.  After the
> submission, I checked the XML file held by the IETF Secretariat, and
> instead of seeing the XML file, I got the error message:
>
>   Location:
> https://www.ietf.org/archive/id/draft-rprice-ups-management-protocol-00.xml

Does "check" mean "open in web browser"?

In that case it's likely because browsers, when reading XML, do not
process external entities (for security reasons).

Best regards, Julian

---

From: Roger Price <[email-masked]>
Date: Mon, 1 Feb 2021 17:27:47 +0100 (CET)

On Mon, 1 Feb 2021, Julian Reschke wrote:

>> ..., I checked the XML file held by the IETF Secretariat, and

Yes, I naïvely expected to see the source code I had submitted.  I will not 
click on that button again.

Roger