Subject: Re: [xml2rfc] Multiple email addresses in <address/>

From: Greg Mirsky <[email-masked]>
Date: Mon, 8 Mar 2021 06:01:53 -0800

Hi Carsten,
I finally got to try two emails and use XML only. I'm afraid it considered
not valid:

draft-mirsky-ippm-epm-03.xml: Line 24: Element address content does not
follow the DTD, expecting (postal? , phone? , facsimile? , email? , uri?),
got (postal email email )

I believe I've seen two email addresses listed in a draft, just don't know
how to make it work.

Regards,
Greg

On Mon, Feb 22, 2021 at 4:56 PM Carsten Bormann <[email-masked]> wrote:

> On 22. Feb 2021, at 23:34, Greg Mirsky <[email-masked]> wrote:
>
>
> Hi Carsten,
> after I try to use https://datatracker.ietf.org/submit/
>
>
> What do you submit?  XML or TXT (or both)?
>
> Since you mentioned the word “metadata”, I’m guessing that you were
> submitting TXT and the metadata extractor choked.
> Try submitting XML (only!).
>
> Grüße, Carsten
>
>

---

From: Julian Reschke <[email-masked]>
Date: Mon, 8 Mar 2021 15:08:33 +0100

Am 08.03.2021 um 15:01 schrieb Greg Mirsky:
> Hi Carsten,
> I finally got to try two emails and use XML only. I'm afraid it
> considered not valid:
>
>     draft-mirsky-ippm-epm-03.xml: Line 24: Element address content does
>     not follow the DTD, expecting (postal? , phone? , facsimile? ,
>     email? , uri?), got (postal email email )
>
> I believe I've seen two email addresses listed in a draft, just don't
> know how to make it work.
>
> Regards,
> Greg

Is this a v2 or a v3 document? What version of xml2rfc? What's the
command line?

Best regards, Julian

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 8 Mar 2021 06:21:00 -0800

Hi Julian,
I've tried submitting TXT format along with XML before. The tool complained
about the metadata. This time I've submitted only the XML. All is done
through the web-portal.

Regards,
Greg

On Mon, Mar 8, 2021 at 6:08 AM Julian Reschke <[email-masked]> wrote:

> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Julian Reschke <[email-masked]>
Date: Mon, 8 Mar 2021 15:28:35 +0100

Am 08.03.2021 um 15:21 schrieb Greg Mirsky:
> Hi Julian,
> I've tried submitting TXT format along with XML before. The tool
> complained about the metadata. This time I've submitted only the XML.
> All is done through the web-portal.
>
> Regards,
> Greg

What exactly is in the XML file?

Best regards, Julian

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 8 Mar 2021 15:06:16 +0000

I have only wanted two emails so I could do email migration. I did this by listing myself twice as an author.

- Stewart

> On 8 Mar 2021, at 14:21, Greg Mirsky <[email-masked]> wrote:
> 
> Hi Julian,
> I've tried submitting TXT format along with XML before. The tool complained about the metadata. This time I've submitted only the XML. All is done through the web-portal.
> 
> Regards,
> Greg
> 
> On Mon, Mar 8, 2021 at 6:08 AM Julian Reschke <[email-masked] <mailto:[email-masked]>> wrote:
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/xml2rfc <https://www.ietf.org/mailman/listinfo/xml2rfc>

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 8 Mar 2021 07:11:03 -0800

Hi Stewart,
Julian helped me to arrive to the following:
<rfc xmlns:xi="http://www.w3.org/2001/XInclude" category="std"
docName="draft-mirsky-ippm-epm-03" ipr="trust200902" obsoletes=""
updates="" submissionType="IETF" xml:lang="en" tocInclude="true"
tocDepth="3" symRefs="true" sortRefs="true" version="3">
Now it works with two <email/> lines.

Regards,
Greg

On Mon, Mar 8, 2021 at 7:06 AM Stewart Bryant <[email-masked]>
wrote:

> complained about the metadata. This time I've submitted only the XML. All
> is done through the web-portal.
>
> Regards,
> Greg
>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 8 Mar 2021 16:37:17 +0100

> Now it works with two <email/> lines.

It is somewhat suboptimal that these relaxations of the v3.rnc were not grandfathered into the v2 support.

I know, v2 is our IPv4, but the problem is that people don’t know they need to change their documents to be somewhat v3 compliant to get the v3 features.

Grüße, Carsten

---

From: Julian Reschke <[email-masked]>
Date: Mon, 8 Mar 2021 17:02:30 +0100

Am 08.03.2021 um 16:11 schrieb Greg Mirsky:
> <rfc xmlns:xi="http://www.w3.org/2001/XInclude
> <http://www.w3.org/2001/XInclude>" category="std"
> ...

...where the important bit is

   version="3"

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Mon, 8 Mar 2021 17:20:49 +0100

> It is somewhat suboptimal that these relaxations of the v3.rnc were not grandfathered into the v2 support.

That's essentially true for *everything* in v3, for xml2rfc.

The original idea was that a v3 processor would accept *all* of v2
(that's why we did *deprecate* things in the spec, not *remove* them).
Unfortunately, the v2 and v3 modes in xml2rfc are entirely different
code paths, and you can't easily mix new stuff with elements that were
deprecated.

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 8 Mar 2021 21:25:53 +0100

> code paths, and you can't easily mix new stuff with elements that were

I understand that (and agree) there was a desire to preserve the v2 codepaths in xml2rfc as a safety measure.

However, the xml2rfc migration path works very well when --v3 is given to xml2rfc.
All v2 constructions (with very few bugs) are supported well by the v2v3 converter.

The problem is in the way the submission interface treats its input.

I haven’t checked the code, but it seems it does a v3 conformance check and only uses the --v3 mode if that succeeds.  But that is not the way the “v2 with some v3” documents look like.  These also should be treated with --v3, but they aren’t.

Again, running the v2 code paths from the submission interface may initially have been a prudent safety hedge, but by now it is creating more way more damage than it helps.

Grüße, Carsten