Subject: [xml2rfc] odd errors with online daft xml parsing

From: "[email-masked]" <[email-masked]>
Date: Sun, 21 Mar 2021 12:08:04 +0000 (UTC)

On a pretty much complete xmlv2 draft that I've been successfully parsing to a text document
previously with the web form at:
http://xml2rfc.ietf.org

Now gives the below error. Seems quite terminal.

Generating output
Running id2xml-rfc2629
Converting 'INPUT'

INPUT(77): Exception: Runaway loop in
   get_first_page_top()
Failure converting INPUT: Runaway loop in get_first_page_top()
Traceback (most recent call last):
  File "/usr/local/bin/id2xml", line 11, in <module>
    load_entry_point('id2xml==1.5.0', 'console_scripts', 'id2xml')()
  File "/usr/local/lib/python3.6/site-packages/id2xml/run.py", line 233, in run
    xml = parser.parse_to_xml()
  File "/usr/local/lib/python3.6/site-packages/id2xml/parser.py", line 1012, in parse_to_xml
    doc = self.document()
  File "/usr/local/lib/python3.6/site-packages/id2xml/parser.py", line 1041, in document
    self.root.append(self.front())
  File "<decorator-gen-10>", line 2, in front
  File "/usr/local/lib/python3.6/site-packages/id2xml/parser.py", line 599, in dtrace
    ret = fn(self, *params,**kwargs)
  File "/usr/local/lib/python3.6/site-packages/id2xml/parser.py", line 1076, in front
    lines_left, lines_right, lines_title, lines_name = self.get_first_page_top()
  File "<decorator-gen-11>", line 2, in get_first_page_top
  File "/usr/local/lib/python3.6/site-packages/id2xml/parser.py", line 599, in dtrace
    ret = fn(self, *params,**kwargs)
  File "/usr/local/lib/python3.6/site-packages/id2xml/parser.py", line 1210, in get_first_page_top
    loops += 1 if loops < 68 else loop_break('get_first_page_top')
  File "/usr/local/lib/python3.6/site-packages/id2xml/parser.py", line 115, in loop_break
    raise RunawayLoop("Runaway loop in %s()" % fn)
id2xml.parser.RunawayLoop: Runaway loop in get_first_page_top()

fyi

Lloyd Wood
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 21 Mar 2021 14:54:29 +0100

> Running id2xml-rfc2629

What are you feeding to id2xml?  This is meant to get a text I-D and return RFCXML.

Grüße, Carsten

---

From: Paul Kyzivat <[email-masked]>
Date: Sun, 21 Mar 2021 12:13:27 -0400

Its because your xml is daft. :-)

On 3/21/21 8:08 AM, [email-masked] wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>