Subject: [xml2rfc] the case of the disappearing refs

From: Randy Bush <[email-masked]>
Date: Sat, 29 May 2021 17:55:08 -0700

two days ago, i could successfully

    xml2rfc draft-ietf-opsawg-finding-geofeeds.xml --html --text

a v2 document.  today, it pukes

    xml2rfc draft-ietf-opsawg-finding-geofeeds.xml --html --text
    Error: Unable to parse the XML document: draft-ietf-opsawg-finding-geofeeds.xml
     draft-ietf-opsawg-finding-geofeeds.xml: Line 695: Unable to resolve external request: "reference.RFC.2119"
    make: *** [all] Error 1

with the accused being the first ref

    <references title="Normative References">
      <?rfc include="reference.RFC.2119"?>

and

    $ env | grep XML_LIBRARY
    XML_LIBRARY=.:/Users/randy/refs/rfc:/Users/randy/refs/id
    $ ls -l /Users/randy/refs/rfc/bibxml/reference.RFC.2119.xml
    -rw-rw-r--  1 randy  staff  868 May 28 09:35 /Users/randy/refs/rfc/bibxml/reference.RFC.2119.xml

turns out /usr/local/bin/xml2rfc

    $ head -1 /usr/local/bin/xml2rfc
    #!/usr/bin/python2

works, but

    $ head -1 /usr/local/bin/xml2rfc
    #!/usr/bin/python3

does not

    $ xml2rfc --version
    xml2rfc 2.32.0

on big sur

xml at https://github.com/massimocandela/draft-ymbk-finding-geofeeds

randy

---
[email-masked]
`gpg --locate-external-keys --auto-key-locate wkd [email-masked]`
signatures are back, thanks to dmarc header butchery

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 30 May 2021 11:40:47 +0200

>      <?rfc include="reference.RFC.2119"?>

No idea about the python2 vs. python3 observation (I don’t have a python2 environment to test this on), but I need

<?rfc include="reference.RFC.2119.xml"?>

to make this work (xml2rfc 3.7.0; I then upgraded to 3.8.0 to see the same; with Python 3.9).

Grüße, Carsten

---

From: Randy Bush <[email-masked]>
Date: Sun, 30 May 2021 07:10:15 -0700

>  <?rfc include="reference.RFC.2119.xml"?>
                                    ^^^^ did it
that's new to me

it makes, yay!  thanks!

but i am now getting

    Warning: Setting consensus="true" for IETF STD document (this is not the schema default, but is the only value permitted for this type of document)

    <?rfc consensus="true"?>

in the prologue does not help.  and issue
https://github.com/metanorma/metanorma.org/issues/315 is too light a
clue bat for me at this caffeine level

randy

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 30 May 2021 17:20:43 +0200

>    Warning: Setting consensus="true" for IETF STD document (this is not the schema default, but is the only value permitted for this type of document)

This is a warning and just tells you that xml2rfc is going to do what needs to be done.

To get rid of the warning as well, make sure your <rfc…> tag has a consensus attribute:

<rfc consensus="yes” category=“std” ipr="trust200902" docName=“draft-…

(Please excuse the random smartquotes.
Note that for a v3 document, this will need to be consensus=“true”.)

Grüße, Carsten

---

From: Randy Bush <[email-masked]>
Date: Sun, 30 May 2021 08:24:20 -0700

> <rfc consensus="yes” category=“std” ipr="trust200902" docName=“draft-…
                     ^ whoops! :)
yay!  thanks.

randy