Subject: [xml2rfc] How to indent a list

From: Robert Moskowitz <[email-masked]>
Date: Wed, 3 Nov 2021 21:42:53 -0400

I wonder if there is an "easy" way to indent a list like:

     <ol spacing="normal" type="TYPE-%d" group="type">
     <li>
         A static, manufacturer assigned, hardware serial number per
         ANSI/CTA-2063-A "Small Unmanned Aerial System Serial Numbers"
         <xref target="CTA2063A" format="default"/>.
     </li>
     <li>
         A CAA assigned (presumably static) ID.
     </li>
     <li>
         A UTM system assigned UUID <xref target="RFC4122"
         format="default"/>. These can be dynamic, but do not need to
         be.
     </li>
     <li>
         Specific Session ID (SSI)
     </li>
     </ol>

Other than using <dl> as noted in the FAQ sec 4.4

Something like a indent=4 in <ol>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 4 Nov 2021 03:00:23 +0100

I’m not sure why you want to do this, but you could slap a <ul empty=“true”><li> around the <ol.
(<ol has an indent attribute, but that does something different, I think.)

Grüße, Carsten

> On 4. Nov 2021, at 02:42, Robert Moskowitz <[email-masked]> wrote:
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 3 Nov 2021 22:33:59 -0400

> (<ol has an indent attribute, but that does something different, I think.)

To my eyes, the following would be easier to follow if the lists were 
indented:

    ASTM Standard Specification for Remote ID and Tracking [F3411]
    specifies four UAS ID types:

    TYPE-1  A static, manufacturer assigned, hardware serial number per
            ANSI/CTA-2063-A "Small Unmanned Aerial System Serial Numbers"
            [CTA2063A].

    TYPE-2  A CAA assigned (presumably static) ID.

    TYPE-3  A UTM system assigned UUID [RFC4122].  These can be dynamic,
            but do not need to be.

    TYPE-4  Specific Session ID (SSI)

    Note that Types 1 - 3 allow for a UAS ID with a maximum length of 20
    bytes, the SSI (Type 4) uses the first byte of the ID for the SSI
    value, thus restricting the UAS ID to a maximum of 19 types. The SSI
    values initially assigned are:

    ID 1  IETF DRIP Device Entity Type

    ID 2  3GPP

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 4 Nov 2021 08:25:13 +0100

>            ANSI/CTA-2063-A "Small Unmanned Aerial System Serial Numbers"

OK, apart from indenting the whole thing with a <ul empty=“true”>, the best thing I can come up with is:

type="-- TYPE-%d”

Obviously, I’d rather write

type="• TYPE-%d”

but the "ASCII plus a few privileged characters” policy we are still stuck with gets in the way here.

Grüße, Carsten