Subject: [xml2rfc] Referencing IEN's in xml2rfc?

From: "Templin (US), Fred L" <[email-masked]>
Date: Thu, 9 Dec 2021 19:24:14 +0000

Is it possible to include IEN's in Normative/Informative references? Here is
what I tried, but xml2rfc didn't like it:

    <references title="Informative References">
      <?rfc include="reference.IEN.0048"?>
    </references>

Thanks - Fred

---

From: Julian Reschke <[email-masked]>
Date: Fri, 10 Dec 2021 09:23:11 +0100

>        <?rfc include="reference.IEN.0048"?>

Is it possible? Definitively. References and the include mechanism
(superseded in V3 by x:include) are generic. What you need to find is an
online resource to include from.

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 10 Dec 2021 09:54:53 +0100

On 2021-12-09, at 20:24, Templin (US), Fred L <[email-masked]> wrote:
> 
> Is it possible to include IEN's in Normative/Informative references?

I don’t know about normative (I don’t think any IEN is on the downref list), but informative can of course be done:

informative:
  IEN48:
    author:
      - name: Vint  Cerf
        org: DARPA/IPTO
    date: July 1978
    title: >
      The Catenet Model for Internetworking
    seriesinfo:
      Internet Experiment Note: 48

kramdown-rfc generates this bibxml snippet in its informative references section:

<reference anchor="IEN48" >
  <front>
    <title>The Catenet Model for Internetworking</title>
    <author initials="V." surname="Cerf" fullname="Vint  Cerf">
      <organization>DARPA/IPTO</organization>
    </author>
    <date year="1978" month="July"/>
  </front>
  <seriesInfo name="Internet Experiment Note" value="48"/>
</reference>

…and xml2rfc (which ignores the organization info) formats that into:

   [IEN48]    Cerf, V., "The Catenet Model for Internetworking",
              Internet Experiment Note 48, July 1978.

> Here is

You don’t need to reference a reference to include that reference in an RFCXML document.  (I’m not aware of a repository of such bibxml snippets for IENs, so you’ll need to roll your own as shown above.)

Grüße, Carsten