Subject: [xml2rfc] <figure> support name field?

From: Robert Moskowitz <[email-masked]>
Date: Wed, 1 Dec 2021 16:54:38 -0500

Can this:

<figure anchor="HHIT_Format">
<name>HHIT Format</name>

be handled something like:

<figure anchor="HHIT_Format" name="HHIT Format">

Obvious not like that cause I get errors when I try it...

I did read the FAQ and the RFC and am not seeing how to do this, "nicely".

thanks

Bob

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 1 Dec 2021 23:15:50 +0100

> <figure anchor="HHIT_Format" name="HHIT Format">

That attribute is called “title”.

(It really should be called caption, as should be the element above, but that’s water under the bridge.)

https://xml2rfc.tools.ietf.org/xml2rfc-doc-3.11.1.html#name-title-attribute-5
says:

> 2.29.7. "title" Attribute
> 
> Deprecated. Use the <name> element instead.

Which raises the question why you don’t like the v3 way of using <name.
You can’t have markup in an attribute, so how do you get your superscripts into your captions?

> I did read the FAQ and the RFC and am not seeing how to do this, "nicely".

https://xml2rfc.tools.ietf.org/xml2rfc-doc-3.11.1.html

is what you want to read here; RFCs are less useful at this point.

Grüße, Carsten