Subject: [xmpp] Documenting DANE for XMPP (WAS: [dane] [apps-discuss] AppsDir review of draft-ietf-dane-protocol-19)

From: Matt Miller <[email-masked]>
Date: Mon, 30 Apr 2012 12:52:59 -0600

On Apr 30, 2012, at 12:37, Paul Hoffman wrote:

> On Apr 30, 2012, at 10:46 AM, Matt Miller wrote:
> 
>> I think there might still need to be some explicitness on what name to expect to match on regardless of where the certificate is found, especially with multi-domain XMPP servers (e.g. a server "im.shakespeare.lit" that services domains "capulet.shakespeare.lit" and "denmark.shakespeare.lit").
> 
> Yes.
> 
>> Maybe that doesn't need to be its own document.  
> 
> Are you serious!?!?! After the amount of confusing and disagreement we have seen in the past few months on this topic, a stand-alone document that can be referred to easily is exactly what we need.
> 

The preference of having a single document came from the XMPP WG.  I personally am not sure it's the best idea, but I also don't have anything written up yet.  I'm more than willing to fight hard to separate, but I also need to see what it looks like with the rest of XMPP federation stuff.

>> I am working on a proposal for improving XMPP federation, and a section in that document might be sufficient...Probably (-:
> 
> I'm skeptical, to say the least.

I did say "might" and "probably" (-:

- m&m

Matt Miller - <[email-masked]>
Cisco Systems, Inc.

---

From: "Richard L. Barnes" <[email-masked]>
Date: Mon, 30 Apr 2012 17:48:28 -0400

+1 to documenting the use of DANE with XMPP

+1 also to incorporating this discussion in a broader DNA / "server federation" document

On Apr 30, 2012, at 2:52 PM, Matt Miller wrote:

> _______________________________________________
> dane mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dane

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 30 Apr 2012 15:24:34 -0700

[ - apps-discuss ]

> +1 also to incorporating this discussion in a broader DNA / "server federation" document

I agree with Paul that it would be nice to have a standalone DANE+XMPP
document available that other folks can point to when working on
DANE+FOO specs, but I also agree with Matt about the desirability of
having one document about XMPP federation that developers can reference.
For now I think Matt and I will work on a separate DANE+XMPP spec and
then fold that in later when all the other federation pieces are complete.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/