Subject: [xmpp] Fwd: I-D Action: draft-miller-xmpp-e2e-01.txt

From: Matt Miller <[email-masked]>
Date: Fri, 22 Jun 2012 07:19:44 -0600

I've updated my XMPP E2E proposal.  Major changes from previous are:

* updated to latest JOSE specs
* section on decryption
* some discussion on content key re-use (lifetime, scope)

Still outstanding are:

* signing (starting work on that now)
* PKI management?

- m&m

Matt Miller - <[email-masked]>
Cisco Systems, Inc.

Begin forwarded message:

> From: [email-masked]
> Date: June 22, 2012 07:00:24 MDT
> To: [email-masked]
> Subject: I-D Action: draft-miller-xmpp-e2e-01.txt
> Reply-To: [email-masked]
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
> 	Title           : End-to-End Object Encryption for the Extensible Messaging and Presence Protocol (XMPP)
> 	Author(s)       : Matthew Miller
> 	Filename        : draft-miller-xmpp-e2e-01.txt
> 	Pages           : 22
> 	Date            : 2012-06-21
> 
> Abstract:
>   This document defines a method of end-to-end object encryption for
>   the Extensible Messaging and Presence Protocol (XMPP).
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-miller-xmpp-e2e
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-miller-xmpp-e2e-01
> 
> A diff from previous version is available at:
> http://tools.ietf.org/rfcdiff?url2=draft-miller-xmpp-e2e-01
> 
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Matt Miller <[email-masked]>
Date: Fri, 22 Jun 2012 17:46:46 -0600

There is discussion of this on the JOSE WG at the moment; start at < http://www.ietf.org/mail-archive/web/jose/current/msg00712.html > and walk by date.

- m&m

On Jun 22, 2012, at 07:19, Matt Miller wrote:

> xmpp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xmpp