Subject: Re: [Yang-multicast] Updated draft-ietf-pim-yang-09

From: Benoit Claise <[email-masked]>
Date: Tue, 3 Oct 2017 14:08:11 +0200

Xufeng,

I updated yanglint to the latest version this morning and the message is 
now clearer.
 From the tool developer:

    the most recent version of libyang (0.13.73) should have improved
    XPath warnings including a specific message when an identityref
    value was found in a non-implemented module for easier fixing of
    such problems.

See http://www.claise.be/IETFYANGPageCompilation.html

I checked that all your YANG modules passes with yanglint -i
So there are no more errors related to your YANG modules. :-)

Regards, Benoit

> Hi Benoit,
>
> We have fixed the warnings from yumadump-pro, but the latest version 
> of yanglint is enforcing some rules that are not clear to us, so the 
> yanglint warnings have not been cleared. It would be good to get more 
> information from the tool’s owner.
>
> Thanks,
>
> - Xufeng
>
> *From:*Benoit Claise [mailto:[email-masked]]
> *Sent:* Wednesday, September 27, 2017 8:22 AM
> *To:* Xufeng Liu <[email-masked]>; Stig Venaas (svenaas) 
> <[email-masked]>; Liuyisong <[email-masked]>; 
> [email-masked]
> *Cc:* Stig Venaas <[email-masked]>; Guofeng <[email-masked]>
> *Subject:* Re: [Yang-multicast] Updated draft-ietf-pim-yang-09
>
> Hi Xufeng,
>
> It still see some warnings, coming from yumadump-pro and yanglint
> http://www.claise.be/IETFYANGPageCompilation.html
> Can you please have a look.
>
> Regards, Benoit
>
>     Hi All,
>
>     Attached please find the planned draft-ietf-pim-yang-09, which has been updated to be NMDA compliant. Please review and provide comments. If no objections, I'd submit it on Monday.
>
>     The draft, model files, and tree views have been checked in to the Github:
>
>     https://github.com/mcallisterjp/pim-yang
>
>     Thanks,
>
>     - Xufeng
>
>
>
>
>     _______________________________________________
>
>     Yang-multicast mailing list
>
>     [email-masked] <mailto:[email-masked]>
>
>     https://www.ietf.org/mailman/listinfo/yang-multicast
>

---

From: Xufeng Liu <[email-masked]>
Date: Tue, 3 Oct 2017 13:29:39 +0000

Hi Benoit,

Thanks.

So we can ignore these warnings about the "non-implemented module" because we assume that the depending parent modules will be implemented, right?

Regards,
- Xufeng

From: Benoit Claise [mailto:[email-masked]]
Sent: Tuesday, October 3, 2017 8:08 AM
To: Xufeng Liu <[email-masked]>; Stig Venaas (svenaas) <[email-masked]>; Liuyisong <[email-masked]>; [email-masked]
Cc: Stig Venaas <[email-masked]>; Guofeng <[email-masked]>; Benoit Claise <[email-masked]>
Subject: Re: [Yang-multicast] Updated draft-ietf-pim-yang-09

Xufeng,

I updated yanglint to the latest version this morning and the message is now clearer.
>From the tool developer:
the most recent version of libyang (0.13.73) should have improved XPath warnings including a specific message when an identityref value was found in a non-implemented module for easier fixing of such problems.
See http://www.claise.be/IETFYANGPageCompilation.html

Regards, Benoit

Hi Benoit,

We have fixed the warnings from yumadump-pro, but the latest version of yanglint is enforcing some rules that are not clear to us, so the yanglint warnings have not been cleared. It would be good to get more information from the tool's owner.

Thanks,
- Xufeng

From: Benoit Claise [mailto:[email-masked]]
Sent: Wednesday, September 27, 2017 8:22 AM
To: Xufeng Liu <[email-masked]><mailto:[email-masked]>; Stig Venaas (svenaas) <[email-masked]><mailto:[email-masked]>; Liuyisong <[email-masked]><mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Stig Venaas <[email-masked]><mailto:[email-masked]>; Guofeng <[email-masked]><mailto:[email-masked]>
Subject: Re: [Yang-multicast] Updated draft-ietf-pim-yang-09

Hi Xufeng,

Regards, Benoit

Hi All,

Thanks,

- Xufeng

[email-masked]<mailto:[email-masked]>

---

From: Stig Venaas <[email-masked]>
Date: Tue, 3 Oct 2017 08:15:11 -0700

Hi

Does the igmp/mld draft pass validations as well? I'll check with Mike
about WGLC, but would be good to get any issues fixed.

Stig

On Oct 3, 2017 06:29, "Xufeng Liu" <[email-masked]> wrote:

Hi Benoit,

Thanks.

So we can ignore these warnings about the “non-implemented module” because
we assume that the depending parent modules will be implemented, right?

Regards,

- Xufeng

*From:* Benoit Claise [mailto:[email-masked]]
*Sent:* Tuesday, October 3, 2017 8:08 AM

*To:* Xufeng Liu <[email-masked]>; Stig Venaas (svenaas) <
[email-masked]>; Liuyisong <[email-masked]>; [email-masked]
*Cc:* Stig Venaas <[email-masked]>; Guofeng <[email-masked]>; Benoit
Claise <[email-masked]>

Xufeng,

>From the tool developer:

the most recent version of libyang (0.13.73) should have improved XPath
warnings including a specific message when an identityref value was found
in a non-implemented module for easier fixing of such problems.

Regards, Benoit

Hi Benoit,

We have fixed the warnings from yumadump-pro, but the latest version of
yanglint is enforcing some rules that are not clear to us, so the yanglint
warnings have not been cleared. It would be good to get more information
from the tool’s owner.

Thanks,

- Xufeng

*From:* Benoit Claise [mailto:[email-masked] <[email-masked]>]
*Sent:* Wednesday, September 27, 2017 8:22 AM
*To:* Xufeng Liu <[email-masked]> <[email-masked]>; Stig Venaas
(svenaas) <[email-masked]> <[email-masked]>; Liuyisong
<[email-masked]> <[email-masked]>; [email-masked]
*Cc:* Stig Venaas <[email-masked]> <[email-masked]>; Guofeng
<[email-masked]> <[email-masked]>
*Subject:* Re: [Yang-multicast] Updated draft-ietf-pim-yang-09

Hi Xufeng,

Regards, Benoit

Hi All,

Attached please find the planned draft-ietf-pim-yang-09, which has
been updated to be NMDA compliant. Please review and provide comments.
If no objections, I'd submit it on Monday.

Thanks,

- Xufeng

[email-masked]

---

From: "Xufeng Liu" <[email-masked]>
Date: Tue, 3 Oct 2017 14:39:04 -0400

Hi Stig,

Yes. draft-ietf-pim-igmp-mld-yang-05 passes Yang validation cleanly.

Thanks,

- Xufeng

From: Yang-multicast [mailto:[email-masked]] On Behalf Of Stig Venaas
Sent: Tuesday, October 3, 2017 11:15 AM
To: Xufeng Liu <[email-masked]>
Cc: Benoit Claise <[email-masked]>; [email-masked]; Liuyisong <[email-masked]>; Huawei - Guo Feng <[email-masked]>; Stig Venaas <[email-masked]>
Subject: Re: [Yang-multicast] Updated draft-ietf-pim-yang-09

Hi

Does the igmp/mld draft pass validations as well? I'll check with Mike about WGLC, but would be good to get any issues fixed.

Stig

On Oct 3, 2017 06:29, "Xufeng Liu" <[email-masked] <mailto:[email-masked]> > wrote:

Hi Benoit,

Thanks. 

So we can ignore these warnings about the “non-implemented module” because we assume that the depending parent modules will be implemented, right?

Regards,

- Xufeng

From: Benoit Claise [mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Tuesday, October 3, 2017 8:08 AM

To: Xufeng Liu <[email-masked] <mailto:[email-masked]> >; Stig Venaas (svenaas) <[email-masked] <mailto:[email-masked]> >; Liuyisong <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 

Cc: Stig Venaas <[email-masked] <mailto:[email-masked]> >; Guofeng <[email-masked] <mailto:[email-masked]> >; Benoit Claise <[email-masked] <mailto:[email-masked]> >

Xufeng,

Regards, Benoit

Hi Benoit,

We have fixed the warnings from yumadump-pro, but the latest version of yanglint is enforcing some rules that are not clear to us, so the yanglint warnings have not been cleared. It would be good to get more information from the tool’s owner.

Thanks,

- Xufeng

From: Benoit Claise [mailto:[email-masked]] 
Sent: Wednesday, September 27, 2017 8:22 AM
To: Xufeng Liu  <mailto:[email-masked]> <[email-masked]>; Stig Venaas (svenaas)  <mailto:[email-masked]> <[email-masked]>; Liuyisong  <mailto:[email-masked]> <[email-masked]>; [email-masked] <mailto:[email-masked]> 
Cc: Stig Venaas  <mailto:[email-masked]> <[email-masked]>; Guofeng  <mailto:[email-masked]> <[email-masked]>
Subject: Re: [Yang-multicast] Updated draft-ietf-pim-yang-09

Hi Xufeng,

Regards, Benoit

Hi All,

 
Thanks,
- Xufeng

---

From: Stig Venaas <[email-masked]>
Date: Tue, 3 Oct 2017 14:42:32 -0700

Thanks. I've checked with Mike and will get a WGLC started for the
igmp-mld draft.

Stig

On Tue, Oct 3, 2017 at 11:39 AM, Xufeng Liu <[email-masked]> wrote:
> Cc: Benoit Claise <[email-masked]>; [email-masked]; Liuyisong
> <[email-masked]>; Huawei - Guo Feng <[email-masked]>; Stig Venaas
> <[email-masked]>
>
>
> Does the igmp/mld draft pass validations as well? I'll check with Mike about
> WGLC, but would be good to get any issues fixed.
>
>
>
> Stig
>
>
>
>
>
> To: Xufeng Liu <[email-masked]>; Stig Venaas (svenaas)
> <[email-masked]>; Liuyisong <[email-masked]>; [email-masked]
>
> warnings including a specific message when an identityref value was found in
> a non-implemented module for easier fixing of such problems.
>
> To: Xufeng Liu <[email-masked]>; Stig Venaas (svenaas)
> <[email-masked]>; Liuyisong <[email-masked]>; [email-masked]
> Cc: Stig Venaas <[email-masked]>; Guofeng <[email-masked]>
> Attached please find the planned draft-ietf-pim-yang-09, which has been
> updated to be NMDA compliant. Please review and provide comments. If no
> objections, I'd submit it on Monday.
>
>
>

---

From: Benoit Claise <[email-masked]>
Date: Thu, 5 Oct 2017 09:18:36 +0200

> Yes. draft-ietf-pim-igmp-mld-yang-05 passes Yang validation cleanly.
Yes, I confirm.

Regards, B.
>
> Thanks,
>
> - Xufeng
>
> *From:* Yang-multicast [mailto:[email-masked]] *On 
> Behalf Of *Stig Venaas
> *Sent:* Tuesday, October 3, 2017 11:15 AM
> *To:* Xufeng Liu <[email-masked]>
> *Cc:* Benoit Claise <[email-masked]>; [email-masked]; 
> Liuyisong <[email-masked]>; Huawei - Guo Feng 
> <[email-masked]>; Stig Venaas <[email-masked]>
> On Oct 3, 2017 06:29, "Xufeng Liu" <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi Benoit,
>
>     Thanks.
>
>     So we can ignore these warnings about the “non-implemented module”
>     because we assume that the depending parent modules will be
>     implemented, right?
>
>     Regards,
>
>     - Xufeng
>
>     *From:* Benoit Claise [mailto:[email-masked]
>     <mailto:[email-masked]>]
>     *To:* Xufeng Liu <[email-masked]
>     <mailto:[email-masked]>>; Stig Venaas (svenaas)
>     <[email-masked] <mailto:[email-masked]>>; Liuyisong
>     <[email-masked] <mailto:[email-masked]>>;
>     [email-masked] <mailto:[email-masked]>
>
>     *Cc:* Stig Venaas <[email-masked] <mailto:[email-masked]>>;
>     Guofeng <[email-masked] <mailto:[email-masked]>>; Benoit
>     Claise <[email-masked] <mailto:[email-masked]>>
>
>
>         the most recent version of libyang (0.13.73) should have
>         improved XPath warnings including a specific message when an
>         identityref value was found in a non-implemented module for
>         easier fixing of such problems.
>
>         We have fixed the warnings from yumadump-pro, but the latest
>         version of yanglint is enforcing some rules that are not clear
>         to us, so the yanglint warnings have not been cleared. It
>         would be good to get more information from the tool’s owner.
>
>         Thanks,
>
>         - Xufeng
>
>         *To:* Xufeng Liu <[email-masked]>
>         <mailto:[email-masked]>; Stig Venaas (svenaas)
>         <[email-masked]> <mailto:[email-masked]>; Liuyisong
>         <[email-masked]> <mailto:[email-masked]>;
>         [email-masked] <mailto:[email-masked]>
>         *Cc:* Stig Venaas <[email-masked]> <mailto:[email-masked]>;
>         Guofeng <[email-masked]> <mailto:[email-masked]>

---

From: Benoit Claise <[email-masked]>
Date: Thu, 5 Oct 2017 12:50:02 +0200

Dear all,

I implemented yanglint -i part of my daily scripts.
       -i, --allimplemented  Make all the imported modules implemented.

That improved the validation stats significantly 
<http://claise.be/IETFYANGPageCompilation.png>.
     24 YANG modules now passes validation.

I thought I would let you know

Regards, Benoit

---

From: Xufeng Liu <[email-masked]>
Date: Thu, 5 Oct 2017 13:12:56 +0000

Hi Benoit,

Thanks for the information. Much better now.

Regards,
- Xufeng

From: Benoit Claise [mailto:[email-masked]]
Sent: Thursday, October 5, 2017 6:50 AM
To: Xufeng Liu <[email-masked]>; Stig Venaas (svenaas) <[email-masked]>; Liuyisong <[email-masked]>; [email-masked]
Cc: Stig Venaas <[email-masked]>; Guofeng <[email-masked]>
Subject: Move to yanglint -i : [Yang-multicast] Updated draft-ietf-pim-yang-09

Dear all,

That improved the validation stats significantly<http://claise.be/IETFYANGPageCompilation.png>.
    24 YANG modules now passes validation.

Regards, Benoit
Xufeng,

Regards, Benoit

Hi Benoit,

Thanks,
- Xufeng

Hi Xufeng,

Regards, Benoit

Hi All,

Thanks,

- Xufeng